-PR-
  • 困ってます
  • 質問No.8832588
締切り
済み

職場内LANネットワーク上のsambaについて

  • 閲覧数268
  • ありがとう数11
  • 気になる数0
  • 回答数4
  • コメント数0

お礼率 0% (0/10)

職場内のLANが100baseだったので、1000baseに変更しました。
LAN上にはLINUXでsambaを稼動させているのですが、転送速度が思った程上がりません。5ポートスイッチングハブ1000Gbsにカテゴリ6のLANケーブルで各パソコンを接続しています。

ファイルをsambaに転送した時に40MB/秒と表示され、近辺をうろうろしています。
40MB/秒、私の解釈が間違っていなければ320Mbpsになります。1Gbpsの1/3しか転送速度が出ていない事になります。

LINUXサーバーはASUSのAT3IONT-Iをして構築しています。ギガビットLAN対応品です。

Windows7からファイルを転送している途中に、LINUXの画面でシステム→管理→システムモニタを眺めていたのですが、ネットワークの履歴で40MB/秒でグラフが100%になってしまっています。これが原因になるのでしょうか?

もし、サーバーをもっと力のあるCPUとマザーを使用して構成すると、転送速度の上昇は期待出来るのでしょうか?

例えば1Gbps対応のNICを追加で搭載し、配線を変えると速度の向上の可能性はあるのでしょうか?

今まであまり厳密にこの様な事を考えていなかったのですが、回線がインターネット回線が1Gbpsに変更になり、この様な変更・及び悩みになっています。

上記の現状の転送速度は妥当か?
私の解釈に問題はないか?
サーバー機の力不足か?
現状のサーバーのPCIソケットに1GbpsのLANポートを設けると改善の見込みはあるか?

上記の件、ご指導願えないでしょうか?

宜しくお願い致します。
  • 回答数4
  • 気になる数0

回答 (全4件)

  • 回答No.4
レベル13

ベストアンサー率 45% (630/1382)

質問の説明文から、サーバ・ネットワーク構築は慣れていない(初めて?)と解釈します。 >上記の現状の転送速度は妥当か? 普通です。おそらくノンインテリHUBですよね?、サーバもatomと低速です。サーバ側で内部転送速度を上げられませんから家庭用PC同士で接続しているのと大差ないです。 通常、ギガビットLAN単体での単純な転送速度は、20~30MB/s前後が普通です。 ギガビットが理論値というのは理解し ...続きを読む
質問の説明文から、サーバ・ネットワーク構築は慣れていない(初めて?)と解釈します。

>上記の現状の転送速度は妥当か?

普通です。おそらくノンインテリHUBですよね?、サーバもatomと低速です。サーバ側で内部転送速度を上げられませんから家庭用PC同士で接続しているのと大差ないです。
通常、ギガビットLAN単体での単純な転送速度は、20~30MB/s前後が普通です。

ギガビットが理論値というのは理解しているでしょうか?ケーブル内の信号もギガビットでは転送できません(だから理論値といいます。詳しくはWikiとか参照)。更に、サーバも低速ですからサーバー側で相当のオーバーヘッドが発生します。atomというとIOデータやBUFFALOの安いNASとおなじですからね。

>サーバーをもっと力のあるCPUとマザーを使用して構成すると

上昇はします。ただ、サーバのCPUは同時アクセス数をさばく方に使われるので、少人数でアクセスしているならばXeonにしても大差は無いです。ソフトRAIDならCPUを変更することで速度も上る可能性はありますが...。
アクセス速度を上げる場合、いろいろな方法がありますが、現在のサーバの構築内容を晒してもらわないとアドバイス出来ません。最低限、RAIDは組んでいると思いますが、どのように組んでいますか?

100M→1000Mに切り替えるのは家庭用ではよく有りますが、仕事場でこれを行うと、アクセス負荷が一気に増大(単純に10倍ですから)し、サーバが低速のCPUだと負荷増大で捌ききれなくなり、ベンチマークでは40MB/sとか出ても、実際に同時アクセスすると一気に速度が落ちたりします。

通常、サーバ側が低速な場合は100MBのLANのままにすれば速度は100Mでアクセスされるため、サーバ側の負荷も低くすみます。ネットワークを1000Mに変更する場合は、インテリHUBなどでクライアント側(もしくは、サーバの直前)の速度をコントロールし、サーバ側の負荷がいっぱいにならないようにする必要があります。
※家庭で行う場合、同時アクセスと言ってもせいぜい家族だけですし、アクセス頻度自体が低いのでインテリHUBを使う程でもないです。

そもそも、40MB/sだと不自由は有りますか?100Mだった頃に比べれば相当速度は上がっているはずで不自由はないはずです。ネットワーク構築は、まず、必要な転送速度がどれくらい必要なのかを考えて構築しないと、際限なく改善改造が必要になってしまいます。

どのような用途でどれくらいの速度が必要で、同時アクセス数はどれくらいで、予算はどれくらいかと書かないとサーバ・ネットワークシステム構築の具体的な助言はなかなか出ないと思います。
  • ありがとう数1
  • 回答No.1
レベル14

ベストアンサー率 53% (2177/4068)

自宅のネットワーク、GigaBitにしていますが…速度計測したコトはないですね。 # ちなみにサーバ側はARMだったりATOMだったり。 ただ、100BASEの時よりは早くなっています。(ARMでも) ジャンボフレームの設定とかしてみたらどうでしょうか? # ハブやその他、全てが対応している必要があります。サイズにはご注意を。 あとは…サーバ側のHDD性能が非力だったりした場合も転送速度の向上は望めない ...続きを読む
自宅のネットワーク、GigaBitにしていますが…速度計測したコトはないですね。
# ちなみにサーバ側はARMだったりATOMだったり。
ただ、100BASEの時よりは早くなっています。(ARMでも)

ジャンボフレームの設定とかしてみたらどうでしょうか?
# ハブやその他、全てが対応している必要があります。サイズにはご注意を。
あとは…サーバ側のHDD性能が非力だったりした場合も転送速度の向上は望めないかと。

使っているLinuxのディストリビューションは何でしょう?
RHELやCentOSの場合、標準で稼働しているドライバに問題がある場合があります。
http://pc.nikkeibp.co.jp/article/special/20100914/1027473/
http://orbitz-zono.blogspot.jp/2010/12/p7p55dcentos54nicrealtek-8112l.html
# 中途半端に動作するので判り難い問題です。
# ちなみに、ウチのx86系サーバも蟹チップ。rc.localのスクリプトでドライバの自動ビルドするようにしてあります。
# カーネルアップデートがあっても、再起動でドライバビルドして適用するように。

>40MB/秒、私の解釈が間違っていなければ320Mbpsになります。1Gbpsの1/3しか転送速度が出ていない事になります。

実効速度は規格ほど出ませんのでその辺りは注意された方がよいかと。
# 夜にでも自宅のネットワークの速度でも計測してみますかねぇ。
# CentOSのISOイメージのコピーにかかる時間でも計測すればいいかな。(4Gくらいあるし)
  • ありがとう数1
  • 回答No.2
レベル14

ベストアンサー率 53% (2177/4068)

と、いうワケで計測してみました。 D510MOにWD20EARSを接続したものでCentOS6.6から、Windows7のRamDiskへ CentOS-6.6-x86_64-bin-DVD1.isoをコピー。 161秒程度かかってますね。 平均で27.5MB/sってところでしょうか。 http://wiki.princo.org/?%A5%AE%A5%AC%A5%D3%A5%C3%A5%C8%BB%F ...続きを読む
と、いうワケで計測してみました。
D510MOにWD20EARSを接続したものでCentOS6.6から、Windows7のRamDiskへ
CentOS-6.6-x86_64-bin-DVD1.isoをコピー。
161秒程度かかってますね。
平均で27.5MB/sってところでしょうか。

http://wiki.princo.org/?%A5%AE%A5%AC%A5%D3%A5%C3%A5%C8%BB%FE%C2%E5%A4%CB%A4%D5%A4%B5%A4%EF%A4%B7%A4%A4samba%28smb.conf%29%C0%DF%C4%EA
こんなページもありますな。
……変更してみるか。
  • ありがとう数0
  • 回答No.3
レベル14

ベストアンサー率 53% (2177/4068)

socket options = TCP_NODELAY SO_RCVBUF=65536 SO_SNDBUF=65536 として、147秒程度。 # /proc/sys/net/core/rmem_maxには112640が。 ジャンボフレーム4k設定していたはずですが…適用されていなかった。 適用して115秒程度。(平均38.4MB/s) まぁ、このくらいで充分かなぁ…。 # /etc/sysconfi ...続きを読む
socket options = TCP_NODELAY SO_RCVBUF=65536 SO_SNDBUF=65536
として、147秒程度。
# /proc/sys/net/core/rmem_maxには112640が。

ジャンボフレーム4k設定していたはずですが…適用されていなかった。
適用して115秒程度。(平均38.4MB/s)
まぁ、このくらいで充分かなぁ…。
# /etc/sysconfig/network-scripts/ifcfg-eth0のMTU=が適用されない原因を調べてみますかね…。

サーバ側で
dd if=CentOS-6.6-x86_64-bin-DVD1.iso of=/dev/null
したところ、 102MB/sが最速。(bs=512にて。HDD自体は4Kセクターだったハズだけど)
なので、どんなに頑張ってもこの速度は越えないですな。ウチの環境では。
  • ありがとう数1
  • 回答数4
  • 気になる数0
このQ&Aで解決しましたか?

関連するQ&A

-PR-
-PR-
このQ&Aにこう思った!同じようなことあった!感想や体験を書こう
このQ&Aにはまだコメントがありません。
あなたの思ったこと、知っていることをここにコメントしてみましょう。

その他の関連するQ&A、テーマをキーワードで探す

キーワードでQ&A、テーマを検索する
-PR-
-PR-
-PR-

特集


-PR-

ピックアップ

-PR-
ページ先頭へ