OKWAVEのAI「あい」が美容・健康の悩みに最適な回答をご提案!
-PR-
締切り
済み

HPにあるはずの音楽が聞こえないのです。

  • すぐに回答を!
  • 質問No.166283
  • 閲覧数147
  • ありがとう数3
  • 気になる数0
  • 回答数7
  • コメント数0

お礼率 23% (3/13)

HPに流す音楽を変えようと思い、HPビルダーver.6を使って、アップロードしたのですが、自分のPCでは音が全く聞こえないのです。以前はちゃんと聞けたのですが。なおかつ、FFFTPでもアップしてみたのですが、これも自分のPCではきこえませんでした。ソースで確認したんですが、ソースにもファイル名がのってませんでした。(知り合いに、同じ場所にいってもらったら、ちゃんと鳴っているということだったんですが。自分のPCで普通に再生する場合には問題なく聞こえるのですが。)また、知り合いのHPでもmidiだとおもうのですが、ページによって聞けたり聞こえなかったりします。ビルダー内でプレビューがあるのですが、その時からすでにファイルが表示されく、音も聞こえません。しかし、転送ツールで確認すると、アップされているようです。PCになにかしらの問題があるのでしょうか?
IE6を使っていますが、それに問題があるのかと思いインストールし直しましたが
状況は変わりませんでした。またHPビルダーもインストールしなおして見ましたが変わりませんでした。PCはGatewayで、Windows98です。
通報する
  • 回答数7
  • 気になる
    質問をブックマークします。
    マイページでまとめて確認できます。

回答 (全7件)

  • 回答No.2
レベル13

ベストアンサー率 46% (402/864)

まず、確実に言えることなんですが、ホームページビルダーのプレビューは、自分の保存したファイルでプレビューしているだけなので、外部(他のサーバ)のアドレスに対しての実行はされません。 ですから、プレビューで音が出ないのは、間違いではないし、ビルダーのせいでもありません。 あと、ソースで確認したというのは……。 ビルダーで? それともアップしたページをブラウザを通して見た場合ですか? どちらにしろ ...続きを読む
まず、確実に言えることなんですが、ホームページビルダーのプレビューは、自分の保存したファイルでプレビューしているだけなので、外部(他のサーバ)のアドレスに対しての実行はされません。
ですから、プレビューで音が出ないのは、間違いではないし、ビルダーのせいでもありません。

あと、ソースで確認したというのは……。
ビルダーで? それともアップしたページをブラウザを通して見た場合ですか?
どちらにしろ、他のかたが聴けるというのであれば、ソースに無いわけはないのですが。

BGSOUNDはIE専用タグですので、ネットスケープで閲覧すると聴けない……という可能性もありますがどうでしょう?
これなら、IEの人には聴けてもネットスケープの人には聴けないので、人によって聴けなくなるということも充分考えられますが。

ただ、以前は聴けたということですので……。
もしかしたら、MIDI用のプラグインがおかしくなっている(もっとも、それなら全てのMIDIがダメですけど)とか。
他に、サウンド(IEの場合)のMIDIアウトの音量が落ちているというのはありませんか?
補足コメント
o-ko

お礼率 23% (3/13)

ビルダー内でのプレビューでは音は鳴らなかったんですか。
記憶違いだったのか鳴ったような気がしていたので勘違いでした。

ソースの確認でっていうのは・・・
下記投稿の補足を読んでいただけたらわかると思うのですが、その自分のHPと違うところにアップしたところのページを実際IEを起動して、ソースで見たんです。そしたら、そのアップしたファイル名があったんですね。でも、音は鳴ってなかったんです。そのページにアップしてるのだから鳴るはずですよね?

midiアウトの音量というのはどういうことなのでしょうか?
もうすこし詳しくわかりやすく教えていただけないでしょうか?
ちなみにmidiなどの音楽ファイルは、自分のPCでは、Winampで再生されます。
投稿日時 - 2001-11-11 11:09:24
  • 回答No.1

状況がいま一つ分からないのですが、以下を確認してみて下さい。 スタートメニュー → 設定 → コントロールパネル → インターネットオプション → 詳細設定 と見て、下の方にある "Web ページのサウンドを再生する" にチェックは入っていますか? また、<BGSOUND> と <EMBED> どちらで再生するようになっているのでしょうか? ...続きを読む
状況がいま一つ分からないのですが、以下を確認してみて下さい。

スタートメニュー → 設定 → コントロールパネル → インターネットオプション → 詳細設定
と見て、下の方にある "Web ページのサウンドを再生する" にチェックは入っていますか?

また、<BGSOUND> と <EMBED> どちらで再生するようになっているのでしょうか?

再生しようとしているファイル形式等は何ですか?
>知り合いのHPでもmidi ~
とありますが、ご自分のHPで流したい曲も .mid という事なのでしょうか。


以上、参考程度に。 m(_ _)m
補足コメント
o-ko

お礼率 23% (3/13)

コンパネを見てみましたが、再生するにチェックが入ってました。
HP使いたいのは.midで、知り合いのHPに流れてるのも.midなんです。

すいません。なんか説明が大雑把すぎましたね。
もう少し詳しく説明しますと。
自分の今持ってるHPには音楽ファイル(.mid)はアップできないんですね。
それで、他にスペースかりてそこにアップしてそこのURLを<BGSOUND>で
貼りつけるんですけど。その、HPビルダー内とアップした先の所だけ音が聞こえないんです。で、聞こえないまま、そのURLを自分のHPに貼りつけてはみたんですが
実際HPでは音が鳴っていて聞こえました。
投稿日時 - 2001-11-10 23:18:15
  • 回答No.3
レベル14

ベストアンサー率 68% (2350/3407)

自分のPCでは鳴らしたいページを開いても鳴らないけど,他の人のPCでは鳴るのですね。 また,私のPCではHPビルダーver.6のプレビューでもMIDIファイルを再生できました(今HPビルダーver.6を起動して確認したところです。ちゃんと,サーバーから読み込みました)ので,疑うのは,オーディオの設定ではないでしょうか? でね,お使いのPCのMIDI環境を,過去に削除したものがあればそれも含めて書いても ...続きを読む
自分のPCでは鳴らしたいページを開いても鳴らないけど,他の人のPCでは鳴るのですね。
また,私のPCではHPビルダーver.6のプレビューでもMIDIファイルを再生できました(今HPビルダーver.6を起動して確認したところです。ちゃんと,サーバーから読み込みました)ので,疑うのは,オーディオの設定ではないでしょうか?
でね,お使いのPCのMIDI環境を,過去に削除したものがあればそれも含めて書いてもらえないでしょうか?
例えば,外部MIDIを使用してたけど今は外部MIDIをはずしているとか,ソフトMIDIをアンインストールした〈この場合はその方法も〉とか,または,以前ソフトMIDIの体験版を入れたことがあるなどです。
補足をお願いします。
補足コメント
o-ko

お礼率 23% (3/13)

MIDI環境といえるようなものは・・特別になんにもしてないと思います。
自分のPCには、QuicktimeとWinampがあるんですけど。
それ以外には特別にはないです。
削除もしてないです。
投稿日時 - 2001-11-12 18:41:56
  • 回答No.4
レベル13

ベストアンサー率 46% (402/864)

すみません、補足です。 ビルダーの件ですが、「ネットに接続した状態」でプレビュー画面にすれば、外部サーバのMIDIも鳴ります(あたりまえのことで申し訳ありません)。 ソースのほうはちょっと混乱してしまったのですが。 最初の御質問では「ソースにもファイル名がのってません」で他のかたの環境では「鳴っているということだった」そうですが……。 そうではなくて、MIDIを置いてあるサーバをブラウザを通し ...続きを読む
すみません、補足です。
ビルダーの件ですが、「ネットに接続した状態」でプレビュー画面にすれば、外部サーバのMIDIも鳴ります(あたりまえのことで申し訳ありません)。

ソースのほうはちょっと混乱してしまったのですが。
最初の御質問では「ソースにもファイル名がのってません」で他のかたの環境では「鳴っているということだった」そうですが……。
そうではなくて、MIDIを置いてあるサーバをブラウザを通してみたら「アップしたファイル名があった」でも「音は鳴ってなかった」んですね?

ソースで確認出来るということは、MIDIを置いてあるサーバでもブラウザ上から鳴らせるようにページを作ってあるわけですね。
それで音が鳴らないなら、ソースが間違っているか、MIDIファイルが無いか、どちらかの可能性がありますが、直接転送ツールから存在が確認されているということと他のかたが聴けるということから、いずれの可能性も消えますので、o-koサマのPCの問題かもしれませんね。

ところで、Winampですが、もしかして、音が聴けなくなる直前にインストールしたなんてことはありませんか?
実は私もWinampを入れたら、勝手に全ての関連付けを書き換えられてしまい、ページに組み込んだMIDIが鳴らなくなってしまった経験があるんです(私の場合、特に必要ではなかったのでWinampをアンインストールして、関連付けを修正しましたが)。

個別のPC環境の問題だとしたら……。
・「コントロールパネル」→「マルチメディア」で、関係するデバイスに以前と違っているところがないか確認して下さい。
MIDI用のプラグインやソフト(音源)があれば、アクティブになっているか確認して下さい。
・「ボリュームコントロール」で音量が落ちていないか確認して下さい(ボリュームコントロールはタスクバーに出ていなければアクセサリに入っていると思います)。
補足コメント
o-ko

お礼率 23% (3/13)

reisさん、何度もありがとうございます。
(すいません。バカなので、変なこといってるかもしれませんが)
補足についてなんですけど、ちゃんと転送されてて、それをソースでも確認できてたんですけど、音は聞こえなかった。そのとおりです。

音が聞けなくなる直前のインストールというのはないです。
インストールして何ヶ月かたちますが、その間midiファイルはWinampで聞けてましたし、それで、何回かHP上にアップし、ちゃんと自分でも音は確認できていましたので(Winamp Media Filesと書かれていたような気がします。)

もしかしたらQuicktimeとWinampがいるというのがなにか関係ありますでしょうか?
midi用のプラグインというのは、特にないと思います。
ボリュームコントロールも確認しましたがボリューム等がしぼられているなどの
問題はありませんでした。
メルチメディアのデバイスも(普段そのようなところを見ないものなのであやしいですけど)違ってるところはなかったように思います。
投稿日時 - 2001-11-12 18:45:03
  • 回答No.6
レベル13

ベストアンサー率 46% (402/864)

やはり、エラーあったのですね。 ディスプレイが真っ黒になって勝手に再起動……というのは、おだやかじゃない気がします。 それがどう関係しているかはわかりませんが、もしかしたら何か関連するところでエラー起こしている可能性は無いとも言えませんね。 IEの再インストールはエラーの後なんですよね。 ちなみにWinampって、単体で入れましたか(ネットスケープ入れても付いてくるはずですが……)。 エ ...続きを読む
やはり、エラーあったのですね。

ディスプレイが真っ黒になって勝手に再起動……というのは、おだやかじゃない気がします。
それがどう関係しているかはわかりませんが、もしかしたら何か関連するところでエラー起こしている可能性は無いとも言えませんね。

IEの再インストールはエラーの後なんですよね。
ちなみにWinampって、単体で入れましたか(ネットスケープ入れても付いてくるはずですが……)。
エラー後、Winampの再インストールはしてますか?
WinampのMIDIプラグインは入ってますか?

全てが聴けないわけではないということなのでこれは関係ないとは思うのですが、出来れば音源リセットをやってみて下さい(これは音がおかしくなった時の対処方法ですし、なんらかの音源を入れてある場合に有効なのですが……)。
どこか適当なサーチで「MIDI 音源リセット」で検索すると、いくつもあがります(音源リセット用MIDIデータ……というより信号……を再生するだけです)。
WinampはPCに複数の音源がある場合でも音源を自動的に切り換える機能はないそうですので、何かのMIDIファイルが要求した音源に応えられないということもありそうな気がしますので。
これでリセットして、それでも問題があるようなら、Winampには音源を自動選択するプラグインもあるそうなので、それを入れてみるというのも方法かもしれません。

お聞かせいただいた現状からすると、おそらく問題はPC環境だと思いますので……。
各デバイス、プラグイン、音源もしくはサウンドカード等、すべてに異常がなければ、とりあえず、関連するものを再インストールしてみる……くらいしか思いつきません(申し訳ないです、こんなに長々とやりとりしたあげく役に立てなくて)。
お礼コメント
o-ko

お礼率 23% (3/13)

Winampもインストールしなおしてみましたが、やはり改善されませんでした。
MIDI音源リセットもだめでした。(信号の再生すらできてないようです)
最後の手段でWindowsを再インストールしてみることにします。
本当にありがとうございました。
投稿日時 - 2001-11-14 19:10:31
  • 回答No.5
レベル13

ベストアンサー率 46% (402/864)

すみません、再確認させて下さい。 MIDIを置いてあるサーバのほうですが、 「転送ツールで、サーバ内にファイルの存在を確認出来る」、これは間違いないですね? 「そのページでもMIDIを再生するようにソースが書いてある」、このソース、出来れば拝見したいんですが。 「他の人は聴けた」、これも間違いないですか? MIDIを置けないサーバのほうで、 「ソースは間違っていない」? 「他の人には ...続きを読む
すみません、再確認させて下さい。

MIDIを置いてあるサーバのほうですが、
「転送ツールで、サーバ内にファイルの存在を確認出来る」、これは間違いないですね?
「そのページでもMIDIを再生するようにソースが書いてある」、このソース、出来れば拝見したいんですが。
「他の人は聴けた」、これも間違いないですか?

MIDIを置けないサーバのほうで、
「ソースは間違っていない」?
「他の人には聴ける」?

まさかとは思うのですが、MIDIを置いてあるサーバってCOOLやジオシティーズだったりはしませんよね?(最近ここが外部からのファイル呼び出しを出来ないようにしてしまったので、かなり混乱が起きたんですけど)
だとしても、他の人が聴けるのと、置いてあるサーバで聴けないということの説明がつかないんですけど……。

「Quicktime」と、MIDIに関するプラグインなんですが。

普通はYAMAHAのMIDPLUGなんかを入れる場合が多いんです。で、そうするとたいてい一緒にYAMAHAのソフトシンセなんかも入れると思うんです。
ただ、最近の「Quicktime」を後から入れると、YAMAHAのほうとバッティング起こします。この場合はYAMAHAのMIDPLUGをもう一度インストールすることで解決します。

で、o-koサマの場合、最初からMIDI関係のプラグインに心当たりがなくて、しかもWinampで再生ということですので……。
私はWinampをさっさと削除してしまったので詳しいことまではわかりませんが、MIDI関連のプラグインの役割と、音源自体、もしくはサウンドカードの制御を、Winampがやっていると思うんです。
私の場合(先にMIDPLUGがあったので)MIDPLUGのほうが変更されたファイルを見失ったかたちで問題が起きたわけですが、o-koサマがもともとWinampを使用していることから、そういう問題が起きるということはないと思います。

あれ? でもサーバにアップしたファイルって、拡張子は.MIDですか? Winamp Media Filesというファイル名にされたものって拡張子も変わってませんか?(ちょっと自信ないんですが)
だとしたら、BGSOUNDやEMBEDのタグではファイルを認識しないなんてこともあるかもしれません(……けど、いままで出来ていたというのなら、きっと対応してるかたちなんですよね?)。
でも、拡張子が変更されているようなら、.midに修正して、もう一度アップしてみるというのも可能性のひとつかもしれません。

……マルチメディア関連のデバイスもアヤシイところがないのですよね?
MIDIが鳴らなくなったころに何か、インストール、アンインストール、もしくはPC自体に妙なエラー等はありませんでしたか?
他のサイトでMIDI、その他の音楽ファイルを聴いた時、エラーが起きたり、音がヘンになったということもないでしょうか?

このヘンの手がかりがないともう何とも言えないのですが……。
ホントはo-koサマのサイトも確認させていただきたいくらいなんですが規約でダメですので……(個人情報の開示にあたらないギリギリのセンで、検索で探せるヒントとかあります?)。
補足コメント
o-ko

お礼率 23% (3/13)

本当に何回もありがとうございます。

「転送ツールで、サーバ内にファイルの存在を確認出来る」
間違いないです。確認しましたので。
そして、<EMBED src="still_love.mid" autostart="true" hidden="true" loop="true">アップしたページにあるソースのコピーです。
実際自分のHPでは、<BGSOUND SRC="アップした先のURL/still_love.mid">として
貼りつけています。アップした先はジオシティーズでもCOOLでもありません。
外部からファイルが呼びだせないという所ではないです。
それとやはり私以外の人には聞こています。

そういえば、今更ながらに思い出したことがあります
これがどうなのかはわからないのですが。。
midiを探しに、あちこちのHPうろちょろしてたんですが、突然何の操作もしてないのにディスプレーが真っ黒になり勝手に再起動かけられたんです。
あと、同じ時だったかどうかも記憶してないんですが、IEからエラーが出たんですね。Windowをいくつも開けていたからかなぁと思ったりなんかもしたんですけど
(3つぐらい開いてたんです(--;A))エラーの内容は覚えてないんですが、このエラーを報告する?みたいなのが出ていたように覚えてます。肝心の内容は覚えてないんです。(なんとも情け無い)そして、その直後とはいいがたいのですが・・
少なくとも後にこのようなことになってしまいました。

それで、今ちょっとmidiを探しにうろちょろしてみたんですけど
BGMがあきらかに再生されているページなのに全く聞こえませんでした。
でも、全てが全く聞こえないというわけでもないんですよね。
そのサイトは完全にどこのページにいっても聞こえなかったんですけど
一部のHPの一部のページだけ音が聞こえる。そんな感じです。
投稿日時 - 2001-11-13 19:38:50
  • 回答No.7
レベル14

ベストアンサー率 64% (2667/4137)

<bgsound>タグの再生では、 DirectXが使われるので、 スタート→「ファイル名を指定して実行」をクリック。 dxdiag と入力して、「OK」をクリック DirectX診断ツールが起動されます。 起動と同時にレジストリの再構成が開始されます。 問題があればダイアログが出ます。 私の場合、これで直りました。 でも、いろいろいじっているみたいなので、 ...続きを読む
<bgsound>タグの再生では、
DirectXが使われるので、

スタート→「ファイル名を指定して実行」をクリック。
dxdiag と入力して、「OK」をクリック

DirectX診断ツールが起動されます。
起動と同時にレジストリの再構成が開始されます。
問題があればダイアログが出ます。

私の場合、これで直りました。

でも、いろいろいじっているみたいなので、
そちらで直るか自信がないです。
このQ&Aのテーマ
このQ&Aで解決しましたか?
関連するQ&A
-PR-
-PR-
あなたが体験したトラブルや解決方法を共有しませんか?
このQ&Aにはまだコメントがありません。
あなたの思ったこと、知っていることをここにコメントしてみましょう。

その他の関連するQ&A、テーマをキーワードで探す

キーワードでQ&A、テーマを検索する
-PR-
-PR-
-PR-

特集


いま みんなが気になるQ&A

関連するQ&A

-PR-

ピックアップ

-PR-
ページ先頭へ