• 締切済み
  • すぐに回答を!

逆IPマスカレード

LINUXkernel2.2.12-32(REDHAT)にipmasqadm入れようと したら"######unpacking of archive failed: cpio: Bad magic”と出てインストール出来ません。何故?どなたか教えて下さい。よろしくお願い致します。

共感・応援の気持ちを伝えよう!

  • 回答数1
  • 閲覧数210
  • ありがとう数9

みんなの回答

  • 回答No.1
  • tscom-m
  • ベストアンサー率44% (13/29)

「入れようとしたら」というのは、何をなさったのでしょうか? 詳細を補足ください。

共感・感謝の気持ちを伝えよう!

質問者からのお礼

RESありがとうございます。詳しく申しますと・・ #rpm -ivh ipmasqadm-0.4.2-2.i386.rpm とパッケージのインストールをしようとしました。 説明不足でした。申し訳ありません。 後、色々調べておりましたら、”rpm2cpio”なるコマンド がある事が分かりました。#man rpm2cpioで見てみたん ですがどうも良く分かりません。合せてお願い出来ますで しょうか?

関連するQ&A

  • kernelのバージョンアップについて

    RedHat7.3をインストールしております。 今回kernelのバージョンをアップしようと思い試行錯誤しながら行っておりますが、上手くいきません。何卒よろしくご指導の程お願いいたします。 rpm -qa | grep kernel でインストールされいるバージョンと種類を確認しました その結果 kernel-pcmcia-cs-3,1,27-18 kernel-2.4.18-3 が表示されましたので ダウンロードサイトより  kernel-2.4.20-20.7.i386.rpmをダウンロードして rpm - U kernel-2.4.20.7.1386.rpm でインストールしたところ error:unpacking of archive failed on file /boot/system.map-2.4.20-20.7;3fa5114c:cpio:MD5 sum mismatch と表示され上手い行きません どこが悪いのでしょうか、またどのようにすればバージョンアップできるのでしょうか よろしくお願いいたします。

  • Redhat-Linux7.1J で「zlib」パッケージを正常にインストールしたい

    Redhat-Linux7.1JのOSを導入完了しています。 Redhat-Linux7.1JのCDROM(1枚目)から 「zlib」パッケージをインストールしようとすると、 次のようなエラーがでて、結果的にはインストールできません。 このzlibがインストールできないと、 あるパッケージがインストールできないので、とても困っています。 どうすれば、「zlib」パッケージを正常にインストールできるでしょうか? 教えてください! <コマンド>  # rpm -ivh zlib-1.1.3-22.i386.rpm <実行結果> Preparing... #######################[ 100%] 1:zlib エラー: unpacking of archive failed on file /usr/share/doc/zlib-1.1.3/README: cpio: MD5 sum mismatch

  • 起動時に"kmem_alloc:Bad slab magic"...

    初めまして19770209と申します。 早速なのですがReHat Linux7Jを IBM Thinkpad i1200へインストールをしたのですが、 Linux起動時に下記の現象が起きてしまいます。 ■現象: starting pcmcia kmem_alloc:Bad slab magic(corrupt)(name=size-128) kmem_alloc:Bad slab magic(corrupt)(name=size-128) kmem_alloc:Bad slab magic(corrupt)(name=size-128) kmem_alloc:Bad slab magic(corrupt)(name=size-128) : kmem_alloc:Bad slab magic(corrupt)(name=size-128) "kmem_alloc:Bad slab magic(corrupt)(name=size-128)"が ダラダラと表示されてしまい止まりません。 ■環境 kernel:kernel-2.2.16 pcmcia:pcmcia-cs-3.1.25 どなたか解決策を教えてください。 宜しくお願いします。

  • kernel2.6.*に対応しているディストリビューション

    Linuxのkernel2.6.*に対応しているディストリビューションを調べています。 出来ればRedHat LinuxかVine Linuxが良いのですが、kernel2.6.*に対応しているのでしょうか? よろしくお願いいたします。

  • Nistnetのインストールと使い方

    御忙しい中すいません。質問させていただきます。 現在NistnetをLinuxサーバにインストールをしてエミュレートを実施したいと思います。是非、インストールと使用方法をご教授いただきたくお願い致します。 OS:RedHat Enterprise Linux AS 3.0 Kernel:v2.4.21-15.0.4

  • RedHatLinux7.0からのアップグレードの方法は?

    RedHatLinux7.0を使っています。 これを8.0、9.0などへ、そのまま、アップしたいのですが。 こんな事が本当にできるのでしょうか? 実は、http://www.okweb.ne.jp/kotaeru.php3?q=624344で質問が既に出ており、astronautさんの回答を参考に、apt-getを何とかインストールし、/etc/apt/source.lstのrpmの物をコメントアウトするところまではやりました。 しかし、RedHatのerattaなどを見ても、7.0は7.0の物で、例えば8.0は8.0のもので括られていたような感じがするので、7.0の動作下で、8.0や9.0の物をインストールしてうまく行くのかな、とも思ってしまいます。 RedHatLinux7.0から例えば8.0へアップする時にkernelも違うと思うので、これもなにか不安です。 7.0の自分の物は、kernel-2.2.16-22で、確かそれ以上では2.4.xだと思いました。 これを例えば8.0のkernel-2.4.xのもの等を取ってきて、rpm -Uvh した場合、みんな正常に動いてくれるのか、疑問です。 また別の方法で、雑誌等についているCDROMからでもそのまま9.0などへアップグレードは可能なのでしょうか? (インストール時に、インストールか、アップグレードかを選択する画面があったような気もします) この様な質問するのは、RedHatの7.0のerattaが終ってしまったからです。 動かなくなってしまった場合が恐ろしいので、ミラーリングでHDDをバックアップした後にやろうと思います。 Webでいろいろ調べてみたりしましたが、分からないので、何卒、宜しくお願い致します。

  • gcc-3.2-7のインストールについて

    Linux初心者です。 LinuxはRedHat7.3を使用しています。 gcc-3.2-7.i386.rpmをインストールしようとしていますが、依存性の欠如エラー ・kernel-headersはglibc-devel-2.2.93-5に必要 ・kernel-headers 2.2.1はglibc-devel-2.2.93-5に必要 ・glibc 2.2.93はglibc-devel-2.2.93-5に必要 が出ます。 これらのモジュールはどこで探せばいいのでしょうか? モジュールダウンロードのよいサイトがあれば教えてください。ちなみにRedHatのホームページには見つかりませんでした。

  • turbolinux とredhatの違い

    turbolinuxとredhatの違いを教えてください。 間違えて、turbolinuxというdistributionを買ってしまいました。(というよりLinuxはkernelで多くのdistributionがあることを後で知りました) 私の周りの人はredhatを使っているようです。 何が違うのでしょうか?

  • RedHatLinux7.1のインストール

    皆様 VMware WorkstationにRedHatLinux7.1をインストールしました。 その後のVMwareToolsインストール作業にて問題が発生しておりヘルプをお願いします。 VMwareToolsのインストールには、LinuxのGCCとmakeとkernel-develが必要のようです、 どこから入手可能でしょうか。 インストール方法含めてご教授頂けますと助かります。 皆様のお知恵をお貸し下さい。

  • Xが起動できません

    環境は DELL D600 RedHat Linux 7.2 においてkernel-source-2.4.20にてkernel再構築後、eth0を認識させるためにドライバをインストールしました。 上記の時点でeth0を認識できましたので、Xを起動させたく思いATIからLinux用のドライバをダウンロード後、インストールしました。ここまでは、エラー無しでした。 以下、私が検証した事を書きます。 RedHat Linux9.0のCDからXFree86-4.3.0.rpmを適用後だと動きます。(KDEだけですが)ですが、依存関係かなにかでkernelを書き換えられてしまうのでこの方法は使いたくありません。 startxの中で /etc/X11/xinit/xinitrc /etc/X11/xinit/xserverrc を起動しているみたいなんですが、この場所にxserverrcなんてないんですが、これが原因なのでしょうか エラーメッセージは以下のとおりです。 execve failed for /etc/X11/X(errno 2) give up xinit: No such file or directory(errno 2):unable to connect to X server xinit: No such process (errno 3): Server error.