• ベストアンサー
  • 暇なときにでも

Debian9でupdateできない

Sudo apt updateができないのでSudo apt autoremoveを試しましたが画像のエラーが出ます。 Fix broken installも試しましたがエラーになります。 どのように対処したら良いでしょうか?

共感・応援の気持ちを伝えよう!

  • 回答数1
  • 閲覧数44
  • ありがとう数0

質問者が選んだベストアンサー

  • ベストアンサー
  • 回答No.1
  • tkf-
  • ベストアンサー率59% (635/1064)

公式以外のリポジトリを追加しているのであれば、いったん削除(コメントアウト)したうえで、apt update/apt upgradeしてみてはいかがでしょうか。

共感・感謝の気持ちを伝えよう!

関連するQ&A

  • Debianのインストール

    Debianを標準システムユーティリティだけを選択してデスクトップ環境なしでインストールしました。 インストールが完了したあとコマンドラインでsudo apt updateやsudo apt installをしてもエラーが出て使えません。 どうすればなおりますか?

  • Debianのインストール後のトラブル

    Debianを標準システムユーティリティだけを選択してデスクトップ環境なしでインストールしました。インストール後にsudo apt updateやsudo apt installなどが使えません。 インストール時にはwifiに繋がっていたんですがひょっとしたらネットに繋がってないんでしょうか? エラーメッセージの写真を添付します。

  • apt upgradeでエラー

    apt upgradeで以下のエラーが出ます 以下のパッケージは満たせない依存関係があります。 libssl1.1:破壊:python-boto(<2.44.0-1.1)しかし、2.44.0-1はインストールされています。 E:未解決の依存関係です。apt&#8212;fix broken installを実行してみてください。 でもapt&#8212;fix broken installもエラーになります。 解決方法ありますでしょうか?

  • apt-get updateの意味

    このページ http://www.miloweb.net/pastbbs/0009/2799.html に、 # apt-get update # apt-get install samba でうまくインストールされましたが・・・ # apt-get update # apt-get install samba swat では・・・ と書いてあります。 何かをインストールする前に apt-get update を実行しているようなんですが、これには意味があるんですか? installする前にはupdateした方がよいのでしょうか?

  • Debian(玄箱、woody)についてですが。

    APTリポジトリが古いので、 stableを ・deb ftp://ftp.dti.ad.jp/pub/Linux/debian stable main contrib ・deb ftp://ftp.dti.ad.jp/pub/Linux/debian-jp stable-jp main contrib にして、 #apt-get update #apt-get install ntpdate したところ、まず、「glibc」を今インストールするか、 後でするか、 っていう質問画面が出てきて、英語でよく分からなくて・・・ 「X11」とか怪しいこと書いてあったような気がしたけど、入れとく分には 問題ないだろと、yesを選択したわけですが・・・ なんと、installがErrorで強制終了という素晴らしい事態に・・・_ _;; それで、もう1回 #apt-get install ntpdate したら、なんと Segmentation faultsts... 0% # ・・・いや、これって・・・? 何かやっているときに上から「Segmentation fault」の 文字列が重なったとしか・・・ インターネットで検索しました。しかし、 大体起こるのは、「apt-get update」の時だそうな。 しかも、 #apt-cache show ntpdate でも、上に同じ。 どうやらapt自体に何か問題が起きたらしい。 それ以外のコマンドは全く問題なし。 プログラミングの時なら何となく分かりますけど・・・これはどうしろと? 原因が分かる方、コメントをよろしくお願いします。 これで原因が分からなかったら Debian入れ直し・・・ しかもいまsamba入ってないからファイル転送が・・・うぐぉ!? まだ玄箱のなかにtmpimage.tgzがあると思うので、大丈夫だろうとは思いますけど・・・ 緊急です!!よろしくお願いします orz 補足ですが、 最初の「#apt-get update」ですが、 正確には「#apt-get update -o APT::Cache-Limit=16777216」 です。 ^^;; 関係ないと思いますが一応。 「Segmentation fault」はメモリ参照異常のようですね・・・ この文字列と重なっていた「*sts...0%」は、 「get lists」だと思いました。 リストを取得するときにエラーが起こるそうです・・・

  • TeraTerm Proで、接続ができない。

    TeraTerm ProでFodoraサーバーにアクセスを試みています。 ホストを入力する画面の後、すぐに「接続が拒否されました」と出て、接続ができません。 自宅サーバーなので、サーバー側で変更をしようとして、行き詰っています。 http://www.jitaku-server.net/ssh_teratermpro.html ここのHPを参考にしているのですが、 >apt-get install openssh ←OpenSSHのインストール をすると、 ---------- # apt-get install openssh パッケージリストを読みこんでいます... 完了 依存情報ツリーを作成しています... 完了 * openssh は既に最新バージョンがインストールされています。 以下の問題を解決するために 'apt-get --fix-broken install' を実行する必要があるかもしれません: 以下のパッケージは解決できない依存関係を持っています: scim-libs#1.4.4-9: 依存: libstdc++-20060203.so.7 それをインストールすることが できません 依存: libstdc++-20060203.so.7(CXXABI_1.4) それをインストー ルすることができません 依存: libstdc++-20060203.so.7(GLIBCXX_4.2) それをインストールすることができません E: 未解決の依存情報です。'apt-get --fix-broken install' を実行してみてください( 又は解決パッケージを明示してください)。 --------------------- と出ます。「'apt-get --fix-broken install' を実行してみてください」とあるので、やってみると、 --------------------- # apt-get --fix-broken install パッケージリストを読みこんでいます... 完了 依存情報ツリーを作成しています... 完了 依存関係を解決しています... 完了 以下のパッケージが削除されます: scim-libs#1.4.4-9 (1.4.4-9) アップグレード: 0 個, 新規インストール: 0 個, 削除: 1 個, 保留: 0 個 0B のアーカイブを取得する必要があります。 展開後に 2118kB が解放されます。 続行しますか? [Y/n]y 変更を適用しています... 準備中... ########################################### [100%] /usr/bin/update-gtk-immodules: line 27: /etc/gtk-2.0/i386-redhat-linux-gnu/gtk.immodules: そのようなファイルやディレクトリはありません error: %postun(scim-libs-1.4.4-9.i386) scriptlet failed, exit status 1 W: トランザクション処理中にエラーが発生しました ------------------ となり、進むことができません。 対処方法を探したのですが、有効なのが見つからなかったので、質問させていただきます。 分かる方、よろしくお願いします!

  • ubuntu アップグレードしてシャットダウン

    ubuntu で一度に、アップデートして、アップグレードして、シャットダウンするコマンドの記述を教えてください。 sudo apt-get update ; sudo apt-get upgrade -y ; sudo shutdown -h now このコマンドだと、sudo が何度も出てきて冗長だし、shutdown コマンドのころには、最初にsudoを実行した時のパスワードの有効時間が超過して再度パスワードを求められた気がします。 sudo (apt-get update ; apt-get upgrade -y ; shutdown -h now) このように()でくくったら文法エラーになった気がします。

  • Debianでapt-get updateでエラー

    数年前に玄箱(玄箱HGではありません)にDebian Sargeをインストールしました。 それを etch、lenny、… とupgradeするために、先ず apt-get updateコマンドを実行しましたが、下記のエラーとなります。 /etc/apt/sources.list の内容を色々変更しましたが、同じエラーなります。 対処方法をご教示して頂きたくよろしくお願い致します。 E: Unable to parse package file /var/lib/apt/lists/ftp.dti.ad.jp_pub_Linux_debian_dists_stable_main_binary-powerpc_Packages (1)

  • Ubuntu 14.04 LTS 日本語化

    Vmware上で Ubuntu 14.04 LTS をインストールしてみたのですが Gnomeの日本語化がうまくいきません。 インターネットで検索して language-pack-gnome-ja Region & Language wget -q https://www.ubuntulinux.jp/ubuntu-ja-archive-keyring.gpg -O- | sudo apt-key add - wget -q https://www.ubuntulinux.jp/ubuntu-jp-ppa-keyring.gpg -O- | sudo apt-key add - sudo wget https://www.ubuntulinux.jp/sources.list.d/raring.list -O /etc/apt/sources.list.d/ubuntu-ja.list sudo apt-get update sudo apt-get upgrade sudo apt-get install ubuntu-defaults-ja などいろいろやってみたのですがうまくいきませんでした。 他に考えられる対処方法はありますか? 何が原因かご存知でしたら、教えてください よろしくお願いします。

  • Debian etchのaptコマンドで

    apt-get install とaptコマンドを実行すると ide:failed opcode:unknown(覚え書きですんません)などとエラーが出ます。 PCがだいぶ熱をもってたからかもしれないですが これは休ませたら直るでしょうか?