-PR-
解決済み

ネットワーク接続・設定方法

  • すぐに回答を!
  • 質問No.856679
  • 閲覧数123
  • ありがとう数2
  • 気になる数0
  • 回答数2
  • コメント数0

お礼率 37% (9/24)

今Intel版Solaris8をインストールしています。
SoftwareCD1,2、LANG_CDのインストールも終わりました。
そこでネットワークの設定を始めましたが、一向に外部との
接続が出来ません・・・。ちなみにNICは、IntelPro1000/MT Desktopです。

ネットワークの設定も
IP Address(192.168.100.100)、
SubnetMask(255.255.255.0)、
/etc/netmasks(192.168.100.100 255.255.255.0)、
/etc/defaultrouter(192.168.100.1)、
/etc/hosts(192.168.100.100 buzz)、
/etc/nodename(buzz)、
/etc/hostname.e1000g0(buzz)を設定しています。
ただし、resolv.confとnsswitch.confはいじっていません。
IPアドレスの設定は、ドライバをpkgaddした後、NICを追加し、sys-unconfigで設定しました。
OS的にはNICをちゃんと認識しているようです。
[ifconfig -a]でも「lo0」の他に「e1000g0」としてインターフェースを認識していました。
ifaceはUP状態です。GWもWindowsで使っているものと同じものを指定しています。

ケーブル等は、Winマシンで通信できているケーブル等を使用しているので、その辺りでの
不通は薄いと思います。

よろしくお願いいたします。
通報する
  • 回答数2
  • 気になる
    質問をブックマークします。
    マイページでまとめて確認できます。

質問者が選んだベストアンサー

  • 回答No.2
レベル11

ベストアンサー率 46% (147/319)

Intel Solaris 8からのアドバイスです。

/etc/netmasks

ネットワーク番号 ネットマスク

ですので、この場合、

192.168.100.0255.255.255.0

とすべきだと思います。
man netmasks
で確認してください。もし、

192.168.100.100 255.255.255.0

としても、pingもaliveとなるとおもいます。

lo0: flags=1000849<UP,LOOPBACK,RUNNING,MULTICAST,IPv4> mtu 8232 index 1
inet 127.0.0.1 netmask ff000000
elxl0: flags=1000843<UP,BROADCAST,RUNNING,MULTICAST,IPv4> mtu 1500 index 2
inet 192.168.1.14 netmask ffffff00 broadcast 192.168.1.255
ether 0:10:5a:5e:ea:97
lo0: flags=2000849<UP,LOOPBACK,RUNNING,MULTICAST,IPv6> mtu 8252 index 1
inet6 ::1/128
elxl0: flags=2000841<UP,RUNNING,MULTICAST,IPv6> mtu 1500 index 2
ether 0:10:5a:5e:ea:97
inet6 fe80::210:5aff:fe5e:ea97/10

理由は別として、名前の解決のために、DNSは使用しないようですが、
resolv.confの内容は、
nameserver xxx.xxx.xxx.xxx ←Primary DNS
nameserver xxx.xxx.xxx.xxx ←Secondary DNS
を記述します。

nsswitch.confの内容は、
passwd: files
group: files
hosts: files dns ←dnsを追加します。
ipnodes: files
networks: files
protocols: files
rpc: files
ethers: files
netmasks: files
bootparams: files
publickey: files

現状の私の環境です。
補足コメント
Hiro_Ka

お礼率 37% (9/24)

その後、設定等確認してみましたが、ご指導頂いた設定でもどうしても外部への通信が出来ませんでした。
LAN内すら通信できず、localhostのIPアドレスにのみpingの反応があるような状態で・・・。
いろんなHPでネットワークの設定を見て回りましたが、どうしてこれで動かないのか・・・。
あ、でもDNSは使ってない、hostsにも自ホスト以外は書いてない、DHCPでもない・・・。もしかしてこれが原因?!・・・とは言え、defaultGWにもpingが飛ばないのは・・・。どうしてこんなにはまっているのか・・・汗
投稿日時 - 2004-05-16 23:38:49
お礼コメント
Hiro_Ka

お礼率 37% (9/24)

netmasksですが、すみません、打ち間違いでした。
慌てて文章を書いたもので、ついホストのIPアドレス
を打ってしまいました・・・汗
ここは元々NICにIPアドレスを設定すれば勝手に書き
困れるのでIPアドレスなわけないですよね(^^;
失礼いたしました・・・。しかしながらご参考ありがとうございました。
投稿日時 - 2004-05-14 01:26:36

その他の回答 (全1件)

  • 回答No.1
レベル14

ベストアンサー率 63% (1021/1612)

>/etc/netmasks(192.168.100.100 255.255.255.0)

netmasksファイルにホストのIPアドレスを書いているのは
おかしくないですか?


このQ&Aで解決しましたか?
関連するQ&A
このQ&Aにこう思った!同じようなことあった!感想や体験を書こう
このQ&Aにはまだコメントがありません。
あなたの思ったこと、知っていることをここにコメントしてみましょう。

その他の関連するQ&A、テーマをキーワードで探す

キーワードでQ&A、テーマを検索する
-PR-

特集


開業・独立という夢を持つ人へ向けた情報満載!

ピックアップ

ページ先頭へ