• ベストアンサー
  • 困ってます

更新プログラムの自動インストールについて

  • 質問No.7810043
  • 閲覧数495
  • ありがとう数1
  • 気になる数0
  • 回答数4
  • コメント数0

お礼率 70% (112/160)

電源を切る毎に、毎回更新プログラムを2個イントールしてしまっています。
原因はうまく、イントールが出来ていないためのようでした。

で、いろいろ教えて頂いたとおり、
「Windows Update が機能していない、更新しない、失敗する問題を診断および修正」
http://support.microsoft.com/kb/971058/ja
http://support.microsoft.com/mats/windows_update/ja?entrypoint=lightbox
こちらを試してだめで・・・



「.NET Framework 更新プログラムのインストールが失敗する場合の解決方法」
http://support.microsoft.com/kb/2161107/ja
.NET Frameworkが原因だったようで、
手順に従って、アンインストールしてもう一度インストールしなおして、
手動で更新プログラムをインストールしたところ、

1個は無事正常にインストールされました。

もう1個
Microsoft .NET Framework, Version 2.0 用セキュリティ更新プログラム (KB928365)
がどうしても上手くインストールされません。

どなた様か、解決方法をご教示くださいますよう、お願い致します。
あと少しで解決できそうなのに・・・・どうかよろしくお願い致します。

質問者が選んだベストアンサー

  • 回答No.4
  • ベストアンサー

ベストアンサー率 62% (1168/1867)

 No.3です。

 OSや「.NET Framework」のバージョンは違いますが、
↓こちらに解決事例があります。

Windows更新プログラムがインストールできない
http://okwave.jp/qa/q7824443.html

 参考にして下さい。
お礼コメント
u2122

お礼率 70% (112/160)

いろいろとアドバイスありあとうございました!
お礼が大変遅くなりまして、申しわけおざいませんでした。

上記で無事解決できました!
本当にありがとうございました。
投稿日時:2013/02/14 22:35

その他の回答 (全3件)

  • 回答No.3

ベストアンサー率 62% (1168/1867)

 No.2です。 追加です。

>出来ればインストールしておきたいです。

 因みに、当方の Vista環境でも確認してみましたが、OSの初期状態で
存在するのは「.NET Framework 3.5」と「.NET Framework 4.0」だけで
あり、「.NET Framework 2.0」はインストールされていないようです。

 WinXP の場合どうなのか分かりませんが、バージョン 2.0が無くても
何とかなる可能性はあります。

 とりあえず、3.0 や 3.5、そして 4.0をインストールして様子を見て
みるというのは、ダメですか? まぁ、そっちの方のセキュリティ更新
プログラムは適用させておく必要があるので、それも出来ないとなると
問題が増えることになりますが…。
  • 回答No.2

ベストアンサー率 62% (1168/1867)

> ~  (KB928365)がどうしても上手くインストールされません。

 質問文の冒頭でも示唆されているとおり、そもそも更新プログラムの
元である「Microsoft.NET Framework 2.0」本体が 正常にインストール
されていないと、更新プログラムの方も正常に適用できないようです。

.NET Framework 2.0 を手動で削除して再インストールする方法
http://support.microsoft.com/kb/908077/ja


>他の人にPC操作されるウィルスを駆除するプログラムとかなんとか

 それは、恐らく、当該セキュリティ更新プログラムが元プログラムで
ある「.NET Framework 2.0」が内包している脆弱性(悪意ある第三者に
コントロールされる恐れのある脆弱性)を修正するためのプログラムで
あるということを説明しているんだと思います。
 元のプログラムが存在しなければ悪用される恐れのある脆弱性も無い
わけで、問題の更新プログラムを適用する必要もないハズです。

 ということで、どうしても更新できなければ、いっそ元プログラムを
アンインストールしてしまうという選択肢もあるでしょう。

 ただ、2.0 をアンインストールして今後の PC 活動に不都合が出るか
どうかは、利用形態やシステム環境等によるので何とも言えません。
 今まで利用していたゲームソフトやセキュリティソフトが機能しなく
なる可能性はありそうです。

.NET Frameworkのバージョンを整理する
http://www.atmarkit.co.jp/fwin2k/win2ktips/1128dnfwvr/dnfwvr.html

.NET Framework 環境まとめ
http://attosoft.info/trac/wiki/.NETFrameworkEnvironment


 因みに「クリックスタンパー」というスタンプ画像を作成するフリー
ソフトは「.NET Framework 2.0」が無いとまともに動かないはずですが
「.NET Framework 2.0」しか実装していない当方の Windows7 環境でも
問題なく動いていたりします。
 「.NET Framework」に関しては完全な上位(下位?)互換では無いに
しても、上位バージョンは下位バージョンの機能を包含している部分が
あるのかも知れません。

 なので、本体をアンインストールして、もし都合が悪かったら検討し
直すという選択肢も、有りのような気がします。


 それから、念のための確認ですが、WindowsXP は SP3ですよね?
  • 回答No.1

ベストアンサー率 0% (0/1)

Microsoft .NET Framework, Version 2.0 用セキュリティ更新プログラム (KB928365)
上記の更新が出来ないといいますが。
更新ができなくても、PCになんの不都合がないのであれば、
する必要はありません。
Windows Updateから、更新プログラムの確認をクリックして、
更新を非表示にすれば、電源を切っても更新が始まることは無くなります。
補足コメント
u2122

お礼率 70% (112/160)

ありがとうございます!

正にそのとおりなんですが、なんだか今話題の他の人にPC操作されるウィルスを駆除するプログラムとかなんとか・・・なので、
出来ればインストールしておきたいです。
投稿日時:2012/11/23 22:45
結果を報告する
このQ&Aにはまだコメントがありません。
あなたの思ったこと、知っていることをここにコメントしてみましょう。
関連するQ&A

ピックアップ

ページ先頭へ