• ベストアンサー
  • すぐに回答を!

javaのインストール

現在、RedHat Enterprise Linux(ES)にて、 j2sdk1.3.1_03をインストールし、PATHを通したのですが、 Error occurred during initialization of VM Unable to load native library: /usr/java/jdk1.3.1_07/jre/lib/i386/libjava.so: symbol __lib c_wait, version GLIBC_2.0 not defined in file libc.so.6 with link time reference というエラーが発生して、コンパイルはおろかjavaのversionすら参照できません。 何か情報提供および対策があれば教えていただきたいです。 よろしくお願いいたします。

共感・応援の気持ちを伝えよう!

  • 回答数3
  • 閲覧数217
  • ありがとう数2

質問者が選んだベストアンサー

  • ベストアンサー
  • 回答No.3
  • xjd
  • ベストアンサー率63% (1021/1612)

これは、けっこう知られているJDKのバグです。 RedHatとJDKのバージョンを上げてください。 http://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=109388 http://www.redhat.com/archives/fedora-list/2003-November/msg06994.html

共感・感謝の気持ちを伝えよう!

関連するQ&A

  • runInstallerを実行するとエラーになる(RedHat)

    RedHat ES 4.5 でOracle9.2.0.4をインストールしようとしています。 (インストールしたいのはClientの機能だけです) runInstallerを実行すると、以下のメッセージが出力されます。 ↓↓↓ [oracle@web1 Disk1]$ Initializing Java Virtual Machine from /tmp/OraInstall2008-10-21_10-01-39AM/jre/bin/java. Please wait... Error occurred during initialization of VM Unable to load native library: /tmp/OraInstall2008-10-21_10-01-39AM/jre/lib/i386/libjava.so: symbol __libc_wait, version GLIBC_2.0 not defined in file libc.so.6 with link time reference ↑↑↑ GLIBC_2.0がないと言っていますが、具体的な対処方法を 教えてもらえますととても助かります。 linuxの知識が浅くすみません、お願いします。

  • fedora core6にOracle9iをインストール

    質問されていただきます。 Linux fedora core6にoracle9iをCDからインストールしようとしてるのですが、マウントして/mnt/cdrom/runInstaller & と入力すると、 Initializing Java Virtual Machine from /tmp/OraInstall/jre/bin/jre. Please wait... /tmp/OraInstall/jre/bin/../lib/i686/green_threads/libzip.so: symbol errno, version GLIBC_2 .0 not defined in file libc.so.6 with link time reference (libzip.so) Unable to initialize threads: cannot find class java/lang/Thread Could not create Java VM というエラーが出て、そのまま止まってしまいます。 現在行っている設定は ・oracleユーザの環境設定 ・上記の該当スレッドにtouchでファイル作成(libzip.so、libc.so.6) ・LD_KARNEL_PASHは設定するとエラーが出る為行っていません。 上記エラーに出てるパッケージの検索結果 $ rpm -qa | grep libc glibc-common-2.5-3 libcap-devel-1.10-25 libcroco-0.6.1-2.1 glibc-headers-2.5-3 glibc-2.5-3 libcap-1.10-25 libcroco-devel-0.6.1-2.1 glibc-2.5-10.fc6 glibc-common-2.5-10.fc6 glibc-devel-2.5-3 少ない情報で申し訳ありません。 必要な情報があれば調べてお知らせします。 何卒お知恵をお貸しください。 よろしくお願いします。

  • fedoracore5にjavaをインストールする方法

    http://www.java.com/ja/download/help/5000010500.xml#14 のページを見ながらやったけどうまくいかなかった。 どこが間違ってますか? [root@windows ~]# cd /usr/lib64/mozilla-1.7.12/plugins [root@windows plugins]# ls -s /usr/java/jdk1.5.0_06/jre/plugin/i386/ns7/libjavaplugin_oji.so 136 /usr/java/jdk1.5.0_06/jre/plugin/i386/ns7/libjavaplugin_oji.so [root@windows plugins]#

その他の回答 (2)

  • 回答No.2

RedHatも、Linux用のj2sdkも使った事がないので外してたら済みません。 >j2sdk1.3.1_03をインストールし たディレクトリが、 >/usr/java/jdk1.3.1_07/ って不思議な気がするんですけど。 複数バージョンが同居しちゃったとか、 jdk1.3.1_07を削除した時に何でか残ったって事ないですか?

共感・感謝の気持ちを伝えよう!

質問者からの補足

すみません。記載ミスです。 インストールしたのは、j2sdk1.3.1_07です。

  • 回答No.1

おつかれさまです。 PathだけでなくClasspathも通さないといけませんよ クラスパスは インストールディレクトリ/jdk1.3.1_07/lib です。

共感・感謝の気持ちを伝えよう!

関連するQ&A

  • GLIBC_2.4 以上がインストールされていない環境で

    GLIBC_2.4 以上がインストールされていない環境で perlで開発中に、libcのバージョンが古いというエラーが出ております。 しかし、事情により、通常のインストールができません。 どうにかして、別サーバから取得したsoファイルなどを使って、GLIBC_2.4以上を読み込ませることはできないでしょうか。 いま、外部サーバから取得したlibc-2.5.soがあります。これをサーバ上にアップロードして、perlから使用できるようにする方法はありますか? あまり詳しくないのですが、Dynaloader などは用途が違うのでしょうか。 すみませんが、宜しくお願い致します。 エラーメッセージ(一部伏字): Can't load '~~~i386-linux-thread-multi/auto/Digest/SHA1/SHA1.so' for module Digest::SHA1: /lib/tls/libc.so.6: version `GLIBC_2.4' not found (required by ~~~~/i386-linux-thread-multi/auto/Digest/SHA1/SHA1.so) at /usr/lib/perl/5.8/DynaLoader.pm line 225. at ~~~~/Digest/HMAC_SHA1.pm line 5

  • コマンドプロンプトでjavaのバージョンの確認をしていてエラーが出てし

    コマンドプロンプトでjavaのバージョンの確認をしていてエラーが出てしまうのですが… 皆様のお力をお貸しください jdk-6u20-windows-i586./exeをダウンロードしまして、環境変数でPATHの設定を済ませ、 環境設定の最後にjavaのバージョンの確認をしているのですが、 C:\Users\名前>java -versionと打ったところ ⇒ 参考HP http://www.javadrive.jp/install/jdk/index.html Error: could not open `C:Program Files \java\jre6\lib\i386\jvm.cfg と出てきてしまいました。 この理由がわかりません。 lib → i386 → jvm.cfgのファイルが解凍されていないようなので、 +Lhacaで解凍してあります。 javaをインストールした後、Program files からCの中に入れたのが原因なのでしょうか?

    • ベストアンサー
    • Java
  • mac(osX)で、Javaはどこにインストールされている?

    今Javaの参考書を買ってきたのですが、 サンプルライブラリを 「c:\ProgramFiles\Java\jdk1.6.0_01\jre\lib\ext」と 「c:\ProgramFiles\Java\jre1.6.0_01\lib\ext」に保存と書いてあります。 osXでは標準でjavaが入っていたのですが、もともとそのjavaがどこにインストールされているのかが分かりません。 macではProgramFilesというフォルダも無いので、辿りようが無いな~と困っています。 上記のフォルダがどこにあるのか、分かる方教えてください!

    • ベストアンサー
    • Java
  • LinuxへのJDKインストールについて

    書籍のCDからインストール作業をしています。 指示に従って指定ファイルからインストーラを起動しました。 ・インストール作業 /media/cdrom/Linux/jdk-6ul-L\linux-i586.bin ・環境変数設定 .bash_profileの変更 ・source ~/.bash_profileの実行 インストールはされているようなのですが、その次のJDK6の動作確認 java -version を行うと以下のようなエラーメッセージが帰ってきました。 [usr@localhost ~]# [usr@localhost ~]# java -version dl failure on line 685Error: failed /usr/local/jdk1.6.0_01/jre/lib/i386/client/libjvm.so, because /usr/local/jdk1.6.0_01/jre/lib/i386/client/libjvm.so: cannot restore segment prot after reloc: Permission denied [root@suzuran ~]# 対処方法につきましてご教示お願い申し上げます。

    • ベストアンサー
    • Java
  • linux firefox java

    linux環境でfirefoxを使っているのですが、java appletなどが表示されません。 プラグインを設定しようと思い、以下のようにしました。 ・javaのプラグインのファイルへのシンボリックリンクをつくる $cd /usr/lib/mozilla/plugins $ln -s /usr/java/jdk1.7.0_04/jre/plugin/i386/ns7/libjavaplugin_oji.so これ以外に方法が見当たらず、困っています。 どうしたら、firefoxのプラグインにjavaを入れることができますか?

  • javaが起動できない

    初めまして、JAVAの勉強のために環境つくりをしていますが、いきずまって質問しました。 現在VM PlayerにLinux8をいれてAPサーバとしてTomcat、JDKインストール後、JAVAの動作確認「java -version」をすると 「cannot handle file '/usr/java/jdk1.7.0/jre/lib/i386/client/libjvm.so' with TLS data」と怒られます。 そのため、tomcatも起動できず困っています。 どなたか、原因がわかる方がいればご教授お願いします。 【環境】 OS:WindowsXP VM:VMware(R) Player 3.1.4 build-385536    ・Red Hat Linux release 8.0 (Psyche) ・jdk-7-linux-i586.rpm    ・apache-tomcat-7.0.20.tar.gz

  • Javaについて教えてね。

    Hello Worldを出そうと、Javaをコンパイルして、次に実行する際に『Error:could not open \'C:\\Program Files\\Java\\jre6\\lib\\i386\\jvm.cfg\'』とエラーメッセージが出るのですが、どんな理由が考えられますか?

  • gccのインストール

    RedHatLinux5.2です。 gccをインストールしようとして gcc-4.4.1.2-9.i386.rpmをダウンロードしました。rpm -Uvhすると、 依存性の欠如として binutils >= 2:2.16.90.0.1-0.3 libc.so.6(GLIBC_2.3) libgcc4 = 5:4.1.2-9 rpnlib(PartialHardlinkSets) <= 4.0.4-1 が必要とされているとでます。 (1)binutilsの入手方法を教えてください。 (2)GLIBCのインストールにgccが必要だと言われたのでgccを入れているのですが、gccのインストールにGLIBCが必要だと言われています。どうしたらよいのでしょうか? Linux初心者です。よろしくお願いします。

  • 特定のディレクトリでコマンドが実行出来ない。

    特定のディレクトリでコマンドが実行出来ない。 OSはRed Hat Enterprise Linux Server release 5.4です。 rootユーザで特定のディレクトリでlsコマンドを実行すると エラーが発生します。 カレントディレクトリが該当のディレクトリでない場合には 問題ありません。 また、そのディレクトリではwhoやdfコマンド等でも エラーとなってしまいます。 このような現象は、どのような原因が考えられるでしょうか? 以下は、全てrootユーザでの実行結果です。 # pwd /opt/oracle/app/product/11.2.0/dbhome_1/lib # ll stubs 合計 6404 -rwxr-xr-x 1 oracle oinstall 12121 2月 3 2009 ld-linux-2.3.4-stub.so -rwxr-xr-x 1 oracle oinstall 12121 2月 3 2009 ld-linux-x86-64.so.2 -rwxr-xr-x 1 oracle oinstall 4911 2月 3 2009 libBrokenLocale-2.3.4-stub.so -rwxr-xr-x 1 oracle oinstall 4911 2月 3 2009 libBrokenLocale.so -rwxr-xr-x 1 oracle oinstall 4911 2月 3 2009 libBrokenLocale.so.1  ・  ・  ・ # cd stubs # pwd /opt/oracle/app/product/11.2.0/dbhome_1/lib/stubs # ls ls: libc.so.6: version `GLIBC_2.4' not found (required by ls) ls: libc.so.6: version `GLIBC_2.4' not found (required by /lib64/libacl.so.1) ls: libc.so.6: version `GLIBC_2.4' not found (required by /lib64/libselinux.so.1) ls: libc.so.6: version `GLIBC_2.4' not found (required by /lib64/libattr.so.1) ls: libc.so.6: version `GLIBC_2.4' not found (required by /lib64/libsepol.so.1) # who who: libc.so.6: version `GLIBC_2.4' not found (required by who) # df df: libc.so.6: version `GLIBC_2.4' not found (required by df) 宜しくお願いいたします。

  • centosのglibcのアップグレード

    CentOS 6.5にてプログラムを実行しようとしたら /lib/libc.so.6: version `GLIBC_2.15' not found という警告表示されて実行できないので、glibcのバージョンを確認したいところ yum info glibc version 2.12でした。 glibcを2.15までアップグレードするにはどうすればよろしいでしょうか。 多少のLinuxの操作は分かりますが、詳しくないため教えていただけないでしょうか。