• ベストアンサー
  • 暇なときにでも

ホームページで画像が×印に変わってしまいます。

  • 質問No.750392
  • 閲覧数55
  • ありがとう数6
  • 回答数5

お礼率 74% (67/90)

ワードでホームページを作成し、FTPを使ってページをアップロードし、ホームページを見てみると画像が表示されない部分がありました。パソコンの中に保存されているhtmlファイルを開くとちゃんと表示されていたのですが・・・。

これは、ワードが問題このようになるのでしょうか?
暇な時で宜しいのでご回答をお願いします。

質問者が選んだベストアンサー

  • 回答No.3
  • ベストアンサー
こんばんは。
多分、パスミスでしょうね。

よくあるミスで、HTMLってのは、それ自体には画像を持っていないので、どこかから参照する必要があります。

通常、同じフォルダの中の画像を使用すれば、
相対パスとなるのですが、画像の位置がおかしかったりして、絶対パスになっているかもしれません。
※当然、画像ファイルもアップしてますよね?

ソースを見てみないとはっきりしたことは言えませんが、まずパスミスと見て間違いないのではないかと。
お礼コメント
husigikazetukai

お礼率 74% (67/90)

ソースの打ち間違えで表示されていないことがわかりました。ご回答ありがとうございました。
投稿日時:2004/01/14 22:45

その他の回答 (全4件)

  • 回答No.5
あと、ファイル名(画像も含め)は半角英数になっていますか?スペースや/*なんかも使えません。
サーバによっては日本語や2ビットの文字を受け付けず化けてしまうことがありますゆえ。
お礼コメント
husigikazetukai

お礼率 74% (67/90)

確認をしたところファイル名は全て半角英数でした。ご回答ありがとうございました。
投稿日時:2004/01/14 19:55
  • 回答No.4

ベストアンサー率 40% (201/496)

ファイル名の大文字小文字の違いでも表示されないことがあります。<img src="Image.jpg"> と書いてあって実際にアップロードしたファイル名が image.jpg となっている場合など。
お礼コメント
husigikazetukai

お礼率 74% (67/90)

ファイル名は大丈夫でした。ご回答ありがとうございました。
投稿日時:2004/01/14 22:33
  • 回答No.2

ベストアンサー率 35% (842/2394)

画像ファイルも正しい位置にアップロードしましたか?
お礼コメント
husigikazetukai

お礼率 74% (67/90)

はい、確かに同じところにアップロードしてありました。
ご回答ありがとうございました。
投稿日時:2004/01/14 22:02
  • 回答No.1
>これは、ワードが問題このようになるのでしょうか?
否。

画像もFTPでUPLOADしてください

そのhtmlを右クリックして[ソースの表示]を選択
いくつかの<img src="ど~のこ~の" />
というところを探してください

多分imgで[編集]-[検索]した方が早いでしょう

でsrc="C:\ど~のこ~の"とか書いてあるか
確認してください

書いてあればC:\以降をその画像をアップロードした
場所においてください
お礼コメント
husigikazetukai

お礼率 74% (67/90)

なんとか画像は表示されるようになりました。ご回答ありがとうございました。
投稿日時:2004/01/14 22:32
関連するQ&A

その他の関連するQ&Aをキーワードで探す

ページ先頭へ