• 締切済み
  • 困ってます

ホームページに画像を転送したが、表示されないのはなぜ??

無料の10メガのホームページサイトにホームページビルダー2000で製作した自分のホームページをI.E5の(htp)で転送したのですが画像が表示されません。どうしてでしょうか?誰か教えてください、宜しく御願い致します

共感・応援の気持ちを伝えよう!

  • 回答数6
  • 閲覧数408
  • ありがとう数7

みんなの回答

  • 回答No.6
  • reis
  • ベストアンサー率46% (402/864)

御使いになったのは、Web発行ウィザードですか? でしたら、あれよりはホームページビルダーの転送の ほうが使えると思いますよ(その方が簡単ですし)。 ホームページビルダーから転送する方をオススメします。 で、画像が出ない原因はみなさまが既に仰るとおり。 ……転送モードが違う。 これに関しては、ホームページビルダーから転送すれば 勝手に判断してくれます。 ……パスが違う。 これはホームページビルダーで作成していれば、通常は 勝手に修正してくれます。だから、可能性低いですね。 一応確認のため、ホームページビルダーの「HTMLソース」 もしくはブラウザの「表示」→「ソース」で、画像の リンク先を確認して下さい。「file」から始まっていたり 余計な階層が出来ていたりしませんか? もし、そうなら それをなおして下さい。 また、画像のアドレスが間違っていたり、日本語だったり 大文字小文字が違っていたりしないかも確認して下さい。 日本語や大文字は使わないようにしましょう。 ……画像自体がアップされていない。 これもホームページビルダーなら容易に確認出来ます。 ホームページビルダーの「ファイル転送」(「スタート」 →「プログラム」→「IBMホームページビルダー」)で、 サーバにアップしてあるデータが一覧されますから、 それで画像のデータが見あたらなければ、アップで失敗 しています。 それ以外では、他の方法(JavaScript等)で画像を コントロールしていて、そのプログラムでエラーが出て いる……等の可能性もありますが? それはないですか? ホームページビルダーを御使いということでしたので、 少々つっこんだアドヴァイスをさせていただきましたが、 pen2sanサマがおっしゃるように、アドレスを教えていた だけると、ページやソースを拝見することで確実な回答を 差し上げられますので、これでもし御解りにならない ところがありましたら、アドレスを書いていただくのが 良いと思います。

共感・感謝の気持ちを伝えよう!

質問者からのお礼

どうもありがとうございました。 転送に成功しました。 画像情報がD://******/****/00000001.jpegということが原因でした。0000001.jpegだけでよかったみたいです。どうもありがとうございました。

関連するQ&A

  • ホームページ転送できません

    ホームページビルダー6で、ページを作成し、いざサーバーへ転送! まではよかったのですが、インターネットで自分のホームページを確認してみると、ちょうど画像部分だけが点線の枠で選択されていて肝心の画像が表示されていませんでした。ビルダー上で作った文字のみで、わけのわからないホームページ です。画像の転送は何か特別なやり方があるのでしょうか。 テキストには書いてないので困っています。

  • ホームページの画像の表示

    ホームページを作成して、転送してみました。一部の画像が表示されません。 どこが問題か教えていただけませんでしょうか? よろしくお願いします。 ※ホームページ作成ソフト「ホームページビルダV9」 ※転送ソフト「FFFTP] ※サイトの構成 「トップページを分割しており、フレームの方の画像だけが、表示されません」 ※URLは「http://www016.upp.so-net.ne.jp/MY-agent/」  ※ホームページを作成してあるファイルも画像も素材も全て同じフォルダ内に入っています。 ※ファイル名や拡張子などは問題ないと思います。(フォイル名は半角、空白はないなど・・・)

  • ホームページのタイトル画像だけが表示されない

    はじめまして。ホームページ作成は初心者です。よろしくお願いします。 あるサイトの無料ホームページテンプレートをホームページビルダー12にて編集し、レンタルサーバーに転送しました。 ところが、topページのタイトル画像だけがまったく表示されません。(同じページの他の画像と、その画像を使っていない他のページはすべて表示されています) 無料のテンプレートの編集方法では、topのタイトル画像に使われている写真は著作権の関係で必ず他の画像に変更するように記載されており、ペイントで編集した違う画像を元のimagesに上書きをしました。 ホームページビルダーのプレビュー画面ではちゃんと表示されています。 どんな事が原因なのか、まったくわからずとても困っています。 こんな事が原因ではないか?という事がありましたら教えてください。 よろしくお願いします。

  • 回答No.5
  • pen2san
  • ベストアンサー率37% (260/696)

あなたのHPアドレスを公開して頂ければ原因がはっきりする事と思えます。 現象が、文字は読めて画像だけ表示されない。リンク先が見つからない等の問題が発生しているとの仮定の元に回答します。但し自分のパソコン上のデーターを見ている限りでは問題無い。 1)リンク先が絶対パスで書かれている。   Blackwinglsさんが回答されておられる通り、問題のHPを開いて、ソースを表示させます。画像やリンク先のアドレスがfile:////で始まっていませんか?その際は相対パスに直しましょう。(ホームページビルダー2000のマニュアルの索引で「絶対パス」または「パス」を参照して下さい。)。 でも、お使いのソフトの場合、編集中のHTMLファイルをセーブする事により相対パスに変更してくれると思われます。(ホームページビルダー2001ではこの仕様です。) 2)画像ファイル名が日本語か大文字で書かれている。 PC上ではアルファベットの大文字小文字の区別を区別しませんが、異なるOS上では大文字、小文字を区別している物があります。ファイル名は全て小文字で統一し、日本語を使用する事も避けた方が安全です。 3)実際のデーターがアップロードされていない。 FTPでアクセスし、HPディレクトリ上にあるファイル名を確認して下さい。(FTPの使い方は同じくマニュアルを参照して下さい。たぶん、「FTPによるデーター転送」とか言った章があると思います。ファイル転送時の操作ミスと思われます。(ファイルが不足している場合は、試しに全てのファイルをもう一度アップロードしてみて下さい。) 不明な点は「補足」として(?)質問して下さい。

共感・感謝の気持ちを伝えよう!

質問者からのお礼

どうもありがとうございました。

  • 回答No.4
  • acky
  • ベストアンサー率31% (182/583)

画像名が日本語になってませんか?日本語のファイル名はHPでは使用できません(でもネスケだと表示される)。もう一度画像を半角英数で名前を変えて保存しなおし、その上でホームページビルダー上で編集しなおしてアップロードしてみて下さい。

共感・感謝の気持ちを伝えよう!

  • 回答No.3
  • Kaz003
  • ベストアンサー率48% (31/64)

画像ファイルの転送等、ホームページビルダーではそのページを構成するのに必要なファイルや構成を管理して転送可能だったと思いますが、それだと転送忘れやリンクミスがないので、ホームページビルダーでサイト管理や転送をしてみたらいかがでしょう。 またツールで現在転送されているファイルと自分のパソコンの中の構成ファイルのやりとりもできるようです。 

共感・感謝の気持ちを伝えよう!

  • 回答No.2

画像のリンクがローカルになってませんか? アップした自分のHPをIEで 表示(V)→ソース(C) で表示してソース内容を確認してください。 file:// で画像ファイルがリンクされてるとローカルにリンクされてます。ソース内を検索して探してみましょう。 また画像のファイル名は間違っていませんか? Windowsですとファイル名の大文字、小文字は区別されませんが、unix系のサーバーだと区別されます。 TEST.GIFとTest.gif、test.gifは全て別ファイルと判断されます。

共感・感謝の気持ちを伝えよう!

質問者からのお礼

まったくそのとうりでした、どうも勉強になりました。ありがとうございました。

  • 回答No.1
  • makorin
  • ベストアンサー率44% (31/70)

IE5のhtpがなんなのかわかりませんが 画像が表示されないので有れば、転送するときにテキストで転送したのではないでしょうか? FTPツールであれば、ファイルを転送するときに バイナリ形式とテキスト形式で転送を指定します (常道判別機能付きもある) テキスト形式は、改行コードを転送先に合わせて変換します。 バイナリ形式は、そのままのファイルを送信します。 ここで、バイナリで送らなければならない、画像ファイルをテキストで送るとどうなるか。 改行コードを同じ値が少なからず、画像には存在します。 それが自動的に変換されて、画像が壊れてしまうのです。 もしWindowsのDOSプロンプトから動かしているFTPであるなら FTPでログイン後bi(またはbinary)でバイナリモードに変更できます。

共感・感謝の気持ちを伝えよう!

関連するQ&A

  • ホームページ画像

    ホームページビルダーV9を使っています。 ホームページにサンプル画像を挿入して、転送しても、画像が表示されません。 分る方いたらお願いします。

  • ホームページに転送できません。

    ウイルスセキュリティをインストールしてからホームページビルダーから自分のホームページへファイル転送できなくなってしまいました。エラー番号が表示され、転送を試みた転送先のページが真っ白になってしまいました。

  • ホームページ転送ができない

    ホームページビルダー7でつくったホームページを 転送し、「転送が完了しました」とでたので、そのホームページへいってみたのですが、まだ作成されていない、というような言葉がでています(ヤフージオシティーズです)表示されるにはどうしたらいいんでしょうか?

  • ホームページの転送が出来ません。

    出来たとしても文字化けするのです。ホームページはホームページビルダーで作り、無料のホームページスペースをレンタルしようと思い、yahooとかinfoseekで試しましたが駄目です。初心者なので、ホームページを転送し、公開することの意味を良く分かってないのかもしれません。せっかく頑張ってホームページ作ったので、どうか助けて下さい。

  • 画像転送

    ホームページビルダーV9の、かんたんモードでホームページを作り、画像を転送しようとしたのですが 、転送できませんでした。 HTMLの保存先と同じでも、送信出来ませんでした。 困っています。

  • 忍者ツールズの無料ホームページにFTPでホームページを転送したのですが画像ファイルが表示されません。

    今までFc2のホームページを使っていたのですが調子がどうも悪いので忍者ツールズの無料ホームページに変えたんですがFTPでHPを転送すると画像が表示されません。 いままではFc2の編集機能でアップロードして貼り付けなおしていたんですが忍者のHPにはそれがないので困っています。 ホームページビルダーV9を使って作ったHPをFFFTPで送ったのですがホームページビルダーの製作方法に問題があるのでしょうか? ビルダーでただ画像の挿入をしただけなんですが・・・。 改善方法がわかる方はできましたら教えていただけないでしょうか。

  • 初めてのホームページ転送

    IBMのホームページビルダーで初めてホームページを作って試験的にプロバイダーにサイトを転送しようとしているのですが、何度やっても「ログインできませんでした」と出ます。プロバイダーには転送に必要なデータはすべて確認しており、そのとおりやっているのですが。何か原因はあるのでしょうか?お教えください。なお、作ったホームページは1ページのきわめて簡単なやつです。

  • 転送した画像が表示されず、困っています

     ホームページビルダー11で、yahooジオシティーズにホームページを公開しています。1回目の転送は問題なくできたのですが、2回目の転送が上手くいかず、「転送エラー:フォルダ名またはファイル名が一致していません」と表示されるため、修正プログラムをインストールして転送しました。すると、転送はできたのですが、イラストと写真のみが×の表示で表示されません。 プレビューでは問題なく表示されているのですが…。どのようにしたら写真等が表示できるのか困っています。 パソコンは初心者に近いです。どなたか、よろしくお願いします。

  • ホームページで使わなくなった画像を転送先から削除するには

    ホームページビルダーver6を使用しホームページ公開済みです。これまでの更新で使わなくなった画像などを削除して転送先ブロバイダーの情報量を軽くしたいのですがやり方が分りません。教えて下さい。

  • ホームページが転送できない

    ホームページを更新しようと思い、新しいサイトを作り転送設定にそって転送しましたが「転送しました」と出たのですが前のサイトの表紙しか見ることができません。どこに誤りがあるのでしょうか。 アサヒネットのフリーアドレス、ホームページビルダーのV11(修正プログラムをインストール済み)を使用しております。 何回も転送したのが悪かったのでしょうか。 途方に暮れています。 なお、パソコンは初心者です。 どなたかわかりやすく教えてください。