• ベストアンサー
  • 困ってます

約一時間で突然、通信が切断状態となります。

  • 質問No.6224769
  • 閲覧数1917
  • ありがとう数3
  • 気になる数0
  • 回答数18
  • コメント数0

お礼率 9% (2/21)

約一時間で突然、通信が切断状態となります。
【使用OS】 windows xp he sp3
【ネットワークアダプタ】 Marvell Yukon 88E8056 PCI-E Gigabit Ethernet Controller
【モデム】 NTT ADSLモデム-NV3
【ルータ】 BUFFALO AirStation WHR-HP-G54 Ver.1.43
【使用ブラウザ名】 Firefox
【プロバイダー名】 hi-ho
【物理的接続】 モデム→ルータ→有線→私PC
                   └→無線→父PC
【問題点】 約一時間で突然通信速度がほぼ0となり、パケットも数十程度しか送受信できなくなります。
      特にエラーメッセージは表示されず、ブラウザはタイムアウトし、「サーバが見つかりませんでした」。
      モデムメニューでは「回線接続中」。ランプ表示もすべて点灯し問題ありません。
      モデム再起動で回復しますが、また約一時間後に再現します。
      NETSTATにて負荷をかけているアプリがないか確認。
      NATタイマを最小値に。
      NTTへ問い合わせし、*モデム交換。
      *モデム、ルータのファーム最新か確認。
      *保安器からPCまでの物理的問題なしを確認。
      *保安器→モデム間にノイズフィルター設置。
      *基地局よりノイズ対策モード(?)にして頂き、ラインモード、上り拡張、オーバーラップを自動設定に。

      以上を行いましたが改善されません。
      その後も検証しましたが、切れる条件が「私PCがネット接続状態で約一時間起動していること」のようです。
      その間、ブラウザ、アンチウィルスソフト等関係ありそうなアプリケーションを起動していない状況でも発生します。
      父PCは起動していても問題無いようです。
      ネットワークアダプタのドライバも最新にして見ましたが改善されません。
      問題発生前後の気になる点も思い当たりません。

私としましてはお手上げ状態です。
アドバイスをよろしくお願いいたします。

質問者が選んだベストアンサー

  • 回答No.17
  • ベストアンサー

ベストアンサー率 41% (525/1254)

#16

出るはずのものが出てないですね。
もしかしてブリッジモードになってませんか?
補足コメント
pachi_id

お礼率 9% (2/21)

ブリッジモードになっていました。
ルータモードにすることにより、切断状況になる不具合は解決いたしました。
ありがとうございました。

ですが、今度はポート開放されていない状況になってしました。
あれやこれやとすみませんがご鞭撻をお願いいたします。
投稿日時:2010/10/12 01:41
お礼コメント
pachi_id

お礼率 9% (2/21)

切断の不具合に関しては解決いたしました!
ありがとうございました!!
投稿日時:2010/10/12 01:42

その他の回答 (全17件)

  • 回答No.18

ベストアンサー率 41% (525/1254)

#17です。

>今度はポート開放されていない状況になってしました。

ポート開放されていないというより、今まではインターネット直結だったのではないでしょうか?
それがルータの内側のLANに配置されたのでインターネット側から見えなくなったということでしょう。

ポート開放したければ設定が必要です。
まず少くともポート開放する側のPCのアドレスを固定IPにします(dhcpのサービスは受けない)。
次にいずれかの設定をする。
・NATでWAN側着信を当該PCのアドレスに転送するようにする。
・DMZの転送先を当該PCのアドレスとする。

です。マニュアルを熟読し、頑張ってみて下さい。
補足コメント
pachi_id

お礼率 9% (2/21)

返事が遅くなりましてすみませんでした。

>ポート開放されていないというより、今まではインターネット直結だったのではないでしょうか?
いえ、IP固定、モデムポート開放、windowsファイアウォール例外設定、ウィルスバスターファイアウォール例外設定を経て開放していました。
あれから、モデムとルータの初期化、再設定、IP再固定を行ってみましたが、
おそらく、二重ルータ状態になっている為だと思いますが、ポート開放できませんでした。

ルータの方をルータ機能無効とするにはブリッジモードにするしかなく、ブリッジモードにすると回線切断が再現しました。
ルータ本体底部にブリッジモードスイッチがあったのでそれを使用しても回線切断が再現しました。
残るはモデムの方のルータ機能を無効にする事で二重ルータ状態を回避するしかないと思うのですが、その方法が見つかりません。

質問の内容が変わって来てしまったので一旦この質問は閉めさせて頂きたいと思います。
長い間ありがとうございました。
いろいろ勉強になりました。
投稿日時:2010/10/14 20:17
  • 回答No.16

ベストアンサー率 41% (525/1254)

#15です。

Top画面に行ってみて下さい。

たぶん

http://buffalo.jp/download/manual/html/air1100/router/whrg54s/chapter127.html

の「2 システム情報画面を表示します。」の画面が出ると思います。
そこで「システム情報」ボタンを押せば、
「3 ファームウェアバージョンを確認します。」の画面が出ると思います。

そこで確認して下さい。
補足コメント
pachi_id

お礼率 9% (2/21)

http://ichigo-up.com/cgi/up/qqq/nm26412.jpg
こちらがトップ画面です。
「システム情報」ボタンを押した際に表示される画面が
http://ichigo-up.com/cgi/up/qqq/nm26316.jpg
です。
投稿日時:2010/10/10 23:41
  • 回答No.15

ベストアンサー率 41% (525/1254)

#14です。

>まず、モデムやルータのメニューに「WAN側」、「デフォルトゲートウェイ」といった単語が出てきません。
>モデムはADSLモデム-NVIIIなのですが、NTTからのレンタルなのでマニュアルは無いですが、ダウンロードして見てみましたが、情報を参照する方法は無いようです。

このモデムはたぶんルータ機能が無いので、もしかしたらメニューさえ無いかもしれません。
一方ルータには必ずその類のメニューがあるはずです。

直接の説明は見つかりませんでしたが、

http://buffalo.jp/download/manual/html/air1100/router/whrg54s/chapter128b.html

の説明でTOP画面の右中段にWAN情報があり、「現在の状態を表示」ボタンがあります。
これで飛べるような気がします。もし飛べれば、
それでDNSやデフォルトゲートウェイのIPアドレスが分かると思います。

ところでPPPOEの場合、デフォルトゲートウェイのIPアドレスの表示が無い可能性があります。
その場合はコマンドプロンプトで

tracert DNSのIPアドレス

と打って下さい。
最初に192.168~の行が出て、それ以降に何がしかのアドレス表示が出れば、
デフォルトゲートウェイまでの通信は概ねできていると判断できます。
さらにその先のDNSのアドレスまで反応が戻れば、デフォルトゲートウェイがルーティングできたと判断でき、
DNSまでの通信も概ねできていると判断できます(DNS機能が使えているとは限りませんが)。

まずこの辺を確認して下さい。
補足コメント
pachi_id

お礼率 9% (2/21)

ご丁寧にありがとうございます。

http://ichigo-up.com/cgi/up/qqq/nm26315.jpg
http://ichigo-up.com/cgi/up/qqq/nm26316.jpg
このように、WAN設定というメニューはありません。
デフォルトゲートウェイのIPアドレスやDNSのIPアドレスは未設定と表示されます。
どうすればいいでしょうか?
投稿日時:2010/10/08 18:45
  • 回答No.14

ベストアンサー率 41% (525/1254)

#13です。

難しいことではないです。というより元々大したことはできないですね。

最後の手段はたぶん、お父さんのPCとあなたのPCにWireSharkか何かをインストールし、
それぞれのパケットのやり取りを観測し、大きな差が無いか見てみる位でしょう。

でもそれをやる前にひとつ確認した方がいいと思うのは、プロバイダとの通信がどうなっているか?です。
プロバイダとはpppoe接続しなければ通信できませんが、
pppoeで認証されppp接続されはじめてIPアドレスを使ったL3の通信が可能となります。
これはルータの管理画面等でWAN側の状態を確認すればできます。
まあ通信とか接続とかになっていれば形式的には繋がっているということになります。

まずあなたのパソコンが正常な状態でルータのWAN側の状態を確認し、接続状態にあることを確認して下さい。
この時デフォルトゲートウェイ(プロバイダのルータやL3スイッチ)が表示されていると思いますので、
そのアドレスにpingを打ってみて下さい。たぶん反応が返ると思います。

次にあなたのパソコンで接続断状態を再現します。
再現したらその状態でルータの管理画面等でWAN側の状態を確認して下さい。
もしそこでpppoeが断となっていれば根本的に繋がりませんし、
トラブルシュートもなぜそうなってしまうか?という観点で進める必要があります。

もし繋がっていた場合は、今度はIPによる通信ができないということを意味しますから、
デフォルトゲートウェイ(プロバイダのルータやL3スイッチ)に再びpingを打って動作確認します。
これでもし反応が返らなければ、一見pppoeは正常に見えてもプロバイダのデフォルトゲートウェイと通信できないことが原因です。

もし反応が返った場合は、デフォルトゲートウェイのこちら側ポートまでは通信できていることになり、
問題はデフォルトゲートウエイの他のポートやさらにその先にあるか、DNSなどと通信できないことが考えられます。


まずはこの辺までですね。
文章でなかなか分かりにくいと思いますけど、こんな感じでやってみてはどうでしょう。
補足コメント
pachi_id

お礼率 9% (2/21)

細かく書いていただいてありがとうございます。
>まずあなたのパソコンが正常な状態でルータのWAN側の状態を確認し、接続状態にあることを確認して下さい。
>この時デフォルトゲートウェイ(プロバイダのルータやL3スイッチ)が表示されていると思いますので、
>そのアドレスにpingを打ってみて下さい。たぶん反応が返ると思います。

まず、モデムやルータのメニューに「WAN側」、「デフォルトゲートウェイ」といった単語が出てきません。
モデムはADSLモデム-NVIIIなのですが、NTTからのレンタルなのでマニュアルは無いですが、ダウンロードして見てみましたが、情報を参照する方法は無いようです。
ググって見ましたが、コレといった調べる方法を見つけることができませんでした。
調べる方法を教えてください。
投稿日時:2010/10/07 23:48
  • 回答No.13

ベストアンサー率 41% (525/1254)

#9です。

もうひとつ確認してはどうか?ということがあります。接続状況です。
通信できない状態には、リンク断の状態と、リンクはしていても通信できない状態があります。
要するに、pppoe認証してプロバイダに接続している状態がどうなっているか?です。
接続していればリンク状態にあり、していなければリンク断です。

リンク断なら根本的に繋がりません。
トラブルシュートもなぜリンク断してしまうのか?という観点になります。

リンク断していないのなら、なぜ通信ができなくなるのかという問題になり、
これはプロバイダ内で通信が途絶えていることを意味します
(但し、利用者の不適当な通信方法に反応してそうなっている可能性は否定できません)。

リンク状態は、ルータ経由の場合はWAN側の状態を表示する機能があるはずですので、
そこで接続状態になっているかどうかで確認できます。

またパソコン直結ならネットワーク接続で当該接続アイコン(たぶん広帯域に分類されている)近辺に、
接続/切断が表示されているはずで、これがリンク状態を表しています。


尚、リンク状態でも業者のデフォルトゲートウェイにpingして反応が返らなかった場合、
直接にはデフォルトゲートウェイとの通信が途絶えていることが原因と分かります。
デフォルトゲートウェイにpingして反応が返った場合は、次に業者のDNSにpingしてみます。
これが返らなければたぶんデフォルトゲートウェイから先に通信できなくなっています。

恐らく今回の問題はプロバイダ(NTTではない)の問題だと思いますが、
この辺の切り分けをして対応を求めないと、適当にあしらわれる可能性が高いと思います。
補足コメント
pachi_id

お礼率 9% (2/21)

よろしければ検証手順を教えてください。
以下の問答でもいくらか意図を勘違いしてしまったり、私の知識が断片的だったりしますので、回答者様の望む答えを的確に答えられないかもしれません。
よろしくお願いいたします。
投稿日時:2010/10/06 20:42
  • 回答No.12

ベストアンサー率 50% (32/64)

>インターネットプロトコルのプロパティでは
>優先DNSサーバ が 192.168.1.1 となっています。

192.168.1.1は、PC側から見た場合のゲートウェイに相当するIPです。
(PCがモデム直結であれば、モデムのLAN側ポートのIPです。)
これにpingを投げても、内部のネットワークなので、外部との接続が確立されているかどうか分からないので、意味がありません。
補足コメント
pachi_id

お礼率 9% (2/21)

>192.168.1.1は、PC側から見た場合のゲートウェイに相当するIPです。
そうですか。

ADSL側 IPアドレス 219.126.129.24 
ADSL側 プライマリDNS 210.130.1.1 
ADSL側 セカンダリDNS 210.130.0.1 
こちらのことでしょうか?
投稿日時:2010/10/06 06:02
  • 回答No.11

ベストアンサー率 50% (32/64)

>192.168.1.1 となっています。
>モデムの表示では、LAN側状態のIPアドレスが同じ値となっていましたが同じ意味なんでしょうか?

今、接続は、モデム直結でしょうか。
プロバイダーのデフォルトゲートウェイは、モデムの上流側になりますので、ipconfigでは出てこないと思います。

pingでの確認は、外部のネットワークへの接続できているか確認するためです。
なので、プロバイダのデフォルトゲートウェイでなくてもいいです。
DNSのIP(プライマリ、セカンダリのどちらでも可)でもいいです。これは、プロバイダから送られる書類に書いていませんか。
(NV3の取説を見ましたが、WAN側の設定状態を表示する画面はなさそうですね。)

なお、pingコマンドは以下のように入力します。
ping XXX.XXX.XXX.XXX ←対象サーバーのIPアドレス

応答(Request)が帰ってくれば、そのIPを持つサーバーとの接続ができていると判断できます。
補足コメント
pachi_id

お礼率 9% (2/21)

お手数をお掛けします。
モデム、ルータ共に、サーバから割り当てられたアドレスを使用するにチェックが入っている状態でIPは表示されていません。
インターネットプロトコルのプロパティでは
優先DNSサーバ が 192.168.1.1 となっています。
こちらでいいのでしょうか?
投稿日時:2010/10/05 23:30
  • 回答No.10

ベストアンサー率 50% (32/64)

>DHCPリース時間ですが、24時間となっていました。
>IPアドレスですが、正常時、192.168.1.12
>切断時、192.168.1.12 と、変わりませんでした。

ということは、DHCPによる再割り当て失敗ではないということです。
LANカード交換は、あくまでも最終手段です。

残る手段は、プロバイダーのデフォルトゲートウェイにpingですかね。
(#9さんと同様の意見です。)

プロバイダのデフォルトゲートウェイのIPは、モデムの設定画面で、「現在の状態」というようなリンクがあると思います。そこをクリックすれば、IPがわかるはずですが。
補足コメント
pachi_id

お礼率 9% (2/21)

ipconfigで出てましたね。(汗
192.168.1.1 となっています。
モデムの表示では、LAN側状態のIPアドレスが同じ値となっていましたが同じ意味なんでしょうか?
pingの打ち方を教えてください。
投稿日時:2010/10/05 22:02
  • 回答No.9

ベストアンサー率 41% (525/1254)

#4です。

今までの現象を総合すると、原因はモデムかモデムより上流だと思いますが、
ひとつ試してはどうか?というのがあります。
それは通信ができなくなった状態で、
プロバイダのデフォルトゲートウェイにpingを打ってみることです。

アドレスは、
直結ならipconfig /allで分かりますし、
ルータ経由ならルータの設定画面でWAN側の状態を見れば分かると思います。

モバイルの場合だとデフォルトゲートウェイからpingが帰り、
一見正常に接続しているように見えるけれども、
そこから先へ正常にルーティングされないということはあります。
その場合は接続し直すと直りますが。

ただ有線では聞いたことはありませんので、あくまでも「試しに」ですけどね。
補足コメント
pachi_id

お礼率 9% (2/21)

やり方が良くわかりません。
よろしければ詳しく教えてください。
投稿日時:2010/10/05 21:10
  • 回答No.8

ベストアンサー率 50% (32/64)

質問者様のPCのIPアドレスは、DHCPによる割り当てでしょうか。
仮にそうであれば、以下のことを確認してください。

1.DHCP割り当て時間(DHCPリース時間)
対象機器は、IPアドレスを割り当てている機器です。
これが、およそ1時間程度になっていないかどうかを確認。

2.ipconfigコマンドで、
不具合発生時の場合と、正常時のIPアドレスを確認。
不具合発生時に、169.254.XXX.XXXになっていないか。
(正常時は、おそらく、192.168.XXX.XXXだと思います。)

設定値が、上記の通りになっていれば、DHCPによる再割り当て失敗の可能性があります。
この場合、該当機器のDHCPリース時間を無制限に設定すれば、回避できます。
(過去に、自分もそのような状態になったことがあります)

他に考えられる不具合は、LANカード異常が考えられますが、この場合は、交換で対処できます。
補足コメント
pachi_id

お礼率 9% (2/21)

ただいま検証致しました。
DHCPリース時間ですが、24時間となっていました。
DHCPサーバを有効にするにチェックを入れ、
アドレス割当パターンは、開始IPアドレス 192.168.1.11、ネットマスク 255.255.255.0 に固定している状態です。
一応、リース時間を無制限に設定しました。
これから様子を見てみます。

IPアドレスですが、正常時、192.168.1.12
         切断時、192.168.1.12 と、変わりませんでした。

これでダメならやはりLANカード増設でしょうか・・・?
投稿日時:2010/10/05 20:58
17件中 1~10件目を表示
結果を報告する
このQ&Aにはまだコメントがありません。
あなたの思ったこと、知っていることをここにコメントしてみましょう。
関連するQ&A

その他の関連するQ&Aをキーワードで探す

ピックアップ

ページ先頭へ