• ベストアンサー
  • 困ってます

SentOS 5.4インストールについて

SentOS 5.4インストールについて 私、最近Linuxについて勉強しております。 最初は構築されたPCでコマンドの勉強等をやり、 各アプリケーションのインストール等をやりました。 今回、初めて一からサーバーを構築しようと、 インターネットに載っている情報を元に、 SentOS5.4をインストールしようと思いました。 CDを作成し、 手順どおりに作業をしていたんですが、 5枚目のCDを入れて、再起動した後、 インストールの初期画面になると思っていたのですが、 下記のエラーから動かなくなりました。 これは、PCのスペックが足りないというエラーなのでしょうか? 本当にすみませんが、 わかる方いらっしゃいましたら、 教えていただけると幸いです。 //ここからエラー画面 root(hd0,0) Filesystem type is ext2fs, partition type 0x83 kernel /vmlinuz-2.6.18-164.e15 ro root=/dev/VolGroup00/LogVo100 rhgb quiet [Linux-bzImage,setup=0x1e00, size=0x1c31b4] initrrd /initrd-2.6.18-164.e15.img [Linux-initrd @ 0xf7e7000, 0x2e8598 bytes] Memory for crash kernel (0x0 to 0x0) notwithin permissible range Red Hat nash version 5.1.19.6 starting //ここから少し時間がかかり下記エラー文になります。 insmod: error inserting '/lib/ext3.ko': -1 Unkown symbol in module insmod: error inserting '/lib/ata_piix.ko': -1 Unkown symbol in module insmod: error inserting '/lib/dm-mirror.ko': -1 Unkown symbol in module insmod: error inserting '/lib/dm-region_hash.ko': -1 Unkown symbol in module insmod: error inserting '/lib/dm-raid45.ko': -1 Unkown symbol in module Reading all physical volumes. This may take a while... Found volume group "VolGroup00" using metadatatype lvm2 2 logical volume(s) in volume group "VolGroup00" now active mount: error mounting /dev/root on /sysroot as ext3: No such device setuoroot: moving /dev failed: No such file or derectory setuoroot: error mounting /proc: No such file or derectory setuoroot: error mounting /sys: No such file or derectory switchroot: mount failed: No such file or derectory Kernel panic - not syscing: Attempted to kill init? //上記のエラー画面の2行下でタイムラインが止まっており、  何も入力もできず、うんともすんと言いません・・・。 いつも、お世話になりっぱなしで、本当にすみませんが、 上記のエラー文が何を意味していて、 どうすれば解決するのかをご教授いただきたいです。 何卒よろしくお願いいたします。

共感・応援の気持ちを伝えよう!

  • 回答数8
  • 閲覧数930
  • ありがとう数12

質問者が選んだベストアンサー

  • ベストアンサー
  • 回答No.8
  • pakuti
  • ベストアンサー率50% (317/631)

/initrd-2.6.18-164.e15.img が壊れているのでは? インストール中にこけたのか HDDの不良によるものなのか。 insmod: error inserting '/lib/ext3.ko': -1 Unkown symbol in module insmod: error inserting '/lib/ata_piix.ko': -1 Unkown symbol in module insmod: error inserting '/lib/dm-mirror.ko': -1 Unkown symbol in module insmod: error inserting '/lib/dm-region_hash.ko': -1 Unkown symbol in module insmod: error inserting '/lib/dm-raid45.ko': -1 Unkown symbol in module ここは、/boot領域に保存されている、起動用のイメージからHDDやファイルシステム関連のモジュールの呼び出しに失敗しているようです。 それ以降のエラーに関してはモジュールが組み込まれていないための エラーと思われます。 単純な切り分けとしては、再度インストールしなおして 成功するか失敗するかを確認でしょうか。

共感・感謝の気持ちを伝えよう!

質問者からのお礼

ご解答ありがとうございました。 HDDの問題なのでしょうか? 再インストールに関しては、 同じCDですが、インストールは3回行いましたが、 3回ともエラーが出て、 先に進めませんでした。 とりあえず、高スペックの「PC」を探して、 それからもう一度頑張ろうと思います。 本当にありがとうございました。

関連するQ&A

  • Debian+カーネル3.0.1での起動時のエラー

    DebianSqueeze(i386)を使用しています。 先日、カーネルを2.6.39.3から3.0.1に変更しました。 そしたら起動時に省電力機能のモジュール読み込みで次のようなエラーが出るようになりました。 Loading cpufreq kernel modules... FATAL: Error Inserting cpufreq_nforce2 (/lib/modules/3.0.1/kernel/drivers/cpufreq/cpufreq-nforce2.ko) No such Device FATAL: Error Inserting longhaul (/lib/modules/3.0.1/kernel/drivers/cpufreq/longhaul.ko) No such Device FATAL: Error Inserting longrun (/lib/modules/3.0.1/kernel/drivers/cpufreq/longrun.ko) No such Device FATAL: Error Inserting p4_clockmod (/lib/modules/3.0.1/kernel/drivers/cpufreq/p4_clockmod.ko) No such Device FATAL: Error Inserting gx_suspmod (/lib/modules/3.0.1/kernel/drivers/cpufreq/gx_suspmod.ko) No such Device FATAL: Error Inserting speedstep_ich (/lib/modules/3.0.1/kernel/drivers/cpufreq/speedstep-ich.ko) No such Device FATAL: Error Inserting speedstep_centrino (/lib/modules/3.0.1/kernel/drivers/cpufreq/speedstep-centrino.ko) No such Device FATAL: Error Inserting speedstep_smi (/lib/modules/3.0.1/kernel/drivers/cpufreq/speedstep-smi.ko) No such Device FATAL: Error Inserting acpi_cpufreq (/lib/modules/3.0.1/kernel/drivers/cpufreq/acpi-cpufreq.ko) No such Device modprobeでacpi-cpufreqを読み込もうとすると FATAL: Error inserting acpi_cpufreq (/lib/modules/3.0.1/kernel/drivers/cpufreq/acpi-cpufreq.ko): Device or resource busy とのエラーが出ますが、p4-clockmodは正常に読み込めます。 このままでも使用には問題がないのですが、なにかすっきりしないので解決できないでしょうか。 ちなみにPCはCPU Core2Duo E4400、M/B P35T-A、メモリ 4GBでEISTはオフです。 同じくDebianSqueezeでPentium4のPCでは3.0.1でも上のようなエラーは出ませんでした。 カーネルの設定はデバイスドライバをある程度削ってるぐらいです。 よければ御知恵をお貸し下さい。お願い致します。

  • linux intel グラフィックドライバインストールNG

    すみません!!!たすけてください!!!! Suse10 にグラフィックドライバのintel IEGD入れようとしたら最後にエラーになりました。 何がわるいのでしょうか? >modprobe iegd_mod FATAL: Error inserting iegd_mod (/lib/modules/2.6.16.60-0.37_f594963d-default/kernel/drivers/char/agp/iegd_mod.ko): Unknown symbol in module, or unknown parameter (see dmesg) 以下実施した手順です。intelのマニュアル通りしました。 1 tar-xvzf IEGD_9_0_2_Linux.tar.gz 2 cd IEGD_9_0_2_Linux/Driver/IEGD_9_0_2_Linux 3 cp *.so /usr/X11R6/lib/modules 4 cp libXiegd_escape.so.2.0.0 /usr/X11R6/lib 5 cd /usr/X11R6/lib/ 6 ln -s libXiegd_escape.so.2.0.0 libXiegd_escape.so 7 ln -s libXiegd_escape.so.2.0.0 libXiegd_escape.so.2 8 ldconfig 9 make cloneconfig 10 make scripts && make prepare 11 cd /lib/modules/2.6.16.60-0.37_f594963d-default/ 12 \rm -rf build 13 ln -s /usr/src/linux-2.6.16.60-0.37_f594963d build 14 cd IEGD_Patches/IKM/ 15 ./install.sh 16 depmod -a 17 modprobe iegd_mod 18 depmod -a 19 modprobe iegd_mod FATAL: Error inserting iegd_mod (/lib/modules/2.6.16.60-0.37_f594963d-default/kernel/drivers/char/agp/iegd_mod.ko): Unknown symbol in module, or unknown parameter (see dmesg) 途中でエラーは出てなかったです。助言お願いします。

  • nVIDIAの「GT 240」用ドライバがインストールできません。

    nVIDIAの「GT 240」用ドライバがインストールできません。 $ wget http://jp.download.nvidia.com/XFree86/Linux-x86/256.35/NVIDIA-Linux-x86-256.35.run で保存し、 init 3 でランレベルを変更し、 chmod +x *****.run sh 「*****.run」 で実行しました。 インストーラが起動しましたが、途中でエラーが出てインストールできませんでした。 ログファイルを見ると、こんなエラーがでていました。 ERROR: Unable to load the kernel module 'nvidia.ko'. This happens most frequently when this kernel module was built against the wrong or improperly configured kernel sources, with a version of gcc that differs from the one used to build the target kernel, or if a driver such as rivafb/nvidiafb is present and prevents the NVIDIA kernel module from obtaining ownership of the NVIDIA graphics device(s), or NVIDIA GPU installed in this system is not supported by this NVIDIA Linux graphics driver release. Please see the log entries 'Kernel module load error' and 'Kernel messages' at the end of the file '/var/log/nvidia-installer.log' for more information. -> Kernel module load error: insmod: error inserting './kernel/nvidia.ko': -1 No such device どうやらカーネルにドライバを組み込めなかったようなのですが、 どうすればよいでしょうか?

その他の回答 (7)

  • 回答No.7
  • Wr5
  • ベストアンサー率53% (2177/4070)

CPU速度が遅いのは、まぁ待っていればいいとして… メモリが少ないとGUIでインストールできない場合もあるのでご注意を。 # 今回はとりあえずGUIでインストールできたようですが……。 「低スペックでも…」というのはCUIで使うか、ひたすら軽いウィンドウマネージャを使用した場合です。 GNOMEなどのデスクトップ環境を使う場合、一昔前のWindowsマシン程度のスペックは必要でしょう。 「上司から~」ということは会社で使用でしょうか? 自宅で使用で、自宅のPCがある程度のスペックがあれば、VMWareなどの仮想マシンを使う…という方法もあります。 # 使い慣れているWindowsで調べながらさわれるので、スペックが許せばこちらの方がよいでしょう。 # ちなみに、No.6の回答も仮想マシンでCD-ROM起動させて確認。

共感・感謝の気持ちを伝えよう!

質問者からのお礼

本当にご回答ありがとうございます。 一応インストールはGUIで全て行いました。 やはりそこそこのスペックは大切なんですね。 ちなみに、会社で使用するわけではないのですが、 システム会社として、UNIXもそろそろ勉強したくて、 今回1からインストール・構築をしてみようと思って、 Linuxが搭載できるPCを探していたら、 会社にあった使っていないPCをいただいた感じです。 自宅にもPCはあるのですが、 スペックも低く、現状の動きすら不安定です。 VMWareなどの仮想マシンを会社のPCに入れることも考えたのですが、 もし何かあった場合、さすがに怖いので、 できれば壊れてもいいようなPCでやろうと思っております。 返答、本当にありがとうございました。

  • 回答No.6
  • Wr5
  • ベストアンサー率53% (2177/4070)

>CDをチェックするというのは、どういう意味でしょうか? 起動時、「boot:」の表示があるハズですが、 [F1-Main][F2-Options][F3-General]~ という表示があります。 F2キーを押すと、メディアチェックする場合の起動方法の説明が表示されます。 >できればSentOSをインストールしたいと思っております。 「CentOS」です。 他の回答者の方が正しく書いているのですから、間違えて覚えないようにした方がよいでしょう。 # googleでは「SentOS」で検索しても「CentOS」の情報引っかかりますけどね…。 イメージファイルをDLした時にMD5SUMなりSHA1SUMなりでファイルが壊れていないか確認していない…んでしょうか? # WindowsでもMD5SUMやSHA1SUMをチェックできるソフトはあります。 「MD5SUM」「SHA1SUM」ってなに? ということでしたら検索して下さい。 なお、MD5SUMでファイルが壊れていなくても、メディアに焼き付けたときに壊れる場合もありますのでメディアチェックはやった方がよいでしょう。 # 記録面にゴミが付着していたりすると、レーザーで焼けないのでその箇所はエラーになってしまいます。 # ある程度まではエラー訂正がありますが…。

共感・感謝の気持ちを伝えよう!

質問者からのお礼

凄く丁寧な回答ありがとうございます。 わからない言葉は、全部調べてみます。 それと、「CentOS」でした。 完全に「SentOS」で覚えてしまっておりました。 本当に申し訳ありません。 (イメージをダウンロードした時に「CentOS」という文字を見ていたのに・・・) 一度、メディアチェックをしてみようと思います。 本当にありがとうございました。

  • 回答No.5
  • mimzy
  • ベストアンサー率33% (32/96)

エラーをからすると一部のファイルがコピーされてないよです。 ダウンロードした際、check sumを確認しないとISOイメージが完全にダウンロードされな かった可能性があります。check sum自体、何なのかお分かりにならないと思います。 >CDの中身まで確認していただける機能があるのでしょうか? その通りです。CD自体に問題がある場合、インストールは完全に成功しません、 表面上は終了しますが、インストールログをみるとエラーになってると思います。 そうなると今回のようにブートしません。 インストールCDをブートさせると確かCentosにもメディアチェックのメニュがあったと思うのですが。

共感・感謝の気持ちを伝えよう!

質問者からのお礼

ご返答ありがとうございます。 それでは、CDを一度焼きなおして、 もう一度インストールしてみます。 インストールログは、どこで見れるのでしょうか? とりあえず、私にはまだまだインストール・サーバ構築は 敷居が高すぎたようですね。。。 コマンド打って作業しているだけで勝手に自信がついて、 できると思っておりましたが、コマンドすら打てない状況では、 私には、成すすべがありませんでした。 ちなみに、メディアチェックするメニューがどこにあるかもわかりませんでした。 check sum等もう少し勉強を頑張ります。 本当にご返信ありがとうございました。

  • 回答No.4
  • yakan9
  • ベストアンサー率54% (2074/3836)

メモリ不足の可能性が高いようですね。 256MBでは、動かないかもしれません。 WEB検索しても、256MBで、ネットワークインストールできないとかがありました。 CentOSのディストリビュションにこだわらなければ、下記がお勧めです。 パピーリナックスだと、余裕でいけると思います。 Puppy Linuxは、パピーリナックス日本語版 http://openlab.ring.gr.jp/puppylinux/ ここでダウンロードもできます。 メモリ、96MBでも起動したという実績報告も載っているので大丈夫です。

共感・感謝の気持ちを伝えよう!

質問者からのお礼

ご回答本当にありがとうございます。 やはり、スペックの環境の問題もあるのでしょうか・・・? 上司からLinuxを勉強するならと渡されたノートPCだったので、 インストールはできると思っていたのですが、 次の給料日で自分でPCを購入してから、 もう一度試して試してみますね。 ちなみに、現在購入している参考書等が、 SentOSですので、 できればSentOSをインストールしたいと思っております。 今の知識でいろんなことを勉強しようとすると、 逆に危険な気もしますので、 もう少しUNIX系OSに慣れたら パピーリナックスにもチャレンジしてみようと思います。 もう少し原因を調べて、それでも解決しなかったら、 PCのスペックが原因だと信じて新しくPCを購入するまでは、 UNIXは諦めます。。。 本当にありがとうございました。

  • 回答No.3
  • mimzy
  • ベストアンサー率33% (32/96)

インストール時にメディアをチェックするメニューがあると思います、 それでCD5枚をすべてチェックしてみてください。

共感・感謝の気持ちを伝えよう!

質問者からのお礼

ご回答ありがとうございます。 インストール時にCDが合計6枚あるかの確認はされましたが、 CDをチェックするというのは、どういう意味でしょうか? 私、ダウンロードしたイメージをCDに焼いて、 そのCDが全てあることは確認しました。 CDの中身まで確認していただける機能があるのでしょうか? 知識がなさすぎて申し訳ございません。 本当にありがとうございます。 もしよろしかったら、CDのチェックの意味だけ教えていただけると幸いです。 それでは、よろしくお願いいたします。

  • 回答No.2
noname#110816

installは完了してGRUBは起動していることが解ります。 問題のエラーは mount: 行の部分以降からでしょう。(それ以前の行は致命的エラーではないでしょう) PC環境が全く解りませんので何とも言えませんが、 ・RAID構成ですか ・sata HDDですか ・他のPCからアクセスできる環境ならfstabを確認してみてください。 ・テキストモードで起動しても同じエラーになるとは思いますが、確認のためGRUBのkernel行の末尾に 3 を追加して試してみてはどうですか。

共感・感謝の気持ちを伝えよう!

質問者からのお礼

ご回答本当にありがとうございます。 PC環境は、 CPU 900MHz メモリ 256MB ハードディスク 30GB の古いノートパソコンです。 SentOSを入れるまでは、WindowsXPが搭載されておりました。 RAID構成や、sata HDDは本当に申し訳ありませんが、 わかりかねております・・・。 本当に知識がなくて申し訳ないです。 fstabに関しても、何のことかわかりませんので、 一度勉強させていただきます。 ちなみに、kernel行の末尾に「3」を追加するには、どのタイミングや、 どこで追加したらいいのでしょうか? 現状、何も入力できませんので・・・。 本当に無知識で申し訳ありません。 そして、本当にご親切に回答していただき、ありがとうございました。

  • 回答No.1
  • yakan9
  • ベストアンサー率54% (2074/3836)

> これは、PCのスペックが足りないというエラーなのでしょうか? なぜそう判断されたのでしようか。 そんなに低スペックのパソコンに入れたのでしようか。 どの程度のマシン仕様かも不明では、何も回答できないところですが、 気づいたところだけを記載しておきます。 内蔵HDDの容量は何GBですか。 CentOS5.4であれば、20GBあれば十分だと思います。 パーティションをカスタム指定しないで、/パーティションだけのようで、できれば、 カスタム指定して、/bootパーティション、/パーティション、swapパーティションを定義した方が、 LVM(Logical Volume Manager)構成をとらせない方が、デバッグしやすくなります。 /bootパーティション サイズ:100MB Ext3フォマット /パーティション サイズ:20GB Ext3フォマット swapパーティション サイズ:2GB 特にフォマットの指定はなし  HDDに余裕があれば、大きくてもかまわない。 エラーメッセージから判断すると、他のOSとのデュアルブートではないようですが、 その確認も補足願いたい。

共感・感謝の気持ちを伝えよう!

質問者からのお礼

ご回答ありがとうございます。 私のPCのスペックですが、 CPU 900MHz以下 メモリ 256MB以下 ハードディスク 30GB以下です。 あまりにも古いノートPCです。 しかし、WindowsXPが載っていたので、 SentOSも載せることができるのかなと思っておりました。 しかし、インターネットで調べたSentOSの推奨スペックが、 CPU 1.5GHz 以上 メモリ 512MB 以上 ハードディスク 10GB 以上の空き容量 とありましたので、てっきりこれが原因かと思っておりました。 正直パーティションのカスタムの方法がわからないです。 インターネットで載っていた手順書どおりに、 「選択したドライブ上の全てのパーティションを削除して、デフォルトのレイアウトを作成します」 でインストールし、次のパーティション設定確認の画面では、 そのまま「次へ」を押してインストールいたしました。 他のOSは入れておりませんので、 デュアルブートではなおと思っております。 本当に素人意見で申し訳ありません。 それなのに、ご回答していただいて本当にありがとうございます。

関連するQ&A

  • Linux insmod

    linux超初心者で。途方に暮れています。教えてください。m()m LINUX OSのパソコンに無線LANボードを差込み、 メーカー提供のデバイスドライバをinsmodコマンドで組み込もうとしたら 下記エラーが大量に出ました。 これは何のエラーなのでしょうか?(TT) ------------------------------------------------------------ ~ # insmod LINUX.o Using /lib/modules/2.4.20/kernel/drivers/net/wireless/LINUX.o insmod: unresolved symbol MgntActQuery_802_11_FRAGMENTATION_THRESHOLD insmod: unresolved symbol InterruptRecognized8180 insmod: unresolved symbol NicIFAllocateMemory insmod: unresolved symbol GlobalDebugComponents insmod: unresolved symbol NicIFHandleInterrupt insmod: unresolved symbol MgntActQuery_802_11_TX_RATES insmod: unresolved symbol GlobalDebugLevel insmod: unresolved symbol MgntActSet_802_11_SSID insmod: unresolved symbol NicIFFreeMemory insmod: unresolved symbol ・・・・以下同様のエラーがたくさん。

  • LINUX INSMOD

    QNo.1907291(この問題は解決)の続きです。 教えてください。 リアルテックのRTL8185L無線LANボードをLINUX OSのPCIボードに組み込もうとしています。 デバイスドライバ(rtldrv.o)を用意し、insmodした所、 ~ # insmod rtldrv.o Using /lib/modules/2.4.20/kernel/drivers/net/wireless/rtldrv.o insmod: init_module: rtldrv: No such device 何ででしょうか?(TT)

  • 自作モジュールを組み込む

    以下に何もしない何もしないカーネルモジュールを組み込みたいのですが、うまくいきません。 以下のソースをコンパイルします。 #define MODULE #include <linux/module.h> #include <linux/kernel.h> int init_module(void) { printk("my module installed\n"); return 0; } void cleanup_module(void) { printk("my module removed\n"); } そして、コンパイル $gcc -c sample.c #insmod sample.o とすると、 insmod: error inserting 'sample.o': -1 Invalid module format と怒られてしまいます。 モジュールフォーマットが無効と言われますが、ソースが間違っているのでしょうか。 カーネルのメッセージを調べると、 $dmesg ... No module found in object と、やっぱり組み込まれていません。 何がいけないのか、御知恵をくださいお願いします。 追記: 自分の環境を以下に記載させていただきます。 Linux localhost.localdomain 2.6.11-1.1369_FC4 #1 Thu Jun 2 22:55:56 EDT 2005 i686 athlon i386 GNU/Linux

  • Linuxの入ったHDDをUSBから起動したい

    元々デスクトップPCにて内蔵で使っていたHDDを、 変換ケーブルでUSB接続にてノートPCに繋いでいます(CentOS5)。 BIOSの設定でそのHDDから起動するようにし、 まずGRUBが立ち上がり、OSの選択画面にはいけるようになりました。 そこでOSを選択し、起動時の、ログがたくさんブワワーっと流れるところで エラーが出てしまい、そこで止まってしまいます。 途中で止まってしまうので全てのログを見る事はできませんが、 止まった時に画面に表示されているログは下記のようになっております。 ------------------------------------------------------ input: USB HID v1.10 Mouse [Logitech Optical USB Mouse] on usb-0000:00:1d.1-2 Making device-mapper control node Scanning logical volumes Reading all physical volumes. This may take a while... No volume groups found Activating logical volumes Volume group "VolGroup00" not found Trying to resume from /dev/VolGroup00/LogVol01 Unable to access resume device. Creating root device. Mounting root filesystem. mounnt: could not find filesystem '/dev/root' Setting up other filesystems. Setting up new root fs setuproot: moving /dev failed: No such file or directory no fstab.sys, mounting internal defaults setuproot: error mounting /proc: No such file or directory setuproot: error mounting /sys: No such file or directory Switching to new root and running init. unmounting old /dev unmounting old /proc unmounting old /sys switchroot: mount failed: No such file or directory Kernel panic - not syncing: Attempted to kill init! ------------------------------------------------------ 一見すると、 VolGroup00 /dev /proc /sys 等のファイルやディレクトリが見つからなくて、 マウントできませんでした、というエラーの様です。 しかし、こちらのHDDを再度デスクトップPCに SATAでの接続をして起動すると、きちんとOSが立ち上がり、 正常動作してくれます。 USB接続のHDDからブートさせるには、 BIOSの設定以外にしなければならない事などありますでしょうか? 宜しくお願い致します。

  • サーバ(OS:CentOS 5.5)が起動しません

    サーバ(OS:CentOS 5.5)が起動しません サーバの電源を入れたところ、 Can't find ext3 filesystem on dev dm-0. mount: error mounting /dev/root on /sysroot as ext3: Invalid argument setuproot: moving /dev failed: No such file or directory setuproot: error mounting /proc: No such file or directory setuproot: error mounting /sys: No such file or directory switchroot: mount failed: No such file or directory kernel panic - not syncing: Attempted to kill init! kernel direct mapping tables up to 128000000 @ 10000-16000 と表示され、OSが起動しません。 どのような対処を行えば回復できるのでしょうか? 最悪、中のデータだけでも取り出したいのですが (その後、OSの再インストールを行ないます) 現時点までで、 ・linux rescueコマンド (システムを/mnt/sysimage にマウントするところで失敗) ・シングルモードでの起動 (kernel /vmlinuz-2.6.18-92.1.6.el5 ro root=/dev/VolGroup00/LogVol00 rhgb quietの後にsingle を指定したが、結果は同じ) で失敗しております OS:CentOS 5.5 以上、お解かりになられる方がおりましたら、 宜しくお願い致します

  • Ubuntu 9.04 WLI-UC-GN に関して

    Ubuntu 9.04 Linux初日の者です。 http://d.hatena.ne.jp/Akineko/20090511/1242059686#c 上記URLを参考してコマンドを入力していたところどうしても $ sudo lnsmod rt3070sta.ko を入力後出来てないようなのです。 また参考ページにはinsmodと説明されております。 以上 2つのコマンドをそれぞれ入力後はこのような結果になりました。 $ sudo lnsmod rt3070sta.ko sudo: lnsmod: command not found $ sudo insmod rt3070sta.ko [sudo] password for ubuntu: insmod: error inserting 'rt3070sta.ko': -1 File exists 他のフォーラムやページでもinsmodとlnsmodを見ます。 これはそれぞれ独立したコマンドなのでしょうか?

  • GTK+2.2.0のインストールエラー

    gtk+-2.2.0をインストールしようとしたのですが、インストールだけにエラーが出て完了しません。以下にログを書きます。(エラーらしきところのみにします途中略してます) ーーーーーここからーーーーー Libraries have been installed in: /opt/valox//lib/gtk-2.0/2.4.0/immodules If you ever happen to want to link against installed libraries in a given directory, LIBDIR, you must either use libtool, and specify the full pathname of the library, or use the `-LLIBDIR' flag during linking and do at least one of the following: - add LIBDIR to the `LD_LIBRARY_PATH' environment variable during execution - add LIBDIR to the `LD_RUN_PATH' environment variable during linking - use the `-Wl,--rpath -Wl,LIBDIR' linker flag - have your system administrator add LIBDIR to `/etc/ld.so.conf' See any operating system documentation about shared libraries for more information, such as the ld(1) and ld.so(8) manual pages. ーーー略ーーー Cannot load module /opt/valox//lib/gtk-2.0/2.4.0/immodules/im-ipa.so: /opt/valox//lib/gtk-2.0/2.4.0/immodules/im-ipa.so: cannot open shared object file: No such file or directory /opt/valox//lib/gtk-2.0/2.4.0/immodules/im-ipa.so does not export GTK+ IM module API: /opt/valox//lib/gtk-2.0/2.4.0/immodules/im-ipa.so: cannot open shared object file: No such file or directory Cannot load module /opt/valox//lib/gtk-2.0/2.4.0/immodules/im-thai-broken.so: /opt/valox//lib/gtk-2.0/2.4.0/immodules/im-thai-broken.so: cannot open shared object file: No such file or directory /opt/valox//lib/gtk-2.0/2.4.0/immodules/im-thai-broken.so does not export GTK+ IM module API: /opt/valox//lib/gtk-2.0/2.4.0/immodules/im-thai-broken.so: cannot open shared object file: No such file or directory Cannot load module /opt/valox//lib/gtk-2.0/2.4.0/immodules/im-ti-er.so: /opt/valox//lib/gtk-2.0/2.4.0/immodules/im-ti-er.so: cannot open shared object file: No such file or directory /opt/valox//lib/gtk-2.0/2.4.0/immodules/im-ti-er.so does not export GTK+ IM module API: /opt/valox//lib/gtk-2.0/2.4.0/immodules/im-ti-er.so: cannot open shared object file: No such file or directory Cannot load module /opt/valox//lib/gtk-2.0/2.4.0/immodules/im-ti-et.so: /opt/valox//lib/gtk-2.0/2.4.0/immodules/im-ti-et.so: cannot open shared object file: No such file or directory /opt/valox//lib/gtk-2.0/2.4.0/immodules/im-ti-et.so does not export GTK+ IM module API: /opt/valox//lib/gtk-2.0/2.4.0/immodules/im-ti-et.so: cannot open shared object file: No such file or directory Cannot load module /opt/valox//lib/gtk-2.0/2.4.0/immodules/im-viqr.so: /opt/valox//lib/gtk-2.0/2.4.0/immodules/im-viqr.so: cannot open shared object file: No such file or directory /opt/valox//lib/gtk-2.0/2.4.0/immodules/im-viqr.so does not export GTK+ IM module API: /opt/valox//lib/gtk-2.0/2.4.0/immodules/im-viqr.so: cannot open shared object file: No such file or directory make[4]: *** [install-data-hook] エラー 1 make[4]: 出ます ディレクトリ `/root/GTK2/gtk+-2.8.17/modules/input' make[3]: *** [install-data-am] エラー 2 make[3]: 出ます ディレクトリ `/root/GTK2/gtk+-2.8.17/modules/input' make[2]: *** [install-am] エラー 2 make[2]: 出ます ディレクトリ `/root/GTK2/gtk+-2.8.17/modules/input' make[1]: *** [install-recursive] エラー 1 make[1]: 出ます ディレクトリ `/root/GTK2/gtk+-2.8.17/modules' make: *** [install-recursive] エラー 1 ーーーーーここまでーーーーー 以上です。 エラーログを見ていると、何かのソフトのライブラリがインストールされていないのかと思い、 gtk+-devel gtk2+-devel を、インストールしましたが、変化ありませんでした。 CPPFLAGS="-I/opt/valox/include" LDFLAGS="-L/opt/valox/lib" PKG_CONFIG_PATH="/opt/valox/lib/pkgconfig" export CPPFLAGS LDFLAGS PKG_CONFIG_PATH LD_LIBRARY_PATH="/opt/valox/lib" PATH="/opt/valox/bin:$PATH" export LD_LIBRARY_PATH PATH を実行してから ./configure && make && checkinstall で、エラーが出ます。 何が足りないのかさっぱりです。エラーの意味もわかっていません。こんな状態ですがどなたか、解決法を、ご教授願えませんでしょうか。お願いいたします。 今回のことは、私は素人なので、できるだけ具体的に指示して下さい。箇条書きのような形式でもかまいません。よろしくお願いします。 補遺:環境は、redhat9 kernel-2.4.30古いのを使っているのは、PCが古いのでスペック上を考慮したものです。

  • Mailmanインストールについて

    CentOS5.5にMailman 2.1.14+j6をインストールしているのですが、以下の画面が表示されます。 # ./configure --prefix=/usr/local/mailman --with-python=/usr/local/python/bin/python --with-mail-gid=mailman --with-cgi-gid=apache # make # make install Compiling /usr/local/mailman/Mailman/versions.py ... ERROR:root:code for hash sha224 was not found. Traceback (most recent call last): File "/usr/local/python/lib/python2.7/hashlib.py", line 139, in <module> globals()[__func_name] = __get_hash(__func_name) File "/usr/local/python/lib/python2.7/hashlib.py", line 91, in __get_builtin_constructor raise ValueError('unsupported hash type %s' % name) ValueError: unsupported hash type sha224 ERROR:root:code for hash sha256 was not found. Traceback (most recent call last): File "/usr/local/python/lib/python2.7/hashlib.py", line 139, in <module> globals()[__func_name] = __get_hash(__func_name) File "/usr/local/python/lib/python2.7/hashlib.py", line 91, in __get_builtin_constructor raise ValueError('unsupported hash type %s' % name) ValueError: unsupported hash type sha256 ERROR:root:code for hash sha384 was not found. Traceback (most recent call last): File "/usr/local/python/lib/python2.7/hashlib.py", line 139, in <module> globals()[__func_name] = __get_hash(__func_name) File "/usr/local/python/lib/python2.7/hashlib.py", line 91, in __get_builtin_constructor raise ValueError('unsupported hash type %s' % name) ValueError: unsupported hash type sha384 ERROR:root:code for hash sha512 was not found. Traceback (most recent call last): File "/usr/local/python/lib/python2.7/hashlib.py", line 139, in <module> globals()[__func_name] = __get_hash(__func_name) File "/usr/local/python/lib/python2.7/hashlib.py", line 91, in __get_builtin_constructor raise ValueError('unsupported hash type %s' % name) ValueError: unsupported hash type sha512 更新の必要はありません. 上記のメッセージは、エラーなんでしょうか? Mailmanを動作させると、特に問題なく動作しているように見えます。 また、pythonのインストールは、下記の様にしています。 # ./configure \ --prefix=/usr/local/Python-2.7.2 \ --disable-ipv6 # make # make install ネットで色々調べてたのですが、全くわかりませんでした。 勉強不足で申し訳ありませんが、教えて頂けたら幸いです。 よろしくお願いします。

  • NICが認識されません

    最近RedHatからFedora Coreにアップグレードしました。それまで、ネットワークはeth0がインターネット、eth1がLANという構成で、問題なく運用していたのですが、アップグレード後、eth1だけが認識されなくなりました。 GUIのネットワーク設定をみる限り、ハードウェアの存在は認識されているようなのですが、ネットワーク起動のさいnatsemi doesn't seem to be presentというエラーがでます。ドライバだろうと思ったのですが、natsamiというのは当方のNIC(ネットギアFA-311)のドライバで間違いなさそうで、またシステムにも存在しているようなのです。もっとも、modprobeでモジュールを組みこもうとすると Error inserting natsemi (/lib/modules/2.6.5-1.358/kernel/drivers/net/natsemi.ko): Unknown symbol in module, or unknown parameter (see dmesg) というエラーがでます。 こうした場合新たにドライバを入手してコンパイルするしか方法がないのでしょうか(挑戦しようとしましたがディレクトリ構成などがRedHatと違うようで、見当がつきませんでした)。 自分自身確信がないことから曖昧に聞こえることと思います。大体の方向性や他の参照先でもかまいませんので、見当のつくかたがいらっしゃいましたら、教えて戴けると助かります。 宜しくお願いします。

  • CentOS 5でNetdumpの使用

    既存環境の絡みもあり、CentOS v5.3でKdumpではなく netdumpの利用を考えています。 サーバを既に建てられていて、CentOS v4のnetdumpは 正常に取得できています。 CentOS v5.3で以下を作業を実施し、起動しましたがエラーになります。 ・netdumpパッケージのインストール(netdump-0.7.16) ・User/Passwd設定 ・/etc/sysconfig/netdumpでサーバ指定 ・クライアントの公開キーをサーバへ登録 ・netdumpサービス起動 (ここで以下のエラー) #service netdump start netdump を初期化中 FATAL: Module netdump not found. [失敗] netconsole を初期化中: FATAL: Error inserting netconsole (/lib/modules/2.6.18-128.el5/kernel/drivers/net/netconsole.ko): Unknown symbol in module, or unknown parameter (see dmesg) # dmesg ・・・ netconsole: Unknown parameter `netlog' netconsole: Unknown parameter `netlog' netconsole: Unknown parameter `netlog' netconsole: not configured, aborting アドバイスよろしくお願いします。