• 締切済み
  • 暇なときにでも

Netscapeインストール後、動作しない

Vine Linux2.6をインストールした後に Netscape7.02をインストールしました。 インストール直後に立ち上がらずに run-moziila.sh: Cannot execute /usr/lib/mozilla-1.2.1/netscape-bin と表示されました。 よって/usr/local/netscapeで./netscapeをしたときも 同じエラーが表示されます。 run-mzilla.sh内の記述を参照したところ MOZ_APPUNNER_NAME="./mozilla-bin" とありました。 ls -aでみたところmozilla-1.2.1ディレクトリに mozilla-binはなかったのでそのために立ちあがらない のだとおもわれます。 対処法をご存知の方がいらっしゃいましたら教えてください。 vine linux 2.6 インストール手順 1./tmpにnetscape-i686-pc-linux-gnu-installer.tar.gz をDL 2.gzip -d netscape~ 3.tar -xvf netscape~.tar 4.cd netscape-installer 5../netscape-installerで/usr/local/netscapeにインストール

noname#6323
noname#6323

共感・応援の気持ちを伝えよう!

  • 回答数1
  • 閲覧数78
  • ありがとう数1

みんなの回答

  • 回答No.1

こんにちは。もしかしてインストールする時に、root でやってませんか? root で、もしくは、su - 等で、root 権限でやってしまうと、パーミッションの関係で root 以外使えなくなっちゃいますので、ネスケを使うユーザーで、インストールをやった方がいいと思いますが。

共感・感謝の気持ちを伝えよう!

質問者からの補足

ご回答ありがとうございます。 はっきりとは覚えていませんが su -でやってしまったかもしれません。 以後気をつけます。 この場合root以外が使えない、とご指摘 がありますがsu -でも使えていないので 他にも原因があるかと思います。 その他助言ございましたらお願いいたします。

関連するQ&A

  • netscapeのインストール

    netscapeをインストールしようと思い、 ​http://archive.netscape.com/releases​ から、7.1をインストールしました。そして、 tar xvfz netscape-i686-pc-linux-gnu-installer.tar.gz cd netscape-installer ./netscape-installer としたのですが、./netscape-installerのところで、 export: 41: Illegal option -n と出て、インストールがされません(?)。 どのようにすればよいのでしょうか?

  • インストール済みかどうか&ファイル展開のコマンド

    SunOS5.6を使っています。 ものすごく初心者なので、UNIXコマンドをネットで検索しながら触っています。 autoconf-2.13.tar.gzをインストールしようと思いネットで検索していたら ----------------------------- $ cd /usr/local/src  $ autoconf-2.13.tar.gz  $ tar -xvzf autoconf-2.13.tar.gz 又は # gzip -cd autoconf-2.13.tar.gz | tar -xvf - ------------------------------- とあったのでautoconf-2.13.tar.gzを展開したいのですが、どうやったら展開できるのか分からず困っています。 というのも、 tar -xvzf 、gzip -cd としてもコマンドが見つかりません。 いろいろ調べまわっても、いろんな展開方法があり試してやっているのですが、よくわかりません。 *.zipというファイルであれば展開を自分で出来ましたが、、、*.tar.gzとなる拡張子の展開方法が分かりません。 その前にautoconf自体がインストール済みであるかどうか、どうやってコマンドでしらべるのでしょうか?

  • Fedora10 への MySQL 5 のインストールについて

    Fedora10をフルインストールしたPCをサーバにみたてて、MySQL5.1.33-linux-i686-glibc23.tar.gz をインストールしようとしています。 root権限で(root@localhost) groupadd mysql useradd -g mysql mysql を行い、 /usr/localにて gunzip < mysql-VERSION.tar.gz | tar xvf - mysql-VERSION.tar.gz を行いました。 その他のディレクトリ usr/local/mysql や home/usr などでもtarコマンドを使って、解凍してみましたが、MySQL versionディレクトリを作成しました。 しかし、 cd mysql-VERSION をしたり、あるいは解凍をした位置などで、 ./configure --with-charset=ujis \ --prefix=/usr/local \ --localstatedir=/sql/data とうってみますが、必ず -bash: ./configure: そのようなファイルやディレクトリはありません と怒られてしまいます。 どうやったらconfigure をかけられるのでしょうか。 ご回答をお待ちしています。

  • Vine Linux 2.5のブラウザMozilla にFlashをインストールしたいです

    Vine Linux 2.5 をクライアントPCとして使っています。ブラウザはMozilla 0.9.8+ です。WebでFlashを表示させようと、Flashをインストールしたのですが、うまくいきません。まず初めに、Download ボタンを押し、ファイルをディスクに保存しました。 install_flash_player_6_linux.tar.gz となっていたので、gedit で開いて gzip -d コマンドでファイルを復元しました。ファイルがinstall_flash_player_6_linux.tar となったところで、tar xvf コマンドでアーカイブからファイルを取り出す作業をしました。install_flash_player_6_linux ディレクトリができ、その中にいくかのファイルがあります。ここまではできたのですが、あとはどのようにしたらよいのでしょうか?

  • redhat9でxineをインストールしようとして・・・

    redhat9でxineをインストールしようとしています。 xine-lib-1.0で「./configure」を実行すると、下記のエラーがでます。 checking build system type... i686-pc-linux-gnu checking host system type... i686-pc-linux-gnu checking target system type... i686-pc-linux-gnu checking for a BSD-compatible install... /usr/bin/install -c checking whether build environment is sane... yes checking for gawk... gawk checking whether make sets $(MAKE)... yes checking for style of include used by make... GNU checking for gcc... no checking for cc... no checking for cc... no checking for cl... no configure: error: no acceptable C compiler found in $PATH See `config.log' for more details. gccがインストールされていないのかなと思い、「rpm -qa | grep gcc」とすると、 compat-gcc-7.3-2.96.118 libgcc-3.2.2-5 compat-gcc-c++-7.3-2.96.118 とでますので、パスが通ってないと思うのですが、違うのでしょうか?それともインストールされてないのでしょうか?ちなみに「echo $PATH」とすると /usr/local/sbin:/usr/local/bin:/sbin:/bin:/usr/sbin:/usr/bin:/usr/X11R6/bin:/root/bin:/usr/lib と出ます。

  • 解凍の仕方

    Linuxのレッドハット7.2を使っているのですが, ネットスケープ7.1をDLしたのですが, ファイル(gzで終っている)を解凍しようと思ったのですが, tarというコマンドを使ったのですが,うまく行かず manコマンドで使い方をみたのですが, 書式の読み方がよくわかりません。ファイル名は netscape-i686-pc-linux-gnu-installer.tar.gz というファイルです どうやった解凍できますでしょうか? 現在使っているネットスケープのバージョンは4.78です. お願いします。

  • GCCコンパイラ作成時にmemory.hも作成する方法

    GCCコンパイラ作成時にmemory.hも作成する方法 TOPPERS/JSPのコンフィグレーションツールを ビルドしたく、ビルド実績のあると耳にした GCC3.4.4をCygwin上に作成しました。 GCC3.4.4は以下の3つから作成しました。 ・binutils-2.16.tar.bz2 ・gcc-3.4.4.tar.bz2 ・newlib-1.14.0.tar.gz GCC3.4.4の作成手順は、Web上に掲載されている手順を 参考にして、以下の通り実施しました。 ■binutilsのインストール $ tar zxvf ./binutils-2.16.tar.gz $ cd binutils-2.16 $ ./configure --target=i686-elf --prefix=/cygdrive/c/cygwin/usr/local/gnu $ make $ make install ■gccのインストール $ tar xvjf ./gcc-3.4.4.tar.bz2 $ tar zxvf ./newlib-1.14.0.tar.gz $ export PATH=$PATH:cygdrive/c/cygwin/usr/local/gnu/bin/ $ cd gcc-3.4.4 $ ./configure --target=i686-elf --prefix=/cygdrive/c/cygwin/usr/local/gnu --with-newlib --with-headers=/cygdrive/c/cgywin/usr/local/src/gnu/newlib-1.14.0/newlib/libc/include/ --disable-bootstrap --enable-languages="c,c++" $ make $ make install しかしながら上記の手順で作成すると、コンパイラ作成時に memory.hが作成されません。 そのため、コンフィグレーションツールのビルドが成功しません。 そこで、教えていただきたいのですが、 そもそもGCC3.4.4のコンパイラを作成する際にmemory.hも一緒に作成し、 GCC3.4.4のg++がインクルードする設定にできるのでしょうか? できる場合は、作成に必要な手順を是非とも教えてください。

  • PostgreSQLをCentOS5にインストールしました。

    閲覧有難うございます。 質問内容なのですが、Postgresqlをインストールしたのですがpostgresql.confとpg_hba.confが見つかりません。 OSはCentOS5です。 インストール方法は以下の手順で行いました。 # /usr/sbin/adduser postgres # chown postgres:postgres /usr/local/pgsql # mkdir /usr/local/src/postgres-8.2.6 # chown postgres:postgres /usr/local/src/postgresql-8.3.7 # su - postgres # cd /usr/local/src # tar xfz /usr/local/src/postgres-8.2.6.tar.gz # cd /usr/local/src/postgres-8.2.6 # ./configure # make # make install また、 [root@ ~]# su - postgres -bash:  LD_LIBRARY_PATH=/usr/local/pgsql/lib: そのようなファイルやディレクトリはありません -bash:  export: command not found -bash:  PATH=/usr/local/pgsql/bin:/usr/kerberos/bin:/usr/local/bin:/bin:/usr/bin: そのようなファイルやディレクトリはありません -bash:  export: command not found -bash:  MANPATH=/usr/local/pgsql/man:: そのようなファイルやディレクトリはありません -bash:  export: command not found -bash:  export: command not found -bash:  PATH=/usr/local/pgsql/bin:/usr/kerberos/bin:/usr/local/bin:/bin:/usr/bin: そのようなファイルやディレクトリはありません -bash:  export: command not found -bash:  MANPATH=/usr/local/pgsql/man:: そのようなファイルやディレクトリはありません -bash:  export: command not found [postgres@ ~]$ のようなエラーがはかれるようになりました。 どうか皆様のお力をお貸しください。

  • flexをインストールできない

    現在、php-4.3.8をインストールしているときに、flexというツールをインストールしてくださいとでたので インストールすると、 /bin/sh ./mkinstalldirs \ /usr/local/bin /usr/local/lib /usr/local/include /usr/local/man/man1 rm -f /usr/local/man/man1/flexdoc.1 1345/usr/bin/install -c -m 644 ./flex.1 /usr/local/man/man1/flex.1 make: 1345/usr/bin/install: コマンドが見つかりませんでした make: *** [install.man] エラー 127 とでてしまいます。 いろんなサイトを見ていると、普通にできるみたいですが、できなくて困っています。 どなたかご存知のかたがいらっしゃましたらお教えください。

  • mozillaにflashをインストールできません

    どうしても、mozillaにflashをインストールできません。 環境 redhat 7.2 mozilla 1.0.1 flash 5.0.51.0 http://www.atmarkit.co.jp/flinux/rensai/linuxtips/335flashinst.html を見ながらインストールしようとしたんですが。。 macromediaからflash_linux.tar.gzをダウンロードしてきて、 解凍してlibflashplayer.soを/usr/lib/mozilla/plugins/にコピー ShockwaveFlash.classを/usr/lib/netscape/plugins/にコピー これで、インストール終わったって書いてあるんですが、どうしても flash playerが起動しません。mozillaのヘルプのAbout Pluginsを見ても defaultのまま、ファイル名が/usr/lib/mozilla/plugins/libnullplugin.so となっています。 ちなみに、他のプラグイン、例えばJAVAなんかは、問題なく認識してくれる のですが。 どなたか、もしよろしければアドバイス宜しくお願いします。