• 締切
  • 困ってます

Xwindowのデスクトップ画面が表示されません。

  • 質問No.369421
  • 閲覧数205
  • ありがとう数1
  • 回答数3

お礼率 17% (3/17)

こんにちは、royroyです。
質 問 No.368308「TurboLinux Workstation7 FTP版を起動できません。」
に自己レスしようと思ったのですが「自分の質問にはコメントできない」
らしいのでここで新たな質問のついでに報告します。

ひょっとして、FDが不良では?と思い、Windowsでフォーマットしようと
したら、FDのディバイスエラーがでました。
新しいFDをフォーマットして、Turbolinux7をもう一度
インストールし、起動ディスクを作成しました。
このFDで起動したらなんと無事に起動しました。
私の初歩的なミスでした。すみませんでした。
お騒がせしました。

ところが、Turbolinux7を起動して、
startxを実行しても、Xwindowのデスクトップ画面が
表示されません。灰色の背景にxのマウスアイコンが
表示されるだけです。Turboxcfgで画面設定をし、
65536色で1024x768に再度設定して、
この設定のテストをすると正しくデスクトップが
表示されていました。安心して、OKを押し、
再び、startxをしましたが、一瞬デスクトップ画面が
表示されて、すぐ灰色の背景になります。
あきらめて、マウスの左クリックでexitを押し
元のテキスト画面になったときに以下のように
表示されます。
「Couldnot init font path element
/usr/X11R6/lib/X11/fonts/TrueType/, removing from list」
そういえば、以前はturboxcfgの設定画面は日本語表示
だったのに、今回は、英語表示になっています。
これが関係しているのでしょうか?

回答 (全3件)

  • 回答No.3

ベストアンサー率 43% (2233/5098)

こんばんは。
時間が取れなくて遅くなり申しわけありません。
よくわかりませんが、XFree86関連のパッケージを再インストールしてみてください。
(rpmコマンドの使い方は、#2の回答をご覧ください)
TurboLinx8なら下記のようなものですが、7は違うかもしれません。

XFree86-100dpi-fonts-4.2.0-11.i586.rpm
XFree86-4.2.0-11.i586.rpm
XFree86-75dpi-fonts-4.2.0-11.i586.rpm
XFree86-contrib-4.2.0-11.i586.rpm
XFree86-cyrillic-fonts-4.2.0-11.i586.rpm
XFree86-devel-4.2.0-11.i586.rpm
XFree86-japanese-fonts-1.0.3-7.noarch.rpm
XFree86-libs-4.2.0-11.i586.rpm
XFree86-unicode-fonts-0.4.0-1.noarch.rpm
XFree86-xfs-4.2.0-11.i586.rpm

これでだめなら、全体を再インストールしたほうが早いかもしれません。
何度かインストール/失敗を繰り返して調べているうちに、ポイントが少しずつわかってきます。
あまりこの点にこだわらずいろいろやってみたほうがいいように思いますがどうでしょう。

その時は、XF86configやいくつかのファイルはバックアップしておいたほうがいいかもしれません。
/etc/ 以下をまとめて圧縮するには、
# tar zcvf etc.tgz /etc
とすればカレントディレクトリに etc.tgz ができます。
# tar zxvf etc.tgz
とすれば、カレントディレクトリの etc/ 以下に復元します。
(etc.tgzは、FDか何かにバックアップしてください)
補足コメント
royroy

お礼率 17% (3/17)

こんにちは、royroyです。

>XFree86関連のパッケージを再インストールしてみてください。
Windows98でturbolinuxのインストールCDを見ると
/turbo/rpms/ディレクトリー以下に
xFree86-100dpi-fonts-4.1.0-17.i586.rpm
xFree86-4.1.0-17.i586.rpm
xFree86-japanese-fonts-1.0.3-5.noarch..rpm
xFree86-75dpi-fonts-4.1.0-17.i586.rpm
xFree86-libs-4.1.0-17.i586.rpm
xFree86-xfs-4.1.0-17.i586.rpm
....が表示されます。しかし

TuroboLinuxで
#mount /dev/cdrom /mnt/cdrom
#cd /mnt/cdrom/turbo/RPMS/
ここで#dir をすると、xFree86関係のrpmファイルが表示されないのです。
(ほかのrpmファイルは表示される)
もちろん#rpm –ivh xFree86-japanese-fonts-1.0.3-5.noarch.rpmを
入力しても、「そんなファイルは見つかりません」と英語で表示されます。

インストールは三回行いましたがいずれも同じ結果でした。

一体どうしてなのでしょうか?
投稿日時:2002/10/08 22:03
お礼コメント
royroy

お礼率 17% (3/17)

こんにちは、royroyです。
自力で解決しました。
turbowmcfgを
起動して、デスクトップをKDEにして、startxをすれば
デスクトップ画面が表示されました。
(これまでわかるのに2週間ほどかかったのでした。)
ありがとうございました。
投稿日時:2002/10/15 22:09
  • 回答No.2

ベストアンサー率 43% (2233/5098)

こんばんは。

>初心者ではずかしいのですがエディターはどうやって起動するのでしょうか?
どの環境でも使えるのがviです。

root で vi /etc/X11/XF86Config  とすれば起動できます。

文字の挿入は、i を押すと挿入モードになります。
編集が終わったら、
[Esc] : wq [Entar] を順に入力してください。

間違ったら
[Esc] : q! [Entar] を順に入力してください。

>TTフォントの再インストール
ごめんなさい。パッケージ名はわかりません。
rpmコマンドでインストールしてみてください。
rpmコマンドの使い方は、参考URLを参照して、
「無理矢理インストール」
とかいてあるやり方でやってみてください。
もう少し詳しいことがわかれば改めて投稿します。
補足コメント
royroy

お礼率 17% (3/17)

こんにちは、royroyです。

>root で vi /etc/X11/XF86Config  とすれば起動できます。
これでXFConfigを書き換えできました。
(#FontPath “/usr/X11R6/lib/X11/fonts/TrueType/”でいいのですね)
ところがstartxでは、今回もXwindowは表示されませんでした。
「Couldnot init font path element
/usr/X11R6/lib/X11/fonts/TrueType/, removing from list」
がまた表示されていました。
困った!
投稿日時:2002/10/01 10:27
  • 回答No.1

ベストアンサー率 43% (2233/5098)

XのTTフォントの設定に問題があるようですね。
とりあえず、/etc/X11/XF86Config のTrueTypeフォントの設定部分の先頭に"#"を入れて
コメントアウトしてみてはどうでしょうか?
根本的には、TTフォントの再インストールが必要なのかもしれません。下記サイトも参考にしてみてください。
http://www.turbolinux.co.jp/knowledge/public/72.html
http://www.turbolinux.co.jp/knowledge/public/377.html
補足コメント
royroy

お礼率 17% (3/17)

こんにちは、MovingWalkさん、royroyです。

>/etc/X11/XF86Config のTrueTypeフォントの設定部分の先頭に"#"を入れて
>コメントアウトしてみてはどうでしょうか?
ありがとうございます。
初心者ではずかしいのですがエディターはどうやって起動するのでしょうか?

>根本的には、TTフォントの再インストールが必要なのかもしれません。
できたら、この方法も教えて下さい。
よろしくお願いします。
投稿日時:2002/09/30 11:38
関連するQ&A

ピックアップ

ページ先頭へ