• ベストアンサー
  • 困ってます

phpのインストールについて

phpで別サーバ(DBのみ)のpostgresqlに接続しようとした場合、接続できませんでした。 php-pgsql?かpgsql.soが無いのが原因ぽいのですが、検索してもyumでインストールとかばかりでソースからインストールした際の記述がみつけられませんでした… phpインストール時にpostgres(php-pgsql?)を有効するにはどうしたらいいのでしょうか? ちなみにpostgresqlとphpが同一サーバ内にインストールされているサーバ(現環境)からこのDBのみのサーバにTCP/IPで接続はできました。 OS:CentOS4.5(共に) apache2.2.6 php:5.2.5 postgres8.2.5 php cofigureオプション ./configure --with-apxs2=/usr/local/apache2/bin/apxs --enable-mbstring --enable-mbregex よろしくお願いします。

共感・応援の気持ちを伝えよう!

  • 回答数2
  • 閲覧数259
  • ありがとう数0

質問者が選んだベストアンサー

  • ベストアンサー
  • 回答No.2

> 接続できませんでした。 ここが曖昧ですが、 関数が未定義となるなら再インストールなどしてpgsql.soを入れる。 サーバ間接続ができないならpg_hba.confやOSのFWを見直す。

共感・感謝の気持ちを伝えよう!

関連するQ&A

  • php5.0.5 について

    apache2+php5.0.5で、 ./configure ./configure --with-apxs2=/usr/local/apache2/bin/apxs --enable-mbstring makeすると、 configure:error: libxml2 version 2.5.0 or greater required. となるのですが、どうしてでしょうか? このままインストールしていいのでしょうか? 教えてください。宜しくお願いします。

    • ベストアンサー
    • PHP
  • PHPのインストールについて

    新しくサーバーを構築しているのですが、前任者がPHPのインストールメモとして「Apacheモジュール用」のconfigureオプションと「コマンドライン用」のconfigureオプションを書き残してあります。 それぞれの違いは Apacheのモジュール用 ./configure --with-apxs2=/usr/local/apache2/bin/apxs コマンドライン用 ./configure --enable-pcntl で外は同じオプションでした。 この場合、同じディレクトリでそれぞれmake installするとあとからmakeしたPHPが生成されるのではと思いますが、これでよいのでしょうか? よろしくお願いします。

    • ベストアンサー
    • PHP
  • Linux PHPからSQLServerに接続できない

    Linuxにphpをインストールしたのですが別のWindowsServerのSQLServerに接続することができません。 LinuxにインストールしたMySQLのデータは参照できています。 なにかモジュールやドライバーなどが必要なのでしょうか? ちなみに別のWindowsから該当のSQLServerは接続できているのでホスト名、DB名、User名、Passwordは 正しいと思います。 以下は環境とphpインストール時のオプションです。 もし、不足しているものがあれば教えてください。よろしくお願いします。 ./configure --with-apxs2=/usr/local/apache2/bin/apxs --enable-mbstring --enable-mbregex --enable-trans-sid --with-mysql=/usr/local/mysql --with-pdo-mysql=/usr/local/mysql Red Hat Linux 8.0 Apache 2.0.55 php-5.1.2

    • 締切済み
    • PHP

その他の回答 (1)

  • 回答No.1
  • SAYKA
  • ベストアンサー率34% (944/2776)

http://www.php.net/manual/ja/configure.php --with-pgsql 勿論、そのphpが有る環境に、そのsqlが入ってないとダメだよ?

共感・感謝の気持ちを伝えよう!

関連するQ&A

  • PHP-4.3.1でmake出来ない

    RedHat8.0 apache(httpd-2.0.45)の環境に PHP-4.3.1をインストールしようとしたのですが、 下記のconfigureでmake出来ません。 ./configure --with-apxs=/usr/local/apache2/bin/apxs --enable-mbstring --enable-mbregex --enable-zend-multibyte どなたか分かる方がいらっしゃいましたら 教えてください。 ※ちなみに、オプションを付けずにconfigureを 行うとmakeできます。 ※上記のオプションを付けると、Makefile.fragmentsと Makefile.objectsのみ作成されます。

  • PHPが動きません

    RedhatLinux4EPで元々PHP4.3がインストールされていて(RPMかソースかわかりません)、PHP5.1.6ソースを新たにインストールしましたところ、PHPが全く動かなくなりました。 php.ini、httpd.confを新たに または 以前の状態のものにしても全く駄目でした。 新たにインストールした時のコンフィグは、下記になります。 ./configure --with-apxs2=/usr/sbin/apxs --with-gd --with-pgsql --with-zlib --enable-mbregex --enable-mbstring --enable-trans-sid あまりよく分かってないので、どのように対処したら良いか分かりません。 新しいのでも、以前のでも良いのでどうにかPHPを再度動くようにするにはどのようにしたら良いでしょうか。 宜しくお願い致します。

    • ベストアンサー
    • PHP
  • apache2.0へのPHP4導入時にエラーがでます。

    現在apache2.0にPHP4.2.2を導入しようとしていますが、PHPのmake時にエラーが出てしまいます。 具体的には以下のようなメッセージを出力してmakeが止まります。 sapi_apache2.c: In function `php_register_hook': sapi_apache2.c:534: warning: passing arg 3 of `ap_register_output_filter' makes pointer from integer without a cast sapi_apache2.c:534: too few arguments to function `ap_register_output_filter' sapi_apache2.c:535: warning: passing arg 3 of `ap_register_input_filter' makes pointer from integer without a cast sapi_apache2.c:535: too few arguments to function `ap_register_input_filter' またconfigureは以下のように実行しています。 ./configure --with-apxs2=/usr/local/apache2/bin/apxs --with-pgsql=/usr/local/pgsql/ --enable-mbstring --enable-mbstr-enc-trans --enable-trans-sid --enable-versioning --enab le-mbregex apache2.0の方はDSOを使えるようになっています。 webで調べたところ、sapi/apache2filter/php_functions.cを修正すればよいとの情報があったのでこのファイルの93行目を #if !MODULE_MAGIC_AT_LEAST(20020506,0)        ↓ #if !AP_MODULE_MAGIC_AT_LEAST(20020506,0) に変更した後、同じ手順でmakeしましたがだめでした。 PHP4.2のapache2.0への対応がexperimentalなのは承知していますが、なんとかして現段階でインストールしたいと思っています。 どなたか情報をお願い致します。

  • phpのインストールが上手く行きません

    お世話になります。 phpのインストールが上手く行きません。 make install で下記メッセージが出力し停止します。 [activating module `php4' in /usr/local/apache/conf/httpd.conf] cp libs/libphp4.so /usr/local/apache/libexec/libphp4.so cp: cannot stat `libs/libphp4.so': そのようなファイルやディレクトリはありません apxs:Break: Command failed with rc=1 make[1]: *** [install-sapi] エラー 1 make[1]: 出ます ディレクトリ `/usr/local/src/php-4.2.2' make: *** [install-recursive] エラー 1 phpインストールにあたり下記を実施いたしました。 OSはRedHat7.2です。 > apache1.3.24インストール # ./configure --enable-shared=max --enable-module=so # make # make install # /usr/local/apache/bin/httpd -l Compiled-in modules:  http_core.c  mod_so.c suexec: enabled; valid wrapper /usr/sbin/suexec > php4.2.2インストール $ tar xvzf php-4.2.2.tar.gz $ cd php-4.2.2/ext $ cp /****/php4_mbregex-1.3.1.tar.gz . $ tar xvzf php4_mbregex-1.3.1.tar.gz $ cd .. $ rm configure $ ./buildconf $ ./configure --with-pgsql \ --enable-track-vars \ --with-apxs=/usr/local/apache/bin/apxs \ --enable-versioning \ --enable-trans-sid \ --enable-mbstring \ --enable-mbstr-enc-trans \ --enable-mbregex $ make $ su # make install 最後のmake installが上記エラーをはいて停止してしまいます。 apacheを入れ直したりphpのバージョンを変えて試しましたが駄目でした。 apxsも/usr/local/apache/bin/の中にあります。 なにが悪いのか私ではさっぱり解りませんので どなたかご教授して頂ければと思います。。。 宜しくお願い致します。m(__)m

    • ベストアンサー
    • PHP
  • Apache OpenSSL PHP でエラー

    CentOS 5.1にOpenSSL-0.9.8g、httpd-2.0.61、Postgres8.1.10、php-5.2.5でWEBサーバを作っているのですが、不思議なエラーが出てうまくいきません。 現象としては以下の通りです。 htdocs_http = httpコンテンツ htdocs = httpsコンテンツ apacheをstartsslで起動して、htdocsにphpinfoを 出力するプログラムを作成した後アクセスすると コンテンツのTOPに Keep-Alive: timeout=15, max=98 Connection: Keep-Alive Transfer-Encoding: chunked Content-Type: text/html ae03 などのメッセージが出力されます。 Apacheとphpを何度も再インストールしたのですが解決できません。 誰か似たような現象を起こった方や、 解決策を知っている方教えていただけませんか。 インストールした順は以下の通りです。 1. OpenSSL 2. httpd 3. Postgres 4. php インストールしたオプション 1. OpenSSL # ./config -fPIC shared 参考にしたサイト http://uguisu.skr.jp/Windows/apache2.html 2. Apache # ./configure \ # --enable-so --enable-ssl --with-ssl=/usr/local/ssl 3. Postgres # ./configure のみのオプションなし。 4. php # ./configure \ # --enable-mbstring=all --enable-mbregex \ # --enable-sockets --enable-ftp \ # --with-apxs2=/usr/local/apache2/bin/apxs \ # --with-pgsql=/usr/local/pgsql --without-mysql \ # --with-gd --enable-gd-native-ttf \ # --with-freetype-dir=/usr --with-jpeg-dir=/usr \ # --with-zlib=/usr --with-png-dir=/usr \ # --with-imap=/usr --with-kerberos=/usr \ # --with-imap-ssl --with-pdo-pgsql=/usr/local/pgsql \ # --with-mcrypt=/usr/local

    • 締切済み
    • PHP
  • PHPのconfigureについて

    PHP5.2.6をインストールしようとしているのですが、configureコマンドの所で躓いています 実行しているconfigureオプションは以下の通りです。 ./configure --with-apxs2=/usr/local/apache2/bin/apxs --with-gd --with-zlib --enable-bcmath --enable-mbregex --enable-mbstring とすると configure: error: libpng.(a|so) not found. となります。 yum install libpngとすると Package 2:libpng-1.2.10-7.1.el5_3.2.i386 already installed and latest version となるので最新版のようです。 このconfigure: error: libpng.(a|so) not found.を克服する術を教えて頂けると助かります。 何卒よろしくお願いします。

    • ベストアンサー
    • PHP
  • CentOS5でLAPPを構築したいのですが・・・

    CentOS5にApacheとPostgreSqlとPHPをインストールしたいんですがうまくいきません。 httpd-2.2.14 postgresql-8.2.6 php-5.2.6 を入れようと思っています。 CentOS5をインストールして、IPアドレスやホスト名などの設定後、もともとインストールされているApacheなどを # rpm -qa | grep 'httpd' # rpm -e httpd などのコマンドで削除ごに #/usr/local/src/ に上記のApcheやPHPなどのファイルを持ってきてApache→Postgresql→PHPの順番にインストールしました。 Apcheの場合 # cd /usr/local/src # tar xfz /usr/local/src/httpd-2.2.14.tar.gz # cd httpd-2.2.14 # /configure # make # make install Postgresqlの場合 # /usr/sbin/adduser postgres # chown postgres:postgres /usr/local/pgsql # mkdir /usr/local/src/postgres-8.2.6 # chown postgres:postgres /usr/local/src/postgresql-8.3.7 # su - postgres # cd /usr/local/src # tar xfz /usr/local/src/postgres-8.2.6.tar.gz # cd /usr/local/src/postgres-8.2.6 # ./configure # make # make install PHPの場合 # cd /usr/local/src # tar xfz /usr/local/src/php-5.2.6.tar.gz # cd /usr/local/src/php-5.2.6 # ./configure --with-apxs2=/usr/local/apache2/bin/apxs --enable-mbstring --enable-mbregex --with-pgsql # make # make install 上記の様なコマンドでインストールしましたがうまくいきません 詳細な設定もしているつもりですがいまいちうまくいきません どうか皆さまの知識をどうかお貸しくださいm(_ _)m

  • サーバに接続できません・・・

    環境はxp、apache2、php5、Postgresql8.2です。 ただ今PHPとPostgresqlの勉強をしています。 Pgadmin3で postgresサーバに接続しようとすると 次のようエラーが出て 接続することが出来ません。 「サーバに接続できませんでした サーバはホスト"000.0.0.1"で稼働していますか? また、ポート5432でTCP/IP接続を受け付けていますか?」 そのため、postgresをアンインストールして インストールし直したところ 接続できるようになったのですが 新しいデータベースを作ろうとしたところ また同じエラーが出て接続できなくなってしまいました。 ご教示して頂けたら幸いです。

  • PHP PDO設定

    PDOでDB接続をしたいのですが、うまくいかず困っていて質問します。 OS Linux  apache 2.0.×(ソースでインストール) PHP5(ソースでインストール) DB MYSQL5(パッケージでインストール) 現状なのですが、PHPを下記の設定でインストールしました。 ./configure --with-apxs2=/usr/local/apache2/bin/apxs --enable-mbstring --enable-zend-multibyte --with-mysql --with-pdo-mysql=shared そのあとPHP.iniに記述してapache再起動 extension=pdo.so extension=pdo_mysql.so phpinfo()でみるとPDOの欄には下記しか表示されていません。 PDO drivers sqlite2, sqlite 試しにPHPで接続したのですが、 could not find driver と出ます。 そこで下記のようにインストールしてみたのですが phpinfoも上記と変わりません。 pecl install pdo_mysql ここまでが現状なのですが、 よくわかっていない部分もありわかりずらい かとは思いますが、参考意見の方を頂けますでしょうか。

    • ベストアンサー
    • PHP
  • PHP4.0.6をインストールして使いたいのですが・・・

    借りているサーバーがPHP4.0.6のため、PHP4.0.6とApacheをインストールしてローカルテストを行おうと考えています。 まず、Apache2とPHP4.0.6をダウンロードして、それぞれインストールしたのですが、php4apache2.dllがPHP4.0.6に入ってなかったため、Apache1.3.35をダウンロードし、インストールしなおしました。 すると今度は、php_mbstring.dllがないらしく、マルチバイト文字列関係の関数が使えません。 そこで素人処方でPHP4.4.2をダウンロードし、その中に入っているphp_mbstring.dllをextensionsフォルダにいれたもののdllから「php_mbstring.dllがみつかりません」のような趣旨のメッセージが出て使えません。 いろいろやってみたのですが、正直八方塞の状態です。 ローカルテストで、PHP4.0.6でマルチバイト文字列関係の関数をつかうことはできないでしょうか?(サーバー上ではつかえるのですが・・・)

    • ベストアンサー
    • PHP