• ベストアンサー
  • 困ってます

IDEハードディスクのUltraDMA33/66/100転送速度設定

こんにちは。 今使っているDOS/V(OS:W2k/WinXPProデュアルブート)のIDEハードディスクに関しての質問です。 マザーボードのIDEインターフェイスUltraDMA33/66/100対応にIDE/ATA100のハードディスクをつけたのですが速度が最高28Mbps/secしかでませんでした。ハードディスクユーティリティで調べたところアクティブDMAモードは2でした。 ハードディスクはDMAモード5までサポートしているので100Mbps/sec近く出せるはずなのですが設定がよく分かりません。 ちなみに、ハードウェアマネージャでIDEインターフェイスの設定では”DMAが使用可能ならば使う”としています。 どなたか設定方法が分かる方教えてください。

noname#68933
noname#68933

共感・応援の気持ちを伝えよう!

  • 回答数2
  • 閲覧数308
  • ありがとう数1

質問者が選んだベストアンサー

  • ベストアンサー
  • 回答No.1

マザーボード側がそもそもUltra DMA モード2までしか対応していないとか、IDEケーブルが40ピン40線のケーブルを使っているという可能性は無いだろうか?  【参考】   http://www.atmarkit.co.jp/fpc/xp_feature/idesupport/idesupport.html

共感・感謝の気持ちを伝えよう!

質問者からの補足

ご回答ありがとうございます。 マザーボードに関してはマニュアルにUltraDMA33/66/100対応と書いてあるのでUltra DMA モード5はサポートされていると思われます。 ケーブルは40ピン40線のような気がします(汗)。 というか素人なので聞きたいのですが80線ケーブルは物理的に繋げることができるのですか?

関連するQ&A

  • HDDの転送速度がDMAにならないのですが・・・

    OS:windowsXP HDD:Maxtor 5T040H4 Maxtor 6Y160L0 上記の物を使用しているのですが、デバイスマネージャーで確認してみたところHDDは二つとも、標準デュアルチャネルPCI IDEコントローラーのプライマリIDEチャネルに接続されていて、プロパティーを開き詳細設定で転送モードをデバイス0、1共にDMAにしているのですが、現在の転送モードが二つともPIOモードのままなのですがDMAにすることは出来ないのでしょうか? 他にも、Intel(R) 82801FB Ultra ATA Storange Controllers-2651と Intel(R) 82801FB/FBM Ultra ATA Storange Controllers-266Fがあり、前者には、何も接続されていなく、後者の方のプライマリにはDVDドライブが接続されていて、こちらはプロパティの転送モードはDMAで、現在の転送モードもウルトラDMAモード2となっているのですが、HDDの方もこのようにはならないのでしょうか? どうか回答の方よろしくお願いします。

  • 「ハードディスク設定」と「IDEコントローラの最新のドライバ」

    ハードディスク診断ツールで、パソコンのハードディスクを調べた所、 「ハードデイスクの転送モードは、UltraDMAモード2(33MB/S)です。UltraDMAモード5(100mb/s)までサポートしています。」と表示されました。そして、「BIOSのハードディスク設定を確認し、IDEコントローラの最新のドライバをインストールしてください」と表示されました。 「ハードディスク設定」の何を確認すればいいのでしょうか。 また、「IDEコントローラの最新のドライバ」というのはどこにあるのでしょうか。ハードディスクメーカーでしょうか。ハードウェアメーカーでしょうか。

  • ハードディスクの転送速度について

    前回、マザーボードについての質問に回答してくださった方々 どうもありがとうございました 今回の質問の件ですが、いろいろ調べた結果どうしても解決しないので質問させていただくことにしました 現在、ハードディスク3台(30ギガ・40ギガ・80ギガ)を接続してましてそのうち一台(80ギガ)をATAカードに接続して使用しております OSはCドライブにWINDOWS ME、EドライブにWINDOWS2000をデュアルブートとして使用しております それで今回の質問なのですが、たまたまWIN2000環境でゲーム起動してみましたら、立ち上がりがすごく遅いのです 一応、ME環境でも同様のソフトを起動してみたらすごく速いのです(起動時に下側に読み込みのバーがあり、その増え方が非常に遅い) 実際、ハードディスク間のコピーなどもME環境では速いのに、2000環境だとかなり遅いのです ためしにベンチマークソフトで計測してみましたら、MEと比べ 5000程も低い結果でした PCにインストールされているインテルATA?(転送速度を表示できる)ものを起動してみましたらUDMA-5と表示されており(マザー・ハードディスクともATA100仕様です) そのソフトではきちんと認識されているようなのです (バイオスでもAUTO設定なのは確認しました) デュアルブートだとこのような問題がでるものなのでしょうか? どうしても解決したいので、よろしくおねがいします!! マザー FIC FS15T ATAカード プロミス?製です

その他の回答 (1)

  • 回答No.2

> 80線ケーブルは物理的に繋げることができるのですか? ということですが、コネクタ部は40芯も80芯も同じものなので、 繋ぐことが出来ます。(増えてる40芯分はGND線なので) フラットケーブルの場合は、何芯あるかケーブル自体を見れば 大体分かりますよ。

共感・感謝の気持ちを伝えよう!

質問者からのお礼

アドバイスありがとうございます。 自分で検索かけた見ましたら。 40ピン80線ケーブルがありました。 問題解決できそうです、感謝いたします。

関連するQ&A

  • 純正以外のIDEハードディスクをMacで使うには?

    Macの内臓IDE(ATA)ハードディスクの換装を考えていますが、IDE接続のハードディスクであればMac純正をうたっていなくても、WindowsやDOS/V用のものでも使えると聞きました。 ところが、そういうハードディスクに付属しているフォーマッタはすべてWindowsやDOS/V用のものです。 Mac用にフォーマットするには、どうすればいいのでしょうか? Macの「ドライブ設定」などで初期化は可能でしょうか。

    • ベストアンサー
    • Mac
  • IDE転送モードの設定はこれでいいのでしょうか?

    DVD(内蔵)が遅くなったので「教えて」で過去質問を調べたら、IDEの転送モードをDMAへ設定とのアドバイスが目にとまりました。 PIOの場合は削除、再インストールと書いてありました。 私の現在の転送モードは プライマリIDE デバイス0=ウルトラDMAモード5   デバイス1=無効 セカンダリIDE デバイス0=PIOモード         デバイス1=無効 となっており、この場合、プライマリIDEのデバイス0がウルトラDMAモード5になっているから問題はないのでしょうか? IDEやデバイス0、デバイス1の存在もよくわからない初心者ですが教えて下さい。

  • パーティションを切ったHDDの転送速度について

    IDEのプライマリのマスターに、容量20GのATA100のHDDを1個、接続しております。 このHDDをCドライブに10Gと、Dドライブに8.6Gで、 パーティションを分け、 CドライブにOSをインストールしております。 CドライブはウルトラDMA5モードで動いているのですが、 DドライブはおそらくPIOモードになっており、転送速度が遅く困っております。 1.転送速度がCドライブより遥かに遅い。 2.Dドライブへのアクセス時に、CPU負荷が高い という症状が出ております。 同じHDDなのでDドライブもDMAモードで転送できると思うのですが、 対処の仕方が分かりません。教えていただけないでしょうか。 OS:windows2000 sp4 M/B:K7vza IDEドライバはマザーボード付属CDの物を使いました。

  • SATA 設定による転送速度

    ギガバイト社のマザーボード「GA-EX58-UD4」使用しています。 BIOSのSATAを設定する項目で、PATAモード、RAID、AHCIモードの三つから選べるようになっています。 デフォルトではPATAモードになっているのですが、この状態だと転送速度はIDEのものになってしまうんでしょうか? 現在、S-ATA300のHDDとS-ATA2.5のDVDドライブを接続していますが、PATAモードだと転送速度は133.3MBytes/secまでという認識で良いのでしょうか? S-ATA300の300MBytes/secの転送速度は、AHCIでないと出せないということでしょうか? それともPATAモードでも速度はS-ATAのもので、NCQといった一部の機能を使えないというだけでしょうか? 調べていくうちに、実はディスクそのものの読み書き速度は90MBytes/sec程度なので、それ以上の転送速度を求めても仕方がないというような記事も見かけました。 もしかして、今のところPATAとかAHCIとか気にするほどの問題ではないのでしょうか? 訊いてばかりで申し訳ありませんが、よろしくお願いいたします。

  • インターフェイスについて

    HDDのインターフェイスのUltraDMAとUltraATAもしくはATA(IDE)の違いについて教えてください。 お願い致します。

  • HDおよびDVDドライブへの転送速度について

    使用環境 PC:DELL Dimension5150C OS:Windows XP professional Ver.2002 Service Pack3 のPCでDVDの書き込みが遅いことから色々調べまして,IDEチャンネルの転送モードがPIOモードになっていることがわかりました. しかしながら,このPCの場合,デバイスマネージャーで「IDE ATA/ATAPIコントローラー」の下層には 「Intel(R) 82801G (ICH Family) Ultra ATA Storage Controllers - 27DF」「Intel(R) 82801GR/GH SATA AHCI Controller」「プライマリIDEチャンネル」の3つしか表示されません.通常,プライマリ=HDD,セカンダリ=DVDと説明されますが,「セカンダリIDEチャンネル」というものが存在しません.一度,プライマリIDEチャンネルを削除して,再起動しましたら新たなドライブ(DVD)が見つかりましたと表示が出て,やはりプライマリIDEチャンネルが再インストールされました. この場合,従来のプライマリ=HDD,セカンダリ=DVDドライブが表示されないということは,どこかおかしいのでしょうか? 「プライマリIDEチャンネル」のプロパティでは,デバイス0の転送モードがやはりPIOになっていました.デバイス1は転送モードが無効になっています.さらに強制的に変更するために「regedit」から指定ファイル(HKEY_LOCAL_MACHINE→SYSTEM→CurrentControlSet→Control→Class→{4D36E96A-E325-11CE-BFC1-08002BE10318} )をみていくとそこには「0000」「0003」「0006」「Properties」のフォルダしか見当たりません.通常は,「0001」=「プライマリ」,「0002」=「セカンダリ」だそうです.それぞれのフォルダ内の「DriverDesc」をみると,「0000」=プライマリIDEチャンネル 「0003」=Intel(R) 82801G (ICH Family) Ultra ATA Storage Controllers - 27DF 「0006」=Intel(R) 82801GR/GH SATA AHCI Controller となっていました. 「0000」フォルダに新規DWORD値ファイル「ResetErrorCountersOnSuccess」を作成して値を1にして,再起動. 結果,「プライマリIDEチャンネル」のプロパティでは,デバイス0の転送モードが「ウルトラDMAモード2」になりました.しかし,デバイス1はもとの転送モード「無効」のままです. 質問ですが, Q1.このPCでなぜセカンダリIDEチャンネルがないのか? Q2.ウルトラDMAモード2以上には早く出来ないのか? Q3.デバイス1の転送モードが無効となるのを改善できないのか? 以上についてアドバイスをください.よろしくお願いします.

  • マザボにUltraDMA100/66IDEとRAID ATAコネクタというのがあるんですが?

    ASUSのP4P800Deluxeというマザーボードを買ってきたんですが、IDEコネクタ(UltraDMA100/66)というもの2基とRAID ATAコネクタ(ATA133/100/66/33)というもの2基がついています。 中にはATA133のHDD3機とDVDドライブを取り付ける予定なのですが、どちらを使って接続すればよいのでしょうか? また、接続に使用するケーブルですが、きれいに接続しようとおもって買っておいたATA100/133のケーブルがあるのですが、そちらを使わずに付属のDMA100/66対応のケーブルを使うべきでしょうか? 教えてください。

  • ハードディスクの接続、設定について

    自作(ベアボーン)の調子が悪くなり、また当初のHD160GBの容量が足らなくなってきたのでメーカーで調整後500GBのハードディスクを購入、500GBのHDをATA2に接続、元の160GBのHDをスレーブにジャンパーを設定しIDEに接続、DVDドライブは160GBのHDと同じくIDEに接続し WindowsXP を500GBのHDに最初から入れなおしました。 BIOSのブート設定を500GBにして一旦立ち上げても、再起動すると元の160GBが立ち上がってしまいます。 160GBで立ち上がると、500GBが認識されていません。(500GBで立ち上げると160GBは認識されています。 機器の接続方法もしくは設定がおかしいのでしょうか DVDドライブもNeroのドライブチェックでエラーが出てしまいます READ OF SCRAMBLED SECTOR WITHOUT AUTHENTICATION(056F03) 機器構成 マシン Soltec EQ3401MW OS : WindowsXP PRO sp2 HDD(1) WD5000AAKS (500G SATA300 7200) HDD(2) Deskstar7K250/160GB DVDRAM GSA-4082B デバイスマネージャー IDE ATA/ATAPIコントローラ (1)Intel(R)80801EB Ultra ATA Storage Controllers (2)Intel(R)80801EB Ultra ATA Storage Controllers (3)セカンダリ IDE チャネル (4)セカンダリ IDE チャネル (5)プライマリ IDE チャネル (6)プライマリ IDE チャネル (1)場所:PCI バス 0, デバイス 31, 機能 2・・・HDドライブ (2)場所:PCI バス 0, デバイス 31, 機能 1 (3)現在の転送モード「ウルトラDMAモード2」・・・DVDドライブ (4)現在の転送モード「ウルトラDMAモード5」・・・(HDドライブ) (5)現在の転送モード「無効」 (6)現在の転送モード「無効」 IDEチャネルがプライマリ、セカンダリとも2つづつありますが、これはおかしいのでしょうか、よろしくお願いします。

  • IDEチャネルの転送モード表示

    いわゆるPIO病の確認に、デバイスマネージャのプライマリ/セカンダリ IDEチャネルの「詳細設定」内にある、現在の転送モードを見ろ、というのがありますが、これは私の場合で3つづつあります。 複数のドライブがつながっている場合、どのドライブがPIOになっているのか、確実に特定するには、どうすればいいのでしょう? それと現在、ウルトラDMAモード1になっているものがあるのですが、これは、故障なのかどうなのか、どう考えればいいんでしょうか?いつもはそんな表示は出ていませんでした。

  • HDDがDMA転送モードにならない

    HDDがDMA転送モードにならず、そのせいか、タスクマネージャーで モニターするとCPUに負担が掛かっていることが多く、全体のパフォ ーマンスが悪いようです。ウインドウを数個開くと、反応が遅くな ったり、動画再生が途切れ途切れになったりします。 PCの主な構成は以下の通りです。 M/B: ECS L4S5A/DX+ CPU: Celeron 1.7GHz RAM: DDR PC2700 256MB VGA: NVIDIA TNT2 M64(AGP 32MB) HDD: Maxtor 6Y060L0 (Primary Master) CD-RW:AOpen4048 (Secondary Master) OS: WIN2000(SP3) デバイスマネージャーで確認すると、 「IDE ATA/ATAPI コントローラー」の 「SiS PCI IDE UDMA Controller」、 「プライマリ IDE チャンネル」は、 共に正常に作動しているのですが、 「プライマリ IDE チャンネル」の「詳細設定」タブで 「デバイス 0」の「転送モード」を 「DMA(利用可能な場合)」にして再起動しても、 「現在の転送モード」が「PIO モード」のままで、 「DMA モード」になりません。 「システム情報」の「ハードウェア リソース」の 「DMAコントローラー」の状態も「OK」になっています。 M/Bに付属のCD-ROMからIDEのデバイスはインストール済みです。 また、BIOS(Phoenix-Award)の「Integrated Peripherals」の 「SIS OnChip IDE Device」の設定は上から、 「Internal PCI/IDE」は「Both」。 「PIO」「UltraDMA」関連はすべて「Auto」。 「IDE DMA Transfer Access」と「IDE Burst Mode」は 「Enaibled」になっています。 DMA転送が可能になっていい筈だと思うのですが、何かアドバイスが ありましたら宜しくお願いします。