• 締切済み
  • 困ってます

リンク先が表示されない

ホームページ作成初心者です。 ホームページビルダー11にて作成し、サーバーにアップしました。 サーバーは忍者?というところです トップページはきちんとアップされましたが、その先のページがすべてエラーになってしまいます。  例・「商品詳細」をクリックしてもエラーページになってします ホームページビルダーのトップページをプレビューし、そこからリンクできるのかたしかめましたが、ビルダー上はすべて上手に作動しています。  となると、サイトの作成がうまくいってないのか?と思い、「ビジュアルサイトビュー」っていうのかな?一覧で確認しましたが、すべてつながっていました。  あとは思い当たるところがないんですが、原因はわかりますでしょうか?

共感・応援の気持ちを伝えよう!

  • 回答数3
  • 閲覧数216
  • ありがとう数2

みんなの回答

  • 回答No.3

no.2の方の回答に追加 ・フォルダ名が日本語(全角英数字記号も含まれる) それでもわかんなければ、サイトが分からないようにして (特定できると質問から削除される可能性があるので) リンク切れしてる部分のソースを貼ってください。

共感・感謝の気持ちを伝えよう!

質問者からのお礼

いろいろいじってましたらできました。 何が原因かわかりませんが^^: ありがとうございました。

質問者からの補足

確認しましたが、新たに???と思われることがあります ビルダーのサイトの「全体の確認」をしましたら、トップページはタイトルがはいってますが、そこからつながるリンク先には(サイト外)と書かれています。  これがアップできない原因ですよね。 リンク先のフォルダですが、保存さきをDフォルダにしてます。その中に「hp」フォルダ「hp」フォルダ「半角英数」のみです。トップページと同じフォルダに入れてます。 何度かサイトを作成しなおしたのですが、やはりだめです。 「それでもわかんなければ、サイトが分からないようにして (特定できると質問から削除される可能性があるので) リンク切れしてる部分のソースを貼ってください。」 とありますが、具体的にどうすればいいのでしょうか? まったくの初心者です。お手数おかけしますがよろしくお願いします。

  • 回答No.2

多くの場合、原因は下の2つです。 ・リンク先をサーバにアップしていない ・リンク先が、HPを作成したパソコンのハードディスクになっている

共感・感謝の気持ちを伝えよう!

  • 回答No.1

当然その「商品詳細」のページもアップされていますよね? 「商品詳細」のページのURLを、WEBブラウザに直接入力して そのページ自体がWEB上にあるかどうかを確認してみてください。 できなければそこが原因です。

共感・感謝の気持ちを伝えよう!

関連するQ&A

  • HPビルダー9で

    HPビルダーでホームページを作っているのですが、トップページから既存の別のページへリンクさせる際、「リンクの挿入」でURLではなくファイル名でリンクさせたのですが、プレビューでは行けるのですが、実際ではとべなくなっています。画面そのままです。(URLでリンクさせると実際もとべます。) (ビジュアルサイトビューでそのリンクできないファイルの横に赤い×があるのですがこれが関係しているのでしょうか?) 初心者のためわかりにくい文章で申し訳ないのですが、アドバイスいただければ幸いです。

  • ホームページビルダー13 ポップアップ小窓を設定した際ビジュアルサイト

    ホームページビルダー13 ポップアップ小窓を設定した際ビジュアルサイトビューで「リンクされていないHTML」になってしまいます。プレビュー画面ではちゃんと小窓でリンクされていて問題ないのですがビジュアルサイトビューの画面では小窓表示されるHTHLファイルがリンクされていないファイルの方に表示されてしまいます。通常のリンクであればビジュアルサイトビューで確認するとリンクされているファイルの方に表示されページのプレビューアイコンで緑色↑マークが表示されるのですが・・・・そのマークも表示されない状態です。ポップアップ小窓リンクにした際はビジュアルサイトビューで確認した場合リンクされているHTMLの方に表示されないのが通常なのでしょうか? リンク画像はGIF画像でリンク先HTMLファイルはswfを配置したHTMLファイルになります。 ポップアップ小窓設定参考書はズバテク182です。

  • ホームページビルダー リンクがビジュアルサイトビューに反映しない

    ホームページビルダーを使っています。 画像に、新しいhtmlファイルへのリンクを挿入しました。 アップロードもうまくいき、 ネット上ではちゃんとリンクされ表示されるのですが、 ビジュアルサイトビューには、 追加したファイルへのリンクが反映されません。 リンク先のファイルを編集するときは ファイル一覧から探して開いている状態です。 どうすればビジュアルサイトビューに反映するのでしょうか? それとも、ビジュアルサイトビューの樹形図の範囲には 限界があるということでしょうか?

  • ホームページビルダー リンク設定できない

    ホームページビルダーで作っているのですが リンクできません ビジュアルサイトビューでリンク設定できたらツリーみたいになるはずなのに リンクされていないHTMLファイルのとこにあるのですが リンク挿入 ページリンク作成する リンク先INDEX.HTMLとつなげたいのですが どうしたらいいのですか?

  • サイト作成にて

    パソコンは初心者でホームページビルダー11でとりあえず希望のHPを作ったのですが、ここからサイトを作り、ブロバイダーに転送してと考えていましたが、サイト作成が上手くいきません。 トップページを開いて(トップページには6つのリンクをつけているのですが)サイト作成しても、ビジュアルサイトビューにはトップページのみでリンクしたサブページの表示がないんです。 トップからはきちんとサブページに飛ぶようにリンクをつけて、移動できることも確認済みで問題ないのですが・・・ 保存の仕方がまずかったのでしょうか? 1個のフォルダを作り、ホームページ作成全ての情報をそこへ入れ込みました。 初心者であまり難しい専門用語はまだ勉強中ですが、教えて下さい。

  • ホームページビルダー

    ホームページビルダーでトップページ作成して 転送前にビジュアルサイトビューのフォルダを見ると 全然関係ないファイルが山のようにくっついていました。 どうしてでしょうか?それは普通であとで削除すればいいのですか?

  • HPビルダーV9 初期化後のビジュアルサイトビュー

    ホームページビルダーV9を使用しています。(OSはwindowsXP SP2) このソフトにてホームページ(以下、HP)を作成し問題なくアップできていたのですが、別理由でPCを初期化する必要があったため、HPのデータをフォルダごとバックアップしました。 初期化後、再度HPビルダーV9をインストールし、HPデータもPC内に戻しました。そして、ページを更新してアップしようと思い、「ページの公開」をクリックしてビジュアルサイトビューを表示すると、今までと大きく異なる表示になっていました。indexファイルのみが表示されており、そのほかのファイルは全て下の「リンクされていないHTMLファイル」に表示されています。 なぜでしょうか? 今までインターネット上で問題なく機能していたHTMLファイルなので当然すべてリンクでつながっています。実際HPビルダー上でindexファイルをプレビューしてもリンク先に飛ぶことができます。 どうすれば正しい表示にできるでしょうか? このままアップすればどうなるかもわからなくて困っています。 ちなみにファイルのアイコンにはすべて「*」がついています。(インターネット上にあるファイルは全て初期化前にアップしたもののため。) よろしくお願いいたいます。

  • ホームページビルダー11 ファイルの名前変更

    質問お願いいたします ホームページビルダー11で4ページ作成 トップページがhtm でしたのでhtmlに変更したところ 始めのビジュアルサイトビューの画面で トップページ以外が消えてしまいました どうすれば元の状態に戻せるでしょうか? よろしくお願いいたします!

  • トップページ以外がでません

    はじめまして。 HPに関してまったくの素人なので質問させて下さい。 ホームページビルダー12を使っています。 トップページは転送するとちゃんと表示されるのですが、そのページに貼り付けたリンクページがでません。 ビルダー内でのプレビューではちゃんとリンクできるし、リンク先ページの転送もエラーなくちゃんとできました。 トップページしかでないというのはどのような原因が考えられるのでしょうか? (ちなみに、トップページに張り付けた『掲示板』などはうまくリンクできています。)

  • ビジュアルサイトビューでindexのトップページになるページに赤い×印がついています。

    ホームページビルダーV9を使っています。ビジュアルサイトビューでトップページになるページで矢印の上に赤い×印がついています。プレビューでは、トップページからちゃんとリンクしている所に飛べます。何がいけないのでしょうか?どうすればよくなりますか?パソコン初心者でパソコンの専門用語も分からなくて困っています。誰か教えて頂けますか?よろしくお願いします。