• 締切
  • すぐに回答を!

更新phpで画像を投稿するとエラー

  • 質問No.3273050
  • 閲覧数54
  • ありがとう数1
  • 気になる数0
  • 回答数2
  • コメント数0

お礼率 50% (60/120)

いつもお世話になっております。
今回はphpの事で困っております。

投稿型で更新の出来る新着情報phpがあります。
以前までなんの問題なく動いていたのですが、いつものように画像を更新しようとすると
「Fatal error: imagecreatetruecolor(): requires GD 2.0 or later…」のエラーが出るようになってしまいました。

かなり前に出たことがあるのですが、これを修復したプログラムを貰って、解決し、今まで動いていたのですが…
突然またエラーが再発してしまいました。

どなたか解決方法を教えてください。
宜しくお願い致します。

回答 (全2件)

  • 回答No.2

ベストアンサー率 40% (10/25)

前回の回答にも書きましたがご質問者様の「ご利用環境」が
分からないので、お答えできないのです。

もしご質問者様がそれをご存知ないのであれば、知っている方に
聞いていただくしかありません。
レンタルサーバを利用しているのであればその会社に、どなたか
お知り合いの方に設定していただいたのであればその方に。
補足コメント
tse-sie

お礼率 50% (60/120)

kiyusaさんの言う「ご利用環境」とはマシンのことですか?
サーバーのことですか?
マシンはmacOSXでサーバーはclasscatというレンタルサーバーです。
kiyusaさんの言う「知っている方」がいないのでこちらで質問させて頂いたのですが、調べ方が分からない・お答え出来ないということなので質問を取り下げさせていただきます。
投稿日時:2007/08/23 11:03
  • 回答No.1

ベストアンサー率 40% (10/25)

ご利用の環境がまったく書かれていないので、以下のマニュアルの内容を
確認してください。
#PHPのバージョン、GDのバージョン
お礼コメント
tse-sie

お礼率 50% (60/120)

すみません。
別ファイルを使用する事で自己解決しましたが、原因が分からないままなので引き続き教えてください。
URL参照しましたがPHPのバージョン、GDのバージョンの調べ方が分かりません…
投稿日時:2007/08/21 16:35
結果を報告する
このQ&Aにはまだコメントがありません。
あなたの思ったこと、知っていることをここにコメントしてみましょう。
AIエージェント「あい」

こんにちは。AIエージェントの「あい」です。
あなたの悩みに、OKWAVE 3,600万件のQ&Aを分析して最適な回答をご提案します。

関連するQ&A

その他の関連するQ&Aをキーワードで探す

ピックアップ

ページ先頭へ