-PR-
解決済み

java-prugin1.3、Netscape communicatorでアプレットが呼び出せない。

  • 暇なときにでも
  • 質問No.299249
  • 閲覧数80
  • ありがとう数1
  • 気になる数0
  • 回答数2
  • コメント数0

お礼率 83% (20/24)

私は現在JAVAアプレットを作成しそのクラスファイルをjarにして
そのjarファイルの中からクラスファイルをロードするhtmlを書きたいので、
アプレットを貼り付ける個所に以下のようにタグを書いたのですがJAVAコンソール上でクラスが見つかりません。といわれて失敗してしまいます。
(netscapeのみ失敗します。IEは成功してアプレットを実行できます。)

何か他に必ず指定しなければいけない属性があるのでしょうか?
javadocも見て確認したのですが。。。

どなたか教えていただけないでしょうか?

ちなみにjarファイルもhtmlファイルも全て同階層のディレクトリにおいてあります。
----------ソースここから--------------
<OBJECT classid="clsid:8AD9C840-044E-11D1-B3E9-00805F499D93"
width="200" height="200"
codebase="http://java.sun.com/products/plugin/1.3/jinstall-13-win32.cab#Version=1,3,1,3">
<PARAM NAME="code" VALUE="ReportSample.class">
<PARAM NAME="archive" VALUE="Sample.jar">
<PARAM NAME="codebase" VALUE=".">
<PARAM NAME="type" VALUE="application/x-java-applet;version=1.3">
<PARAM NAME="mylabel" VALUE="MyLabel">
<COMMENT>
<EMBED type="application/x-java-applet;version=1.3"
width="200" height="200" align="baseline"
java_archive="Sample.jar"
java_codeBase="./"
java_code="ReportSample.class"
 pluginspage="http://java.sun.com/products/plugin/1.3/plugin-install.html">
<NOEMBED>
</COMMENT>
Java Plug-inの実行に失敗しました
</NOEMBED>
</EMBED>
</OBJECT>


--------------------------------------
通報する
  • 回答数2
  • 気になる
    質問をブックマークします。
    マイページでまとめて確認できます。

質問者が選んだベストアンサー

  • 回答No.2
レベル11

ベストアンサー率 47% (160/334)

再びatonです。

#1の回答は間違いでした。

Java Plug-in は Netscape Navigator/Communicator 3.0 以降をサポートしているようです。
(最新のJava Plug-inのインストール手引き(http://java.sun.com/getjava/download.html)を見るとIEとNetscape 6しか名前が出ていなかったので,その2つしかサポートされていないのかと誤解していました)

ただ,Java Plug-inのバージョンとブラウザーのバージョンの組み合わせでいろいろ動作が異なるようで,その辺りのことをまとめた情報が,参考URLのページ(英語。日本語のものも探せばあるかもしれません)に載っています。

基本的には,NN/NC 4.x系では,

・<object>タグはサポートされていない
・<applet>タグだとブラウザーのVMが動作する

ので,Java Plug-inを使うには<embed>タグを使わなければいけないようです。

youhiさんの質問中のソースでも<embed>タグが書かれているのに動作しない理由はよくわかりません。もしかしたら<object>タグ中に<embed>タグが含まれているのがいけないのかもしれません。<embed>だけでもIEやNS6でも動作するはずなので,一度<embed>タグだけで試してみてはどうでしょうか?

その他の回答 (全1件)

  • 回答No.1
レベル11

ベストアンサー率 47% (160/334)

不確かな記憶ですが,Netscape Communicator (4.x系列) は独自のVMを持っていて,Java Plug-in は使えなかったのでは?
お礼コメント
youhi

お礼率 83% (20/24)

ご回答ありがとうございます。。。

うへ!まじすか?
そんなぁ。初耳。うーん。。。
じゃぁ<APPLET>タグで指定いいのかな。。。
そっちの方向でも調べてみようと思います。
投稿日時 - 2002-06-25 14:01:19


このQ&Aで解決しましたか?
関連するQ&A
こんな書き方もあるよ!この情報は知ってる?あなたの知識を教えて!
このQ&Aにはまだコメントがありません。
あなたの思ったこと、知っていることをここにコメントしてみましょう。

その他の関連するQ&A、テーマをキーワードで探す

キーワードでQ&A、テーマを検索する
-PR-

特集


開業・独立という夢を持つ人へ向けた情報満載!

ピックアップ

ページ先頭へ