解決済み

ルーターを入れたらレスポンスが悪くなりました

  • すぐに回答を!
  • 質問No.21086
  • 閲覧数399
  • ありがとう数18
  • 気になる数0
  • 回答数18
  • コメント数0

こんにちは
いつもお世話になっています。
環境説明から
PC1:P3ー600Mhz
MEM 128MB-CL2
M/B ASUS P3BF
HDD 20GB
EtherCard Melco PCI Fast Ethernet(100BASE) 
OS Win98SE
TA OMRON MT128S-D/U2

PC2 CELERON300A
MEM 128MB-CL2
M/B ASUS P2BF
HDD 20GB
EtherCard NE2000Compatible(10BASE)
OS Win98SE

EtherHUB pci_ FX-05SC(5Port Fast Etherenet Switching HUB)

上記の環境ですが
昨日PC1に以前付けていたHDD(Linux RedHat7J)を外しました
するとMBRにLILOが残っていたためWindowsを起動できなくなってしまいました
しょうがなく起動ディスクを使ってWin98SEの再インストールを試みたのですがWin98SEはアップグレード版の為
DOSからはインストールできませんでした。

仕方なく始めにWin98をインストールしてその後にWin98SEをインストールしました
すると、PC1とPC2の間でのデータ転送速度がめちゃくちゃ遅くなりました(不安定です)
HUBを入れる前はPIA to PIAでクロスケーブルで接続してPC1をインターネットに接続してPC2は「インターネット接続の共有」で接続していました。

HUBを入れたのは昨日ですが、HUBとイーサネットの相性とか関係あるのでしょうか?
それとも設定のどこかが悪いのでしょうか?
原因がわかりません
PC2の方は設定は全く変えていません
PC1は「インターネット接続の共有」を再インストールしました
PC1のイーサカードのIPアドレスとサブネットマスクは
設定したほうがいいのでしょか?
その他、「ココとココをチェックしてみて」というのをご指導お願いいたします
よろしくお願いいたします

質問者が選んだベストアンサー

  • 回答No.6

ベストアンサー率 25% (873/3452)

NICとHUBに相性はあるかとの事ですが、ある事もあります。
特に相性問題をおこし易いのが10/100の自動切換えがあるNICやHUBの場合、オートネゴシエーションやフロー制御の方法が規定される前の製品だと、ネゴシエーションに失敗して異常動作する事があります。クロスケーブルでHUBなしで接続するとうまく行くという事ですので、この互換性問題をおこしている可能性もあります。私の知る範囲では低価格スイッチングHUBでHUB側に手動設定を持っている物がMELCOしか知らないので、NIC側で速度固定を試みてくださいと書きました。
それで、銘柄をそろえたほうが良いかどうかという質問ですが、先ほどのような理由で同一銘柄でも新旧を混在させてしまえば互換性が取れなくなる可能性もあります。一方、最近製品同士であれば銘柄が異なっても大概平気です。

ケーブルの品質は短距離でしたら繋がってさえいればまず大丈夫ですが、コネクターの圧着不良までは分りません。不良品である可能性はゼロではありませんがpingが通るのですからまず平気だと思います。それよりも、クロスケーブルで正常でNICの速度固定をした上でHUBでテストしてもおかしいのであれば、HUBが不良品の可能性が浮上してきそうです。

あと、NICのドライバーの入れ直しはまだしていないようですが、ドライバー、プロトコル、サービス等、一度全部入れ直してみても良いと思います。但し、クロスケーブルで問題が無いのでしたら恐らく正常だとは思いますけれど。
IPアドレスについては先にも書いたようにPC1、PC2ともに手動設定にしてみてください。
補足コメント
noname#38849

適切な解答を有難うございます
クロスケーブルで異常が無いので、やはりHUBを疑ってみます
IPアドレスをホスト(PC1)とクライアント(PC2)とも手動設定してやるとクライアントから「インターネット接続の共有」が出来なくなりました。

通常 Pia to PiaからHUBを入れてストレートケーブルに変更しただけの場合は
NICなどの設定を変える必要があるのでしょうか?
投稿日時 - 2000-12-22 11:50:52
感謝経済

その他の回答 (全17件)

  • 回答No.18

ベストアンサー率 25% (873/3452)

回答するの忘れてました。(^^;)

フロー制御が出来なくてオーバーフローしてしまうのの確認方法、ん~、思い付かない……。両方のスピードを10baseでOK、片方10、もう片方100でこけて、100同士ならOKならって、それでも確証を得た事にはならんよね、100同士でも10同士でも受信側がbusyならこけるし……
ところで、asucaさんの案も最終手段かも知れませんけど、PC1<->PC2のファイル転送が失敗するのとは関係ないですよね。(^^;)
ところで、シリアルルーターって言うんですかねぇ?今あるTAなどに付け足すとルーターになってくれるものがあるのですが、大体値段は1万2千円くらいです。

でも、まずはHUB問題ですけれど、うーむ、何か進展はありました?
補足コメント
noname#38849

補足解答有難うございます

残念ながら、私のTAはUSB接続のみ、ですのでシリアルルータは使用できません  ^^;
HUB(本体)を本日、別のLAN環境に持ち込んで繋いでみます
それでOKなら、自宅のPCの設定がダメということで
OKならHUBの初期不良と言うことになると思いますので・・

他人のトラブルなのに皆様は親身にトラブルシュートして頂いて
ホントに感激しております。

有難うございます
投稿日時 - 2000-12-27 10:03:40
お礼コメント
noname#38849

marimo_cxさんには沢山の解答を頂きホントに有難うございました

まずはHUBを別環境に持ち込んでのテスト結果から報告させていただきます。

結果から申し上げますと、同じ症状でした・・・
で、販売店に初期不良と言う事で交換していただきました
自宅に持ち帰って接続してみると
「・・・・  ・・・・  ・・・ ん? ・・・ なんで?」
同じ症状でした。
LANカードをpci_社で揃えてしまおうと思って同じモノを
購入していたので、PC1のLANカード交換してみたところ
何の問題も無くサクサクといってくれました。

原因不明のまま解決しました・・・
しいて言えばPC1に刺していたメルコ製のLANがコリジョンを発生させていたんだと思われますが
コリジョンの原因は不明です ^^;

つまり「HUBとEathenetカード間にも相性があった」という
結果(?)になりました ^^;

marimo_cxの貴重なお時間を使わせていただきホントに有難うございました
marimo_cxさんのおかげでスキルが少しだけアップしました
投稿日時 - 2000-12-28 10:21:53
  • 回答No.17

ベストアンサー率 47% (11786/24626)

ちなみにルータという選択肢は無いのでしょうか?
共有などの面倒な設定もいらないしレスポンスも良いですよ。一度使うとやみつきになってTAには戻れなくなります。もちろんPC <-> PCのためにSWITCHING HUBはそのまま生かせますし。
補足コメント
noname#38849

補足解答有難うございます
一応、選択肢の一番最後にあります、
と言うのは、将来CATVにするか、ADSLにするか迷っているので
現段階でのダイヤルアップルーターの線は薄いですね
投稿日時 - 2000-12-27 10:11:03
お礼コメント
noname#38849

多数の有益な解答を有難うございました

問題解決いたしました。
原因はメルコ製のLANカードでした・・・(?)
まず、HUBを別のLAN環境で接続したところ、やはりダメでした
そこで、初期不良品と思い販売店に出向いて交換して頂きました。
自宅に持ち帰りテストしてみると・・・・
「アレレ??・・ なんで?」同じ症状です・・・
pci_社のLANカードをもう一枚買ってきたので、PC1を入れ替えて
もう一度テストすると、問題なく「AutoSens」でも問題なく動いてくれました

今回のトラブルにおける、一考察として
・LANカードとHUBの相性があった
ということになりました

asucaさんにはご多忙中、貴重なお時間を割いて沢山の解答を頂きホントに有難うございました。
投稿日時 - 2000-12-28 10:09:51
  • 回答No.16

ベストアンサー率 47% (11786/24626)

しまった、忘れてました。
PC1 192.168.0.1
PC2 192.168.0.2
でやってみてください。
ルータを入れてから共有をやって無くって忘れてました。
補足コメント
noname#38849

補足解答、有難うございます

一回整理して現在の設定情報を記述しますので検討していただけ無いでしょうか?

PC1: MELCO LGY-PCI-TXR
IP : 192.168.0.1
SUBNET : 255.255.255.0
転送速度 : 100-半二重

PC2: pci_FNW-9702-T
IP : 192.168.0.2
SUBNET : 255.255.255.0
転送速度 : 100-半二重

に設定しています。
勿論、それぞれ10half-10halfや10Full-10Fullでも
テストしました。
投稿日時 - 2000-12-27 10:18:53
  • 回答No.15

ベストアンサー率 47% (11786/24626)

HUBは滅多に不良品など無いと思うんですが、スイッチングHUBは内部構造もある程度複雑ですのであり得ないとは言えません。
またNICに関しては私の経験ではそれほど同一メーカーにこだわる必要はないと思います。
良心的な店でしたら新品交換をすぐしてくれますので
安定した正月が迎えられると良いですね。
補足コメント
noname#38849

EtherカードのIPアドレスですが
PC1をホストとして「インターネット接続の共有」を
していますのでPC1は「192.168.0.1」以外には
設定できないようですが問題ないのでしょうか?
(試してないですがWindowsのヘルプに書いてありました・・)
投稿日時 - 2000-12-26 15:33:34
  • 回答No.14

ベストアンサー率 25% (873/3452)

> pingは届くのにHUB自体の初期不良ってあるでしょうか?

バカハブならpingが飛べば正常と言い切って問題ないのですが、スイッチングハブの場合、パケットを右から左にただ中継するのではなく、一度パケット全体を受け取ってからMACアドレスなどの解析を行って、適切なポートに“だけ”送り出すという仕事をしている装置です。それなので、pingという小さなパケット(データ)は正常に扱えるのに、大きなパケットが来るとハングってしまうという事はありえる事です。それと、pingのパケットはicmpというもので、通常(というと語弊があるけど…)のパケットとは形も違いますので、pingが飛ぶというのは、スイッチングハブやルーターのような機器の場合、電線が電気的に繋がっているという事だけで全てが正常に機能していると言い切れるわけではありません。
一応ご説明。(笑)

P.S.
そう言えば大きいファイルのやり取りでハングるのですから、HUBかNICかどっちの責任かは今の所不明ですが(でもPC3でもちゃんと動かないのだからHUBだとは思うのですが…)フロー制御がうまくいかずにHUBのキャッシュがあふれているというのが今回の原因かも知れませんね。
補足コメント
noname#38849

解答有難うございます

大変解りやすくて、参考になります
プロトコルについてはとても疎いので勉強になります
フロー制御の検査方法は下記にも出てるように
10BASEの半二重などで固定する、などの方法でよいのでしょうか?

やはりHUBの交換でしょうか?
NICですが、片方はメルコ製(廉価製品)もう片方は
メジャーなpci_製なのですが、どうでしょう?
LANの「通信回りは同一メーカーで揃える」みたいな
暗黙の常識みたいな事があるのでしょうか?
投稿日時 - 2000-12-26 10:10:09
  • 回答No.13

ベストアンサー率 25% (873/3452)

もう一台PCを用意されてのテスト、お疲れ様です。
その状況ですと、私もasucaさんのHUB不良であろうという意見に賛成です。
asucaのおっしゃるように、初期不良品の疑いという事で販売店にご相談されたら良いと思います。
補足コメント
noname#38849

補足解答、有難うございます

今度、(21世紀を迎える前に・・)販売店に問い合わせて見ます

しかし、このような症状はLANでは頻繁に起こっているのでしょうか?
投稿日時 - 2000-12-26 10:16:07
  • 回答No.12

ベストアンサー率 47% (11786/24626)

うーん、ここまで来るとHUB自体の故障は十分考えられますね。まだ買ったばかりだと思いますので店の方と
相談してみてはいかがでしょうか?
良い店だったら新品交換してくれると思いますので
それでもう一度やってみるのが早いと思います。
補足コメント
noname#38849

補足解答有難うございます

販売店に問い合わせて見ます・・・
新品交換してくれると良いのですが・・・
投稿日時 - 2000-12-26 10:18:23
  • 回答No.11

ベストアンサー率 33% (1/3)

(marimo cxさんへ)
(「NICの速度等の設定」に関して、適切なフォローアップありがとうございます。)

まずNICを確実に 10Mbps/Half Dupulex にしてみてくださいね。

それでもダメな場合、あるいはNICの設定パネルやFull(全二重)/Half(半二重)の設定方法がどうしても分からない場合は、少々古典的ではありますが、PC2台が起動している状態で「pci_ FX-05SC スイッチングHUB」の電源を抜き差ししてみてはいかがでしょうか(あるいはその逆にスイッチングHUBの電源を先に入れておいて、後からPC2台を起動、再起動する)。

あとはフツーのHUB(スイッチングではないモノ)を用意できるのであれば、それに取り替えてみるのはいかがでしょうか(クロスケーブルで直結となんら変わらなくなりますが・・・)。
補足コメント
noname#38849

回答ありがとうございます

上記の設定をイロイロと試してみました。
結果は、やはり同じでした・・・
ポートやケーブルも差し替えてみましたが結果は同じでした・・

pingは届くのにHUB自体の初期不良ってあるでしょうか?

ホントに原因不明です。
投稿日時 - 2000-12-25 09:17:31
  • 回答No.10

ベストアンサー率 25% (873/3452)

だんだん入り乱れて解り難くなってきましたねぇ。(苦笑)


まず、100baseOKと箱に書いてあったならそれはカテゴリー5のケーブルですので、万が一不良品でない限りケーブル選びはそれで大丈夫です。ちなみに、カテゴリーがいくつなのかはケーブルに印刷していない限り外観から区別する方法はありません。

NICの速度等の設定は 「コントロールパネル > ネットワーク > ネットワークの設定 > EtherCard Melco PCI Fast Ethernet(を、選択してプロパティを出す) > 詳細設定」で、プロパティの中をちくちくいじっていれば解ると思います。

> IPアドレスをホスト(PC1)とクライアント(PC2)とも手動設定してやるとクライアントから「インターネット接続の共有」が出来なくなりました。
これは接続共有のどこかの設定の問題でしょうが、混乱するのでひとまず一旦置いておきましょう。^^;
補足コメント
noname#38849

ありがとうございます

ごみ箱を漁ってケーブルのパッケージを見つけたら
「カテゴリー5」と書いてありました。 ^^;

直近の症状ですが
HUBにもう一台ノートPC(ダイナブック)を繋いで見ました
*(以下PC3)
TOSHIBA Dynabook 300CT
CPU Pentium MMX166
MEM 96MB
EtherenetCard Billionton LNT-10TB Etherenet PCMCIA Adapter
-----------------------------------

症状は、やはり同じくPC3からもインターネットに接続すると
MSNのトップページを途中まで読み込んでフリーズします
また、PC2とPC3の間でのファイルの転送も出来ません
PC2→PC3へファイルを転送するとエラーメッセージで
「○○○○を作成または置き換えできません、指定されたネットワークリソースまたはデバイスは、もう使用できません」と出ます
この症状は、PC1→PC3間でも同じです

PC3→PC2ではものすごくレスポンスが悪くPC3からPC2のフォルダを開くのにも30秒以上かかります、
PC3でPC2にあるファイルを取りに行くと、やはり上記の
エラーメッセージが出ます。

PC3のエクスプローラーでネットワークを開くと
それぞれのPCは見えています
PC3から他の2台のPCにping打ってみてもロスもなく問題ありません
その反対のPC1とPC2からPC3へpingを打っても問題ありません

PC3-PC1をピア・ツー・ピアで繋ぐと全く問題ありません
WEB閲覧も問題ありません。
同様に、PC3-PC2間でも全く問題ありません。

どうも,HUB自体の固体不良のように感じますがいかがでしょう?
投稿日時 - 2000-12-24 12:34:11
  • 回答No.9

ベストアンサー率 33% (1/3)

Duplexモードについて補足します。
Full Duplex = 全二重
Half Duplex = 半二重
とも言います。

一般的に「HUB(正確にはリピータHUB)」は半二重で動作し、「Switch(正確にはスイッチングHUB)」は全二重/半二重のどちらでも動作します。
したがって「pci_ FX-05SC」は Switch ですので、全二重/半二重のどちらでも動作するため、オートネゴシエーションという機能で Full or Half いずれかで自動認識します。
(正しく動作すると 100 Full > 100 Half > 10 Full > 10 Half の優先順位)
この自動認識が Switch と PCのNIC でズレるケースがあるのです。
そのズレを防止するために自動認識ではなく Full or Half(ついでに10or100も)を固定にします。
補足コメント
noname#38849

初歩的な質問で恐縮ですが

>そのズレを防止するために自動認識ではなく
> Full or Half(ついでに10or100も)を固定にします。

は、どこから設定したらよいのでしょうか?
投稿日時 - 2000-12-22 16:04:22
17件中 1~10件目を表示
AIエージェント「あい」

こんにちは。AIエージェントの「あい」です。
あなたの悩みに、OKWAVE 3,500万件のQ&Aを分析して最適な回答をご提案します。

関連するQ&A
このQ&Aにこう思った!同じようなことあった!感想や体験を書こう
このQ&Aにはまだコメントがありません。
あなたの思ったこと、知っていることをここにコメントしてみましょう。

その他の関連するQ&A、テーマをキーワードで探す

キーワードでQ&A、テーマを検索する

特集


感謝指数によるOK-チップ配布スタート!

ピックアップ

ページ先頭へ