-PR-
解決済み

ルーターを入れたらレスポンスが悪くなりました

  • すぐに回答を!
  • 質問No.21086
  • 閲覧数373
  • ありがとう数18
  • 気になる数0
  • 回答数18
  • コメント数0

こんにちは
いつもお世話になっています。
環境説明から
PC1:P3ー600Mhz
MEM 128MB-CL2
M/B ASUS P3BF
HDD 20GB
EtherCard Melco PCI Fast Ethernet(100BASE) 
OS Win98SE
TA OMRON MT128S-D/U2

PC2 CELERON300A
MEM 128MB-CL2
M/B ASUS P2BF
HDD 20GB
EtherCard NE2000Compatible(10BASE)
OS Win98SE

EtherHUB pci_ FX-05SC(5Port Fast Etherenet Switching HUB)

上記の環境ですが
昨日PC1に以前付けていたHDD(Linux RedHat7J)を外しました
するとMBRにLILOが残っていたためWindowsを起動できなくなってしまいました
しょうがなく起動ディスクを使ってWin98SEの再インストールを試みたのですがWin98SEはアップグレード版の為
DOSからはインストールできませんでした。

仕方なく始めにWin98をインストールしてその後にWin98SEをインストールしました
すると、PC1とPC2の間でのデータ転送速度がめちゃくちゃ遅くなりました(不安定です)
HUBを入れる前はPIA to PIAでクロスケーブルで接続してPC1をインターネットに接続してPC2は「インターネット接続の共有」で接続していました。

HUBを入れたのは昨日ですが、HUBとイーサネットの相性とか関係あるのでしょうか?
それとも設定のどこかが悪いのでしょうか?
原因がわかりません
PC2の方は設定は全く変えていません
PC1は「インターネット接続の共有」を再インストールしました
PC1のイーサカードのIPアドレスとサブネットマスクは
設定したほうがいいのでしょか?
その他、「ココとココをチェックしてみて」というのをご指導お願いいたします
よろしくお願いいたします
通報する
  • 回答数18
  • 気になる
    質問をブックマークします。
    マイページでまとめて確認できます。

質問者が選んだベストアンサー

  • 回答No.6
レベル14

ベストアンサー率 25% (873/3452)

NICとHUBに相性はあるかとの事ですが、ある事もあります。
特に相性問題をおこし易いのが10/100の自動切換えがあるNICやHUBの場合、オートネゴシエーションやフロー制御の方法が規定される前の製品だと、ネゴシエーションに失敗して異常動作する事があります。クロスケーブルでHUBなしで接続するとうまく行くという事ですので、この互換性問題をおこしている可能性もあります。私の知る範囲では低価格スイッチングHUBでHUB側に手動設定を持っている物がMELCOしか知らないので、NIC側で速度固定を試みてくださいと書きました。
それで、銘柄をそろえたほうが良いかどうかという質問ですが、先ほどのような理由で同一銘柄でも新旧を混在させてしまえば互換性が取れなくなる可能性もあります。一方、最近製品同士であれば銘柄が異なっても大概平気です。

ケーブルの品質は短距離でしたら繋がってさえいればまず大丈夫ですが、コネクターの圧着不良までは分りません。不良品である可能性はゼロではありませんがpingが通るのですからまず平気だと思います。それよりも、クロスケーブルで正常でNICの速度固定をした上でHUBでテストしてもおかしいのであれば、HUBが不良品の可能性が浮上してきそうです。

あと、NICのドライバーの入れ直しはまだしていないようですが、ドライバー、プロトコル、サービス等、一度全部入れ直してみても良いと思います。但し、クロスケーブルで問題が無いのでしたら恐らく正常だとは思いますけれど。
IPアドレスについては先にも書いたようにPC1、PC2ともに手動設定にしてみてください。
補足コメント
noname#38849

適切な解答を有難うございます
クロスケーブルで異常が無いので、やはりHUBを疑ってみます
IPアドレスをホスト(PC1)とクライアント(PC2)とも手動設定してやるとクライアントから「インターネット接続の共有」が出来なくなりました。

通常 Pia to PiaからHUBを入れてストレートケーブルに変更しただけの場合は
NICなどの設定を変える必要があるのでしょうか?
投稿日時 - 2000-12-22 11:50:52
関連するQ&A
-PR-
-PR-

その他の回答 (全17件)

  • 回答No.5
レベル14

ベストアンサー率 47% (11786/24626)

IPアドレスは設定の必要があると思います。 PC1 192.168.0.2 PC2 192.168.0.3 あたりにしてサブネットマスクは255.255.255.0 あたりで良いと思います。 192.168.0.1は将来ルータを入れた時用にあけておくと良いと思います。 その後ハブの電源を入れ直した後、各PCの電源を入れてみて動作を確認してください。 ...続きを読む
IPアドレスは設定の必要があると思います。
PC1 192.168.0.2
PC2 192.168.0.3
あたりにしてサブネットマスクは255.255.255.0
あたりで良いと思います。

192.168.0.1は将来ルータを入れた時用にあけておくと良いと思います。

その後ハブの電源を入れ直した後、各PCの電源を入れてみて動作を確認してください。
補足コメント
noname#38849

ありがとうございます
大変参考になります
早速、試してみます。
他の方の回答に補足を入れたのですが
ネットワークドライバ(Ethernet)をいったん削除して
入れなおすのはマズイでしょうか?
また、カードとHUBの相性などもあるのでしょうか?
投稿日時 - 2000-12-22 09:15:32


  • 回答No.7
レベル14

ベストアンサー率 47% (11786/24626)

PLANEXのFX-05SCでしたらNICとの相性はそれほど考えなくても良いと思いますがマニュアルにもあるとおりケーブルのカテゴリーは結構問題になることがあります。マニュアルにあるとおりの規格の物を使った方がよいです。 もし何らかの理由でマニュアルがなければ下記アドレスで見ることも出来ますので確認してください。 ...続きを読む
PLANEXのFX-05SCでしたらNICとの相性はそれほど考えなくても良いと思いますがマニュアルにもあるとおりケーブルのカテゴリーは結構問題になることがあります。マニュアルにあるとおりの規格の物を使った方がよいです。
もし何らかの理由でマニュアルがなければ下記アドレスで見ることも出来ますので確認してください。
補足コメント
noname#38849

解答有難うございます
ケーブルのカテゴリーですがケーブルのパッケージ(包装)は
「10BASE/100BASE OK!」とありましたので購入したのですが
カテゴリー3とかカテゴリー5とかを見分ける方法はありますか?
パッケージは捨てちゃいました。
投稿日時 - 2000-12-22 15:23:34
  • 回答No.8
レベル5

ベストアンサー率 33% (1/3)

障害切り分けから・・・ クロスケーブルで直接つなぐとうまくいって、Switchを介すとうまくいかない。 これはおそらく PCのNIC ~ Switchポート 間の障害ですね。 PCのNIC ~ Switchポート のケーブル不良(可能性小)か、オートネゴシエーション・エラー(可能性大)の疑いがあります。 ケーブル不良を確かめるには、ケーブルを新しいものに交換してみてください。 オートネゴ ...続きを読む
障害切り分けから・・・
クロスケーブルで直接つなぐとうまくいって、Switchを介すとうまくいかない。
これはおそらく PCのNIC ~ Switchポート 間の障害ですね。
PCのNIC ~ Switchポート のケーブル不良(可能性小)か、オートネゴシエーション・エラー(可能性大)の疑いがあります。

ケーブル不良を確かめるには、ケーブルを新しいものに交換してみてください。

オートネゴシエーション・エラーかどうかを確かめるには、
今の環境であれば NIC の設定を "10Mbps/Half Duplex" で固定にすると良いと思います(PC2は10Mbpsですしね。)

#本当は、Switchのポートも同様に "10Mbps/Half Duplex" に固定できると良いのですが、「pci_ FX-05SC」はオートしかできない(というより設定のしようがない・・・)ですよね?

参考) 上記のDuplexモードがズレている(片側がFullで、もう片側がHalf)と、「つながるけど不安定な状態」になりがちです。
これはFull側で輻輳(パケットがきちんと送信できずに、再送処理が発生してしまう)が頻発しやすく、結果としてパフォーマンスが著しく悪くなってしまうためです。

御参考にしていただければ幸いです。
補足コメント
noname#38849

適切なご解答有難うございます

PC2の方はEthereCardをpci_FNW-9702-Tに変えてみましたが
結果は同じでした、
初歩的なチェック、いろいろとPJ-45ポートを差し替えたり
ケーブルを入れ替えてみたりとしてなかったので
チェックしてみます。
「灯台下暗し」になってるかもしれないので・・・
投稿日時 - 2000-12-22 15:28:22
  • 回答No.4
レベル14

ベストアンサー率 47% (11786/24626)

スイッチングハブを使っているあたりが臭いですね。 PC1のTCP/IPを10BASE固定に出来ませんか? それで試してみてください。 ハブの設定あたりも見てみてください。 ...続きを読む
スイッチングハブを使っているあたりが臭いですね。
PC1のTCP/IPを10BASE固定に出来ませんか?
それで試してみてください。

ハブの設定あたりも見てみてください。
補足コメント
noname#38849

回答ありがとうございます
HUBは電源とLANケーブルに繋ぐだけなのですが
何処の設定を見たら良いのでしょうか?
Ethernet Cardは、やはり同一メーカーで揃えるのがいいのでしょうか?(相性なんてあるのかな?)

ケーブルの品質とかも関係するのでしょうか?
ショップでイチバン安いのを買いましたが・・・
投稿日時 - 2000-12-22 09:19:07
  • 回答No.3
レベル10

ベストアンサー率 28% (42/146)

不安定・・・というのはどういうことでしょう? 途中で失敗することがあるのでしょうか? そうなら、ケーブルを変えてみてはいかがでしょうか。 もし、ルーターがあるのでしたら、各PCから ルーターにpingを打てばどちらのケーブルに異常があるのか 発見できると思います。 両方から打って遅いなら、ルータとHUBを結ぶケーブルでしょう。 TAしかないならこの方法は使えませんが。 ...続きを読む
不安定・・・というのはどういうことでしょう?
途中で失敗することがあるのでしょうか?
そうなら、ケーブルを変えてみてはいかがでしょうか。

もし、ルーターがあるのでしたら、各PCから
ルーターにpingを打てばどちらのケーブルに異常があるのか
発見できると思います。
両方から打って遅いなら、ルータとHUBを結ぶケーブルでしょう。
TAしかないならこの方法は使えませんが。
補足コメント
noname#38849

タイトルは「HUBを入れたらレスポンスが悪くなりました」の誤記です
失礼しました。

不安定というのは、たとえばPC1からPC2に3MBくらいのファイルを送ると途中で送り元がフリーズします。
PC2のほうはインターネットに接続してブラウジングしてるとMSNのトップページの半分ほど読み込んでフリーズです。
pingはPC1とPC2と両方から打ってみましたがどちらも問題ないようです。
原因はPC1にあるように感じられるのですが・・・
どこの設定でしょうか?
ネットワークアダプタのドライバを全部削除してPnPで読み込ませるのはどうでしょうか?
危険ですか?
投稿日時 - 2000-12-21 23:23:58
  • 回答No.1
レベル14

ベストアンサー率 25% (873/3452)

的確な機器構成の説明で良いのですが、なんかルーターが見当らない……(^^; > PC1のイーサカードのIPアドレスとサブネットマスクは > 設定したほうがいいのでしょか? ということは、現在は設定していないという事ですね? Win98の自動設定に頼るよりもやはり手動で固定的に設定してみると良いのではないでしょうか。 あと、一応念のためですが、Ethernetケーブルは正しく繋がれていま ...続きを読む
的確な機器構成の説明で良いのですが、なんかルーターが見当らない……(^^;

> PC1のイーサカードのIPアドレスとサブネットマスクは
> 設定したほうがいいのでしょか?

ということは、現在は設定していないという事ですね?
Win98の自動設定に頼るよりもやはり手動で固定的に設定してみると良いのではないでしょうか。
あと、一応念のためですが、Ethernetケーブルは正しく繋がれていますか?
見間違いでストレートケーブルをカスケード端子に刺してしまっているとか。(もしそうなら全く通信できませんけど)
あとは試みとしてPC1のNICをオートネゴシエーションではなく手動で10Baseに設定してみるとかでしょうか?
でも、この程度はもうやっていますよねぇ?今の所どこまで試しましたでしょうか?

P.S.
今更なのですが、LILOの削除はDOSで「fdisk /mbr」ですが、駄目でした?
補足コメント
noname#38849

始めに「ルーター」ではなく「TA」の誤りです・・・
失礼しました。

ケーブル類は再三チェックしました
PC2のEthernetカードをpci_ のFNW-9702Tに差し替えましたが
結果は同じでした、
LILOの削除は再インストール後に知りました・・・
PC2の症状が
・インターネットに繋がるのですがブラウジング途中で固まる
・PC2でメールチェックが出来ない(POP3)に繋がらない
です
投稿日時 - 2000-12-21 23:04:43
  • 回答No.2
レベル11

ベストアンサー率 55% (155/280)

タイトルのルーターが、スイッチングハブとはまったく別物なのは ともかくとして… そのハブをはずしてクロスケーブルでの接続に戻すことはできない のですか?それをやったら、元の安定した状態にもどるんでしょうか? ...続きを読む
タイトルのルーターが、スイッチングハブとはまったく別物なのは
ともかくとして…

そのハブをはずしてクロスケーブルでの接続に戻すことはできない
のですか?それをやったら、元の安定した状態にもどるんでしょうか?
補足コメント
noname#38849

失礼しました、誤記です。
ルーターではなくTAで接続しています
タイトルは「HUBを入れたらレスポンスが・・・」と解釈してください
元のピア・ツー・ピアに戻すと、問題なくサクサク行きます
投稿日時 - 2000-12-21 23:19:06
  • 回答No.9
レベル5

ベストアンサー率 33% (1/3)

Duplexモードについて補足します。 Full Duplex = 全二重 Half Duplex = 半二重 とも言います。 一般的に「HUB(正確にはリピータHUB)」は半二重で動作し、「Switch(正確にはスイッチングHUB)」は全二重/半二重のどちらでも動作します。 したがって「pci_ FX-05SC」は Switch ですので、全二重/半二重のどちらでも動作するため、オートネゴ ...続きを読む
Duplexモードについて補足します。
Full Duplex = 全二重
Half Duplex = 半二重
とも言います。

一般的に「HUB(正確にはリピータHUB)」は半二重で動作し、「Switch(正確にはスイッチングHUB)」は全二重/半二重のどちらでも動作します。
したがって「pci_ FX-05SC」は Switch ですので、全二重/半二重のどちらでも動作するため、オートネゴシエーションという機能で Full or Half いずれかで自動認識します。
(正しく動作すると 100 Full > 100 Half > 10 Full > 10 Half の優先順位)
この自動認識が Switch と PCのNIC でズレるケースがあるのです。
そのズレを防止するために自動認識ではなく Full or Half(ついでに10or100も)を固定にします。
補足コメント
noname#38849

初歩的な質問で恐縮ですが

>そのズレを防止するために自動認識ではなく
> Full or Half(ついでに10or100も)を固定にします。

は、どこから設定したらよいのでしょうか?
投稿日時 - 2000-12-22 16:04:22
  • 回答No.10
レベル14

ベストアンサー率 25% (873/3452)

だんだん入り乱れて解り難くなってきましたねぇ。(苦笑) まず、100baseOKと箱に書いてあったならそれはカテゴリー5のケーブルですので、万が一不良品でない限りケーブル選びはそれで大丈夫です。ちなみに、カテゴリーがいくつなのかはケーブルに印刷していない限り外観から区別する方法はありません。 NICの速度等の設定は 「コントロールパネル > ネットワーク > ネットワークの設定 > Eth ...続きを読む
だんだん入り乱れて解り難くなってきましたねぇ。(苦笑)


まず、100baseOKと箱に書いてあったならそれはカテゴリー5のケーブルですので、万が一不良品でない限りケーブル選びはそれで大丈夫です。ちなみに、カテゴリーがいくつなのかはケーブルに印刷していない限り外観から区別する方法はありません。

NICの速度等の設定は 「コントロールパネル > ネットワーク > ネットワークの設定 > EtherCard Melco PCI Fast Ethernet(を、選択してプロパティを出す) > 詳細設定」で、プロパティの中をちくちくいじっていれば解ると思います。

> IPアドレスをホスト(PC1)とクライアント(PC2)とも手動設定してやるとクライアントから「インターネット接続の共有」が出来なくなりました。
これは接続共有のどこかの設定の問題でしょうが、混乱するのでひとまず一旦置いておきましょう。^^;
補足コメント
noname#38849

ありがとうございます

ごみ箱を漁ってケーブルのパッケージを見つけたら
「カテゴリー5」と書いてありました。 ^^;

直近の症状ですが
HUBにもう一台ノートPC(ダイナブック)を繋いで見ました
*(以下PC3)
TOSHIBA Dynabook 300CT
CPU Pentium MMX166
MEM 96MB
EtherenetCard Billionton LNT-10TB Etherenet PCMCIA Adapter
-----------------------------------

症状は、やはり同じくPC3からもインターネットに接続すると
MSNのトップページを途中まで読み込んでフリーズします
また、PC2とPC3の間でのファイルの転送も出来ません
PC2→PC3へファイルを転送するとエラーメッセージで
「○○○○を作成または置き換えできません、指定されたネットワークリソースまたはデバイスは、もう使用できません」と出ます
この症状は、PC1→PC3間でも同じです

PC3→PC2ではものすごくレスポンスが悪くPC3からPC2のフォルダを開くのにも30秒以上かかります、
PC3でPC2にあるファイルを取りに行くと、やはり上記の
エラーメッセージが出ます。

PC3のエクスプローラーでネットワークを開くと
それぞれのPCは見えています
PC3から他の2台のPCにping打ってみてもロスもなく問題ありません
その反対のPC1とPC2からPC3へpingを打っても問題ありません

PC3-PC1をピア・ツー・ピアで繋ぐと全く問題ありません
WEB閲覧も問題ありません。
同様に、PC3-PC2間でも全く問題ありません。

どうも,HUB自体の固体不良のように感じますがいかがでしょう?
投稿日時 - 2000-12-24 12:34:11
  • 回答No.15
レベル14

ベストアンサー率 47% (11786/24626)

HUBは滅多に不良品など無いと思うんですが、スイッチングHUBは内部構造もある程度複雑ですのであり得ないとは言えません。 またNICに関しては私の経験ではそれほど同一メーカーにこだわる必要はないと思います。 良心的な店でしたら新品交換をすぐしてくれますので 安定した正月が迎えられると良いですね。 ...続きを読む
HUBは滅多に不良品など無いと思うんですが、スイッチングHUBは内部構造もある程度複雑ですのであり得ないとは言えません。
またNICに関しては私の経験ではそれほど同一メーカーにこだわる必要はないと思います。
良心的な店でしたら新品交換をすぐしてくれますので
安定した正月が迎えられると良いですね。
補足コメント
noname#38849

EtherカードのIPアドレスですが
PC1をホストとして「インターネット接続の共有」を
していますのでPC1は「192.168.0.1」以外には
設定できないようですが問題ないのでしょうか?
(試してないですがWindowsのヘルプに書いてありました・・)
投稿日時 - 2000-12-26 15:33:34
17件中 1~10件目を表示
このQ&Aで解決しましたか?
関連するQ&A
-PR-
-PR-
このQ&Aにこう思った!同じようなことあった!感想や体験を書こう
このQ&Aにはまだコメントがありません。
あなたの思ったこと、知っていることをここにコメントしてみましょう。

その他の関連するQ&A、テーマをキーワードで探す

キーワードでQ&A、テーマを検索する
-PR-
-PR-
-PR-

特集


新大学生・新社会人のパソコンの悩みを解決!

いま みんなが気になるQ&A

関連するQ&A

-PR-

ピックアップ

-PR-
ページ先頭へ