• ベストアンサー
  • すぐに回答を!

FletsADSLを経由しての自作linuxルータは不調

前回、Linux機はFletsADSLを経由して、外のIPAddressは訪問できましたが、 でも、このマシンはルータとして、後のLANのマシンはまだ訪問できませんでした。 OS: RedHatLinux 7.01J Hardware: CPU celeron 333MHZ Memory:64MB NIC eth0:rtl8139 eth1:tulip インストール手順: 1>eth1にADSLModemと接続させて、eth0は別のマシンと接続している。 それで、netconfでeth1関連IPアドレスを抜いて、無効になった。 2>次、adsl-setupで、ISPから貰ったUID、eth1を選択して、ISPプライマリーDNS とセカンダリーDNSのIPアドレス、パスワード、firewallの選択(0に指定して) 等順序に設定した。 3>adsl-startで起動して、...connectedになった、成功そうです。 4>ifconfigで確認して、eth0,eth1,lo,ppp0に対しての情報が出てきた。 eth0 ......... MTU=1500 eth1 ......... MTU=1500 ppp0 ......... MTU=1454 成功そうです。 5>/etc/sysconfig/networkに,gatewaydevはeth1になる 6>このlinuxマシン自体でping www.goo.ne.jpは順調にできました。 7>eth0と接続しているほかのマシンで"ping www.goo.ne.jp"をやりますと、 最初には、正しいIPAddress順調に出来ましたが、すぐ、"Request timed out" になりました。 でも、"ping linux機のinetのIPAddress"は大丈夫でした。 今、困っています。 よろしくお願いいたします。

共感・応援の気持ちを伝えよう!

  • 回答数1
  • 閲覧数80
  • ありがとう数1

質問者が選んだベストアンサー

  • ベストアンサー
  • 回答No.1
noname#202350
noname#202350

IPマスカレードの設定が行われていないためだと思います。 firewallの指定が0の場合はipchainsもしくはiptablesのコマンドを使い、IPマスカレードの指定を行います。 また、firewallの指定を2にするとIPマスカレードの設定をしてくれるようです。 (こちらは試したことがないのでわかりません) なお、クライアントになる他のPCのゲートウェイの設定は正しく行っていますか?ゲートウェイの設定を行わないと正しくアクセスできません。

共感・感謝の気持ちを伝えよう!

質問者からのお礼

アドバイス 有難うございます。 やはり、IPマスカレード関係問題ですね。

関連するQ&A

  • FletsADSLを経由してのLinuxルータ???

    前回、Linux機はFletsADSLを経由して、外のIPAddressは訪問できましたが、 でも、このマシンはルータとして、後のLANのマシンはまだ訪問できませんでした。 OS: RedHatLinux 7.01J Hardware: CPU celeron 333MHZ Memory:64MB NIC eth0:rtl8139 eth1:tulip インストール手順: 1>eth1にADSLModemと接続させて、eth0は別のマシンと接続している。 それで、netconfでeth1関連IPアドレスを抜いて、無効になった。 2>次、adsl-setupで、ISPから貰ったUID、eth1を選択して、ISPプライマリーDNS とセカンダリーDNSのIPアドレス、パスワード、firewallの選択(0に指定して) 等順序に設定した。 3>adsl-startで起動して、...connectedになった、成功そうです。 4>ifconfigで確認して、eth0,eth1,lo,ppp0に対しての情報が出てきた。 eth0 ......... MTU=1500 eth1 ......... MTU=1500 ppp0 ......... MTU=1454 成功そうです。 5>/etc/sysconfig/networkに,gatewaydevはeth1になる 6>このlinuxマシン自体でping www.goo.ne.jpは順調にできました。 7>eth0と接続しているほかのマシンで"ping www.goo.ne.jp"をやりますと、 最初には、正しいIPAddress順調に出来ましたが、すぐ、"Request timed out" になりました。 でも、"ping linux機のinetのIPAddress"は大丈夫でした。 今、困っています。 よろしくお願いいたします。

  • Red HatLinux 7.01JでFletsADSLの接続問題

    今日、初めてRed HatLinux 7.01Jを使ってFletsADSLを接続したいけど、不調でした。 Hardware: CPU celeron 333MHZ Memory:64MB NIC eth0:rtl8139 eth1:tulip インストール手順: 1>eth1にADSLModemと接続させて、eth0は別のマシンと接続している。 それで、netconfでeth1関連IPアドレスを抜いて、無効になった。 2>次、adsl-setupで、ISPから貰ったUID、eth1を選択して、ISPプライマリーDNS とセカンダリーDNSのIPアドレス、パスワード、firewallの選択(0に指定して) 等順序に設定した。 3>adsl-startで起動して、...connectedになった、成功そうです。 4>ifconfigで確認して、eth0,eth1,lo,ppp0に対しての情報が出てきた。 eth0 ......... MTU=1500 eth1 ......... MTU=1500 ppp0 ......... MTU=1454 成功そうです。 5>しかし、pingを使うと、外のIPアドレスは全然検索できません。 今、困っています。 よろしくお願いいたします。

  • Red HatLinux 7.01Jを使ってFletsADSLを接続する問題

    今日、初めてRed HatLinux 7.01Jを使ってFletsADSLを接続したいけど、不調でした。 Hardware: CPU celeron 333MHZ Memory:64MB NIC eth0:rtl8139 eth1:tulip インストール手順: 1>eth1にADSLModemと接続させて、eth0は別のマシンと接続している。 それで、netconfでeth1関連IPアドレスを抜いて、無効になった。 2>次、adsl-setupで、ISPから貰ったUID、eth1を選択して、ISPプライマリーDNS とセカンダリーDNSのIPアドレス、パスワード、firewallの選択(0に指定して) 等順序に設定した。 3>adsl-startで起動して、...connectedになった、成功そうです。 4>ifconfigで確認して、eth0,eth1,lo,ppp0に対しての情報が出てきた。 eth0 ......... MTU=1500 eth1 ......... MTU=1500 ppp0 ......... MTU=1454 成功そうです。 5>しかし、pingを使うと、外のIPアドレスは全然検索できません。 今、困っています。 よろしくお願いいたします。

    • ベストアンサー
    • ADSL
  • NICの2枚挿し(ルーター用に)

    こんにちわ。 RedHat Linux9をADSLルーターにしようとしています。 (ADSLは、YahooBBのです) ですが、NIC一枚だけ(eth0)の時は、ちゃんとインターネットに接続でき外に向けたpingも通るのですが、二枚目(eth1)を認識させたとたんに、外へのpingすら通らなくなってしまいます。 eth0には、DHCPからIPアドレスなどを取得するように設定 eth1には、 IPAddress=192.168.1.1 SubnetMask=255.255.255.0 DefaultGateway:設定なし としています。 /etc/sysctl.comは、 net_ipv4.ip_forward=1 # iptables -t nat -A POSTROUTING -s 192.168.1.0 -o eth0 -j MASQUERADE も打ってみたのですが。。 以上、足りない設定や確認すべきところなど教えていただけませんでしょうか。 よろしくお願いします。

  • CATV回線にてVinelinux3.1をルータとして使いたい

    余っているPCにVinelinux3.1を入れ、それをルーター として使用したいと考えています。 eth0をCATV回線と接続し, eth1はDHCPを起動して HUBに接続しています。 Network構成は以下の通りです。 ------------  CATV Modem ------------    ↑↓eth0 -------------  (Vinelinux3.1)   ルータPC -------------    ↑↓ eth1 ------------    HUB ------------    ↑↓ ---------------------------  WindonsXP & VineLinux3.1 --------------------------- ルータPCの端末から"ifconfig"にてeth0,eth1ともに端末に表示されました しかし・・・・ ルータPCからWindowsXPに対するpingとLocalのLinuxからWindowsXPに対するpingが通りませんでした。 (それ以外のpingは通りました。) 質問その1・・・・ この状態は何が原因なのでしょうか?? 以下、関係しそうな設定ファイルです。 /etc/dhcpd.conf ------------------------------------------------ ddns-update-style none; subnet 192.168.0.0 netmask 255.255.255.0 {  range 192.168.0.100 192.168.0.200;  option routers 192.168.0.1;  option subnet-mask 255.255.255.0;  option broadcast-address 192.168.0.255; } ------------------------------------------------ /etc/sysconfig/network-script/ifcfg-eth1 ------------------------------------------------ DEVICE=eth1 IPADDRESS=192.168.0.1 NETMASK=255.255.255.0 NETWORK=192.168.0.0 BROADCAST=192.168.0.255 ONBOOT=yes ------------------------------------------------ ぜひぜひ皆様からのご指摘、よろしく宜しくお願いいたします!!!

  • RadHatLinux9 での ルーター兼サーバー構築

    RedHatLinux9 をインストールし、NICを2枚挿し、 eth0 (ヤフーなのでDHCP)を WAN(YahooBB)、 eth1 (固定 192.168.1.1)を LAN として設定し、DHCPの設定を行いました。 eth1にWindowsXPのマシンをつないだのですが、「ネットワークに接続されていません。」になってしまい、ping も通らず Media disconnected になってしまします。windowsのIPは自動取得にしています。 サーバー側では、ifconfig で確認すると eth1,eth0 ともちゃんと設定されているようです。 WAN側へは、pingは通ります。 NICが、原因なのかと思って、 別のNICで試したのですが、やぱりだめでした。 なにか基本的なことが抜けているのか、 まったく原因が解らないのですが、どうかよろしくお願いします。

  • PINGが通らない

    こんにちは! 教えて下さい。 LinuxでNICを2枚さして、 eth1は(192.168.0.1)ゲートウェイ用、 eth0は(ppp0での動的IP割り当て)インターネット用としています。 この環境でクライアントWin98(192.168.0.25)から外部にPINGを 打ちたいのですが通りません。 ゲートウエイ192:168:0:1は通り、 ppp0で割り当てられた動的IPアドレスにも通ります。 その先が行かないのです。 Linuxからは外部にPINGが通ります。 何が問題なのでしょうか? ppp0はBフレッツ(pppoe)の常時接続です。 やりたい事はクライアント(pppoe無し)からLinuxを経由 してプロバイダーのメールが取りたいのです。 (Linuxからはプロバイダーのメールは取れます)

  • デフォルトゲートウェイとDNS

    ブロードバンドルーターとサーバマシンがあります。 ブロードバンドルータ(192.168.1.1) | | |eth1(192.168.1.253) サーバ(linux or Windows)eth2(192.168.2.254)----192.168.2.0/24NW |eth0(192.168.3.254) | 192.168.1.0/24NW という構成の時、サーバインストール時にて各インターフェースにて以下設定をしております。 <eth0> IP:192.168.3.254/24 デフォルトゲートウェイ:192.168.1.1 DNS:192.168.1.1 <eth1> IP:192.168.1.253/24 デフォルトゲートウェイ:192.168.1.1 DNS:192.168.1.1 <eth2> IP:192.168.2.254/24 デフォルトゲートウェイ:192.168.1.1 DNS:192.168.1.1 ・質問1:eth0,1,2にデフォルトゲートウェイとDNSを設定する必要性 eth0,1,2のデフォルトゲートウェイアドレスとDNSアドレスを ブロードバンドルータに設定しているのですが 3つのインターフェースすべてに設定が必要な物なのでしょうか? ・質問2:eth0,2デフォルトゲートウェイの設定内容 eth0とeth2のデフォルトゲートウェイは、192.168.1.1のブロードバンドルータに設定していますが eth1の192.168.1.253に設定した方がいいのでしょうか? ご教授お願いします。

  • rp-pppoeとBフレッツベーシックを用いたマルチセッション接続について

    こんにちは。 ある一台のIAサーバー(Fedora core4)にイーサネットカードを4枚刺し、そのうち2枚(eth0とeth2)には、ONU直後にHUBで分岐したWAN側に接続され、残りの2枚(eth1とeth3)にはローカルネット側に接続されています。 NTT側 - ONU - HUB-+- eth0(ppp0) eth1-+ HUB-LAN側          +- eth2(ppp1) eth3-+ 今、eth0とeth2をpppoeでISP1とISP2に2セッション接続をしています(ISP1とISP2はフレッツスクエアではありません)。 ここで、 eth1に到達したアクセスはppp0へ、 eth3に到達したアクセスはppp1へ割り振るにはどのような設定をしたらよろしいでしょうか。 市販の”ブロードバンドルーター”2台を1台のサーバーにさせる感じなのですが、 サーチエンジンによる検索でマルチセッション接続について調べると、 メインで使用するISPと静的NATでフレッツスクエアに接続する解説が多く、なかなか資料がないようです。 よろしくお願いいたします。

  • linuxルーター構築について

    こんばんは。 今回やりたいのはunnumberd接続可能なルーターを作成したいです。 IPはプロバイダから8個もらってます。 現在、http://info.odic.ne.jp/security/pc_router.phpのサイトを参考に設定をしました。 設定状況 ・eth0をWAN側、eth1をLAN側 ・もらっているIPは111.222.333.100~107 ・iptablesはstopしております(ファイアーウォールは無効) [/etc/sysconfig/network-scripts/ifcfg-eth0] DEVICE=eth0 ONBOOT=no [/etc/sysconfig/network-scripts/ifcfg-eth1] DEVICE=eth1 IPADDR=111.222.333.101 NETMASK=255.255.255.248 NETWORK=111.222.333.100 BROADCAST=111.222.333.107 ONBOOT=yes BOOTPROTO=none プロバイダへの接続はできましたが、LAN側のPCにIP(111.222.333.105)を設定してもネットにつながりません。 その他設定するところはありますでしょうか? また、ほとんどのサイトを探してみましたが、もっと詳しく参考になるサイト等ご存知ないでしょうか? ほんとに困っているのでどなたかよろしくお願いします。