• ベストアンサー
  • 困ってます

SATAを2台目の接続に関して

シリアルATAを2台接続してます。 マザーボードにはSATAコネクタが4個あり SATA1:DISK_A(OSインストール) SATA2:空き SATA3:DISK_B(空) SATA4:空き と接続してます。 (IDEケーブルでDVDドライブ1個接続) しかし、起動のときに 「DISK BOOT FAILURE, INSERT SYSTEM DISK PRESS ENTER」 のメッセージがでたまま止まってしまいます。 そのままENTERキーを押すと普通にDISK_AからOSが起動します。 なぜ、このようなメッセージが出て止まってしまうのでしょうか? ちなみにBIOS画面で確認した所、以下のようになってます。 IDE CHANNEL 0 MASTER HL-DL-ST DVDRAM・・・・ IDE CHANNEL 0 SLAVE IDE CHANNEL 1 MASTER IDE CHANNEL 1 SLAVE IDE CHANNEL 2 MASTER DISK_A IDE CHANNEL 2 SLAVE IDE CHANNEL 3 MASTER IDE CHANNEL 3 SLAVE DISK_B SATA1にOSの入ったDISKで、それ以外に増設分のHDDを接続すると思ってたのですが、 SATA1~SATA4の接続するコネクタが間違ってるのでしょうか? 最初はSATA1:DISK_Aのみ接続して、OSインストールしまして その後、もう一台を増設したところです。 SATA1一台のみだと普通に起動します。 よろしくお願いします。

noname#164909

共感・応援の気持ちを伝えよう!

  • 回答数1
  • 閲覧数667
  • ありがとう数3

質問者が選んだベストアンサー

  • ベストアンサー
  • 回答No.1

全8台のHDDを使えるので、チップセット内のコントローラ以外にもRAIDコントローラの別チップを搭載しているのではないでしょうか。 このような場合はBoot Sequenceがよく混乱を起こします。 本来の最も優先順位の高い位置は、IDEのプライマリーマスターです。 現状ではそこにDVDドライブが繋がっていることが根本原因だと思います。 詳しく言うと、マザーボードの設計でSATAのポートを無理に増やした格好になっていますので、もしそのポートのドライブから起動させたい場合は、そのSATAのポートをIDEの上位に振り替えることが必要になってきます。 (本来の機能からすれば、DVDがプライマリー、HDDがセカンダリーでも問題はないはずですが。) それを例えば「AUTO」にしてあると、「DISK_B」の方が「DISK_A」より自動的に上位に位置してしまっている可能性があることです。 つまり、DISK_Aのみの場合だけ正常起動する理由は、実験としてDISK_BをDISK_Aのスレーブ側に繋ぐと正常起動するのなら、DISK_BがCHNNEL3につながったことで、そのCHANNEL3が起動の上位に自動的に位置してしまった可能性が高いです。 2台ともCHANNEL2にある場合はDISK_AがBOOTの上位になり、HDDがCHANELL2と3に分かれているとCHANNEL3が上位に来てしまっているものかと推測します。 マザーボードの違いというかBIOSの違いによって、これらを「AUTO」ではなくマニュアルで設定する必要がある(DISK_Aを含むポートをIDEのプライマリーに設定する)ものと、ただ起動HDDの型番(名称)を選択するだけでよいものとがあります。 このどちらかはお使いのマザーの説明書をご覧ください。 (BIOSに入れば多分すぐにわかりますが。) 要は、できるなら次のような設定をやってみてほしいのです。 1.DVDドライブをIDEのセカンダリーマスターに繋ぐ。(今はプライマリーマスターのはずですね。) 2.SATAのDISK_Aがつながっているポートを、IDEのプライマリーに設定する。 3.2ができないなら、転送速度は犠牲になるが、BをAのスレーブに繋ぐ。 2ができないことはないと思いますので、BIOSの設定でやってみてください。 「ENTER」を押すと次のドライブに進むというのは、BIOSによる違いだと思います。 記憶は確かではありませんが、2台のHDDのBoot Sequenceが下位の方にシステムがある場合、上位の方を自動的にパスするものと、質問者様のようにいったんそこで止まるものがあったような気がします。 あるいは、「ENTER」を押したことによって、Boot Sequenceの設定外のHDDを読みにいったのか、BIOSプログラムの構造を明記してあるメーカーなどありませんので、FAQなどから検索するかメーカーに直接問い合わせるしか知る術はないと思います。

共感・感謝の気持ちを伝えよう!

質問者からのお礼

勘違いしてました。 SATA3:DISK_Bを書きましたが、SATA4に接続されてました。 改めてSATA3に接続しなおして、BIOSでは下記のようになりました。 IDE CHANNEL 0 MASTER DISK_A(OS) IDE CHENNEL 0 SLAVE  DISK_B IDE CHENNEL 1 MASTER DVDDrive IDE CHENNEL 1 SLAVE  - これで正常に起動するようになりました。 SATA1とSATA4では駄目だったって事ですかね? それにしても同じ1と4でも上記とは逆で SATA1:DISK_B(OS) SATA4:DISK_A(空) の場合は、起動に問題なかったのですが。。。 いろいろ勉強になりました。有難うございました。

関連するQ&A

  • SATAでの複数ドライブ接続について

    GA-EG41MF-US2Hを使っています。 IDE Channel 0とIDE Channel 1にそれぞれMasterとSlaveがあります。 今はそれぞれのMasterに光学ドライブとハードディスクドライブをつないでますが、MasterとSlaveにつないだ場合、速度低下は起きるのでしょうか? また、SATAなのにIDE Channelと表示されるのはなぜでしょうか?

  • winXP(IDE)からSATA-HDDを使いたい

    [M/B] GA-G31M-S2L [chipset] INTEL G31+ICH7 [OS] Windows-XP(SP2) IDE Channel0 master [HDD] ST340015A -- windowsXP IDE Channel0 slave [DVD] パイオニア製DVD IDE Channel1 master [HDD] HDP725050GLA360 (SATA300) IDE Channel1 slave none この構成で電源を入れると、windowsの起動選択画面(win2000とwindowsXPのデュアルブートにしています)が表示されます。そしてwindowsXPを選ぶと一瞬xpの起動中画面が表示された後、リセットされてしまいます。この現象を回避する方法はあるのでしょうか? 希望としては SATA-HDD(HDP725050GLA360)をwindowsXPからデータディスクとして使用したいです。 ちなみに、IDE-HDD(ST340015A)を外して IDE Channel0 master none IDE Channel0 slave [DVD] パイオニア製DVD IDE Channel1 master [HDD] HDP725050GLA360 (SATA300) IDE Channel1 slave none の構成で、IDE-DVDからwindowsXPをSATA-HDDにインストールすると問題なくXPが立ち上がります。また、SATAのケーブルをSATAII0(上の場合はSATAII1接続)に接続して IDE Channel0 master [HDD] HDP725050GLA360 (SATA300) IDE Channel0 slave none IDE Channel1 master none IDE Channel1 slave [DVD] パイオニア製DVD の構成でwindowsXPは問題なく立ち上がります。

  • SATA-IDE変換Disk Slaveで開けない

    SATAからデータを取り出すため、SATAーIDE変換ケーブルでSlaveにして起動させたがメーカロゴのままフリーズして起動しません。SATA側を外すと、MasterのOS(XP)は起動します。Masterを外すとSlaveのOS(Vista)は起動します。単独では起動するのに、どこか設定要るのでしょうか?  今回Slaveには起動Diskを使用していますが、ログオンなし開いていたものが、突然雷でログインを要求。PWなんか設定してないので、そのままEnter、Administrator入れても駄目。こんなDiskからデータを救出したいのです。 たなぼた はある機能を除けば、あの重くて遅いVistaが通常マシーンでサクサク動いたことです!

  • 増設したSATAのHDDが認識されません…

    マザボ:Gigabyte GA-8IPE1000-L OS:XP SP1 です。 「SATA Port 0」に80G(システム) 「SATA Port 1」に250G(今回増設した物) 「Primary IDE Mastar」に160G(サーバ) 「Primary IDE Slave」にDVDドライヴ と接続してます。 「Secondary IDE」はMastar、Slave共に空けてます。 これで、BIOSのSerialATAの認識方法(動作モード?)を「Auto」すると、BIOSでは、 IDE Channel 0 MasterはPrimary IDE Mastar IDE Channel 0 SlaveはPrimary IDE Slave IDE Channel 1 MastarにSerial Port 0 IDE Channel 1 SlaveにSerial Port 1 となります。 ここまでは問題ないのですが、これでWindowsを立ち上げると、Windowsで認識されるのは、IDE Channnel 0 Mastar、つまりSerial Port 0に接続しているシステム用ドライヴのみです。 他ドライヴは「コンピュータの管理」の所にも表示されません。 そこで今度は、BIOSのSerialATAの認識方法(動作モード?)を「Manual」にし、Serial ATAをSerial ATAとして認識するようにします(?)。 するとBIOSでは、 IDE Channel 0 MasterはPrimary IDE Mastar IDE Channel 0 SlaveはPrimary IDE Slave IDE Channel 1 Mastar,Slaveは共に無し IDE Channel 2 MastarにSerial Port 0 IDE Channel 3 MasterにSerial Port 1 となります。 これですと、Windowsでも、 IDE Channel 0 MasterはPrimary IDE Mastar(サーバ) IDE Channel 0 SlaveはPrimary IDE Slave(DVD) IDE Channel 2 MastarにSerial Port 0(システム) は何とか認識してくれるのですが(今まではこれで使用してました)、肝心の増設した、 IDE Channel 3 MasterにSerial Port 1 が、認識されません。 「コンピュータの管理」の所にも表示されません。 PrimaryとSecondaryを入れ替えたり、色々やったのですが、どうにも解決しないので質問させて頂きました。 よろしくお願いします。

  • Cube型M/BのIDE接続について

    お世話になります。 先日購入したベアボーン、EZ965が本日届きました。 さっそく組み立てて 動かすと、光学ドライブが認識されません。 IDEコネクタが1つしかないので、2又にする延長ケーブルで、IDEコネクタの光学ドライブとHDDをそれぞれケーブルスイッチで接続しているのですが、BIOSの画面を見ると、 IDEchannel0 Master/Slave none IDEchannel1 Master/Slave none IDEchannel2 Master none IDEchannel3 Master <接続してるHDD> と表示されます。 まるでchannel3には1つしか接続できないように見えるのですが、ご存知の方はいないでしょうか?

  • BIOSでSATAが認識しない

    OSが壊れて起動できなくなってしまったので 新規にHDDを購入し、構成を変更しました。 <旧構成> OS:WindowsXP SP1 M/B :GIGABYTE 8IPE1000PRO2 IDE プライマリ マスタ    HDD(1)(BOOT)[OS壊] IDE プライマリ スレーブ   なし    IDE セカンダリ マスタ    DVDドライブ IDE セカンダリ スレーブ   なし SATA0            HDD(2) SATA1            HDD(3)  まずはHDDをすべて取り外し、新規に購入した HDDにOSをインストール。その後、下の構成にて HDD(1)を復旧しました。 <新構成> IDE プライマリ マスタ    HDD(新)(BOOT) IDE プライマリ スレーブ   HDD(1)[復旧] IDE セカンダリ マスタ    DVDドライブ IDE セカンダリ スレーブ   なし  SATA0             なし SATA1             なし その後、SATA0にHDD(2)を接続すると普通に認識してOSもきちんと起動するのですが、さらにSATA1にHDD(3)を接続するとBIOSで認識しなくなり、OS起動前にフリーズしてしまいます。 SATA0からHDD(2)をはずすと、逆にHDD(3)だけ認識して起動できます。 <現状> IDE プライマリ マスタ    HDD(新)(BOOT) IDE プライマリ スレーブ   HDD(1)[復旧] IDE セカンダリ マスタ    DVDドライブ IDE セカンダリ スレーブ   なし  SATA0   同時接続× どちらかのみ○ SATA1   同時接続× どちらかのみ○ 旧構成ではどちらのSATAも認識していたのですが IDEへの増設が原因でしょうか? ご教授くださいますようよろしくお願いします。

  • 新品SATA HDDが認識されません 故障?

    いつも皆様にはお世話になっております。 自作機2基で同じ現象が出ます。増設SATAハードディスクがデバイスマネージャ、BIOSで認識されているが、マイコンピューターのハードドライブに認識されず、ディスクの管理に表示されません。 OSはWin XPSP3です。MBはそれぞれGA-H55-USB3とGA-8I945Gです。増設HDDはHITACHI HDS721032CLA3621TBです。現在GA-H55に接続してあります。BIOS CMOS FeatureはIDE Channel 0 MasterおよびIDE Channel 0 Slaveそれぞれに既存のMaxtorのSATA HDD、IDE Channel 1 MasterにHitachiのSATA HDDを表示しています。またOnboard SATA/IDE Ctrl ModeはIDEのままです。 デバイスマネージャはこの3基を正しい名称で表示していますが、HITAHI HDDのみマイコンピューターに認識されず、この先へ進めません。この状況ではHDDの故障と判断するのが妥当でしょうか?

  • SATAとジャンパピン

    初心者の質問ですみません。 1■IDE/ATAPの接続ではMasterやSlaveをジャンパピンで設定すると思います。DVDドライブのコネクター変換アダプターでSATA接続にするのですが、この場合ジャンパピンの設定は関係ないのでしょうか? 2■そもそも変換アダプターを使ってもSATA接続できないHDDやドライブもあるのでしょうか? どんどんPCも進歩しておいていかれています。

  • sataの接続について

    IDEで接続していたhddをシリアルに変更したのですが。配線の仕方がいまいち分かりません。マザーボードのsata1とhddをつなぎhddと電源をシリアルでつないで起動させました。ideの時は3箇所つないだような気がするのですが・・・・・教えてください

  • IDEドライブの接続設定

    中古で買ったデスクトップパソコンです DVDマルチが乗っていますがやや不具合な感じがするので外したPCのDVDマルチ(IDE)と乗せ替えたいのです マザー(G31TーM)にIDEコネクタがついていますので 乗せ替えたい その場合のジャンパーピンの設定を どうすればいいのか教えてください 現在のBIOSは Primary IDE Master Hard Disk Primary IDE Slave ATAPI CDROM・・・・・外したいDVD  Secondary IDE Master Not Detected Secondary IDE Slave Not Detected Third IDE Master Not Detected Third IDE Slave Hard Disk(データ用 下ろしたPCの内臓HDD(増設)をつけたもの ジャンパーはSlaveのままだが認識している) DVDドライブを乗せ替えるには Third Hard IDE SlaveのHard DiskのジャンパーピンをSlaveからMasterに変更 DVDのジャンパーピンをSlaveとしこの2台を1本のIDEケーブルでつなぐ ・・・で認識するでしょうか ダメならもとに戻せばいいし