-PR-
締切り
済み

FloppyFWのトラブルシューティング

  • 困ってます
  • 質問No.80832
  • 閲覧数135
  • ありがとう数4
  • 気になる数0
  • 回答数2
  • コメント数0

お礼率 0% (0/4)

Linux初心者(タコ?)ですが、よろしくお願いします。
レガシーなシステムでルーターを作れるということでFloppyFWを挑戦してみたのですが、DHCPがうまく作動してない様なのですがSolutionをご教授お願いします。

僕が使ってるのは、
floppyfw-1.0.11-pppoe
Packageに dhcpcd.bz2 dhcpd.bz2 post-dhcpd.iniを入れてます。
PPPOEは繋がってるみたいなのですが、eth1につないだPCでは外(インターネット)に繋がりません。

よろしくお願いします。
通報する
  • 回答数2
  • 気になる
    質問をブックマークします。
    マイページでまとめて確認できます。

回答 (全2件)

  • 回答No.1
レベル11

ベストアンサー率 36% (86/235)

ネットワークインターフェースは、うまく認識されているのでしょうか? 私も、最初につながらなかった経験があります。 ifconfig -aで、インターフェースの状況を確認してください。 うまくeth0とeth1が、認識されているようなら、(eth0)が、きちんとIPアドレスを取得できているかどうか。 多分、eth0が、DHCPサーバーからIPアドレス等を取得できていないのでは? 参考URLから、最 ...続きを読む
ネットワークインターフェースは、うまく認識されているのでしょうか?
私も、最初につながらなかった経験があります。
ifconfig -aで、インターフェースの状況を確認してください。
うまくeth0とeth1が、認識されているようなら、(eth0)が、きちんとIPアドレスを取得できているかどうか。
多分、eth0が、DHCPサーバーからIPアドレス等を取得できていないのでは?
参考URLから、最新のモジュールを使用してみてください。
特にDHCPです。
post-dhcp.iniや、configファイルの設定は、大丈夫ですよね。
補足コメント
aodaisho

お礼率 0% (0/4)

Resありがとうございます。
えっと、ifconfigで見るとeth0,eth1両方認識されているみたいです。
PPPOEでの接続も.....connected!!と出るので
eth0は外と繋がってると思われるのですが。
タコの僕にはよくわかりません、ただブートしてるときにNICのIRQが両方とも11になってるのが関係ありますか??
競合ということであれば、それを変える方法を教えてほしいです。
投稿日時 - 2001-05-29 06:38:39


  • 回答No.2
レベル11

ベストアンサー率 36% (86/235)

ifconfigのコマンドを実行したときに、 test-srv# ifconfig -a lo0: flags=849<UP,LOOPBACK,RUNNING,MULTICAST> mtu 8232 inet 127.0.0.1 netmask ff000000 le0: flags=863<UP,BROADCAST,NOTRAILERS,RUNNING,MULT ...続きを読む
ifconfigのコマンドを実行したときに、
test-srv# ifconfig -a
lo0: flags=849<UP,LOOPBACK,RUNNING,MULTICAST> mtu 8232
inet 127.0.0.1 netmask ff000000
le0: flags=863<UP,BROADCAST,NOTRAILERS,RUNNING,MULTICAST> mtu 1500
inet 192.168.10.2 netmask ffffff00 broadcast 192.168.10.255
ether 8:0:20:78:1c:5f
というような感じになっていればいいです。
上記の部分のUPがあれば、大丈夫だと思います。IRQ等が、コンフリクトしている場合は、UPしません。
IRQが、同じ値になっていても、最近のPCIは、IRQをシェアーするようなので、気にしなくてもいい場合があります。
ところで、ネットワークカードは、何を使用しているのでしょうか?
ISAカードがある場合には、当然IRQが、同じではまずいです。
まずは、floppyfwのマシンが、きちんと立ち上がっているかどうかを確認するべきです。ifconfigで、きちんとIPアドレスを取得しているようなら、netstat -rで、ルーティングができているかを確認し、pingで、どこかのサイト(たとえば、プロバーだーのSMTPサーバー)にpingを飛ばしてみてはいかがでしょうか。
まあ、IPアドレスをきちんと取得しているなら、大丈夫だと思います。
あとは、floppyfwからのDHCPから、eth1につないだ、PCが、IPアドレスをうまく取得しているかが問題となります。
うまく、プロバイダーから、floppyfwが、IPアドレスを取得していない場合は、DHCP関連のモジュールを新しいものを取得しなおしてください。
このQ&Aで解決しましたか?
関連するQ&A
-PR-
-PR-
このQ&Aにこう思った!同じようなことあった!感想や体験を書こう
このQ&Aにはまだコメントがありません。
あなたの思ったこと、知っていることをここにコメントしてみましょう。

その他の関連するQ&A、テーマをキーワードで探す

キーワードでQ&A、テーマを検索する
-PR-
-PR-
-PR-

特集


関連するQ&A

-PR-

ピックアップ

-PR-
ページ先頭へ