OKWAVEのAI「あい」が美容・健康の悩みに最適な回答をご提案!
-PR-
解決
済み

J2EEとTomcat4.0について

  • 困ってます
  • 質問No.245656
  • 閲覧数73
  • ありがとう数0
  • 気になる数0
  • 回答数1
  • コメント数0

お礼率 66% (294/439)

現在Tomcat3.2.1とJ2SEでJAVAのプログラムを作成していますが
今度J2EEとTomcat4.0で起動させようとかんがえています。
今時点のTomcatとJ2SEを削除し新たにJ2EEとTomcat4.0をインストール
をし、設定するだけで大丈夫なのでしょうか?この他なにか設定する必要がある
のでしょうか?ちなみにJ2SEからJSEEに変えると今までのプログラムは使えなく
なるということがあるのでしょうか?質疑が多くご迷惑おかけしますが助言お願いします。
通報する
  • 回答数1
  • 気になる
    質問をブックマークします。
    マイページでまとめて確認できます。

質問者が選んだベストアンサー

  • 回答No.1
レベル7

ベストアンサー率 58% (7/12)

J2SEは消すことはできません。
J2EEは追加パッケージのようなものですのでJ2SEがないと動きません。
例えばjavaコマンドやjavacコマンドはSEに含まれているため、おそらくtomcatの起動すらできないと思います。
また、java.lang,java.ioなどのパッケージはSEに含まれているため、消してしまうとStringですら使えない状況になってしまいます。
厳密に言うと全てのクラスが暗黙的に継承しているjava.Objectも含まれています。
ですのでSEは絶対に消すことはできないと考えてください。
-PR-
-PR-
このQ&Aで解決しましたか?
関連するQ&A
-PR-
-PR-
こんな書き方もあるよ!この情報は知ってる?あなたの知識を教えて!
このQ&Aにはまだコメントがありません。
あなたの思ったこと、知っていることをここにコメントしてみましょう。

その他の関連するQ&A、テーマをキーワードで探す

キーワードでQ&A、テーマを検索する
-PR-
-PR-
-PR-

特集


いま みんなが気になるQ&A

関連するQ&A

-PR-

ピックアップ

-PR-
ページ先頭へ