OKWAVEのAI「あい」が美容・健康の悩みに最適な回答をご提案!
-PR-
解決
済み

RedhatLinux7.1J-apacheのアップグレード失敗します

  • すぐに回答を!
  • 質問No.186637
  • 閲覧数43
  • ありがとう数1
  • 気になる数0
  • 回答数1
  • コメント数0

RedhatLinux7.1Jを使用しています。

http://www.jp.redhat.com/support/errata/RHSA/RHSA-2001-126J.html

以上のサイトから、7.1用のApache最新版を入手し、
インストールしようとした所、以下のエラーが表示されて
インストールに失敗してしまいます。


apache本体を導入しようとすると、「mod_~.rpm」がないって怒られて、
「mod_~.rpm」を導入しようとすると、apacheと競合すると怒られ、
結局アップグレードできないんです・・・。


<その1>
 rpm -Fvh apache-1.3.22-1.7.1.i386.rpm
  ↓
 エラー: 依存性の欠如:
  mod_bandwidthは apache-1.3.22-1.7.1 に必要とされています
  mod_putは apache-1.3.22-1.7.1 に必要とされています
  mod_throttleは apache-1.3.22-1.7.1 に必要とされています

<その2>
 rpm -ivh mod_bandwidth-2.0.3-2.i386.rpm
 rpm -ivh mod_put-1.3-2.i386.rpm
 rpm -ivh mod_throttle-3.1.2-3.i386.rpm
  ↓
 エラー: 依存性の欠如:
  apache < 1.3.22-1 mod_bandwidth-2.0.3-2 と競合します
通報する
  • 回答数1
  • 気になる
    質問をブックマークします。
    マイページでまとめて確認できます。

質問者が選んだベストアンサー

  • 回答No.1
レベル9

ベストアンサー率 53% (41/76)

全部まとめて指定してください。
こんな感じです。

rpm -Uvh mod* apache*
お礼コメント
noname#2802

まとめて実行するとは、考えもしませんでした。
ありがとうございました!
投稿日時 - 2001-12-18 11:09:01
-PR-
-PR-
このQ&Aで解決しましたか?
関連するQ&A
-PR-
-PR-
このQ&Aにこう思った!同じようなことあった!感想や体験を書こう
このQ&Aにはまだコメントがありません。
あなたの思ったこと、知っていることをここにコメントしてみましょう。

その他の関連するQ&A、テーマをキーワードで探す

キーワードでQ&A、テーマを検索する
-PR-
-PR-
-PR-

特集


いま みんなが気になるQ&A

関連するQ&A

-PR-

ピックアップ

-PR-
ページ先頭へ