OKWAVEのAI「あい」が美容・健康の悩みに最適な回答をご提案!
-PR-
解決
済み

MIDIだけ音が出ません

  • 困ってます
  • 質問No.184066
  • 閲覧数47
  • ありがとう数3
  • 気になる数0
  • 回答数2
  • コメント数0

お礼率 85% (24/28)

OSはWINDOWS98
MediaPlayerは6.4
つい先日OSの再インストールをしたばかりです。
その時は何事もなかったのですが。。元の環境に戻すためにいろいろとソフトをインストールしたところ音が出なくなりました。それで、MediaPlayerを再びDLしてインストールしてみましたが状況は変わりません。
実は以前にも同じようになった時にYamahaのXG20を音源ごとDLしたら聞けるようになりました。
どれかソフトが原因かと思いますが・・。ここで同じような質問(音が出ません)に対する回答を読み一応試してみましたが改善されません。
インストールしたソフトはたくさんありますが。。心当たりがあるのはYahooメッセンジャーです。。(確信はありません)・・でメッセンジャーを一旦アンインストールして見ましたが、だめでした。音源がなくなったのでしょうか?
・・同じような質問で申し訳ありません。。
まさかとは思いますが・・ウイルスの関係とかもありますか・・?
通報する
  • 回答数2
  • 気になる
    質問をブックマークします。
    マイページでまとめて確認できます。

質問者が選んだベストアンサー

  • 回答No.2
レベル14

ベストアンサー率 62% (6253/9971)

ESS製のサウンドチップが統合されているようですね。
それなら、ESFM Synthesis(9080) を有効にしてみてください。

これで、発音するはずです。MPUはMIDI/ジョイスティックインターフェースに出力されますので、スピーカーから音が出なくなります。

その上で音が出ない場合は、スタート→「ファイル名を指定して実行」で
dxdiag
と入力して実行します。
DirectMusicを選択して、MusicのテストでMicrosoft synthとMPU-401以外のシンセを試してください。
これで発音するなら問題はないですね。

もしここで異常が(マ社でドライバテストがされていないという警告は除く)でれば、サウンドチップに致命的なエラーがあったり、ドライバが破損している可能性があります。

いかがでしょう。もし何かあれば補足を
お礼コメント
punyu

お礼率 85% (24/28)

ありがとうございました。音が出るようになりました。
投稿日時 - 2001-12-14 21:54:00
-PR-
-PR-

その他の回答 (全1件)

  • 回答No.1
レベル7

ベストアンサー率 40% (10/25)

ボリュームなどの基本的なことは確認されたものとして まずは、コントロールパネルの中のマルチメディアを見ていただいて MIDIに割り当てられている音源が意図しているものかどうかを確かめてください それでも改善されない場合、MIDIファイル側の問題も考えられます というのはMIDIには現在大きく4規格「GM」「GM2」「GS」「XG」がありますが それぞれ所有する音の種類や数が異なっています ...続きを読む
ボリュームなどの基本的なことは確認されたものとして
まずは、コントロールパネルの中のマルチメディアを見ていただいて
MIDIに割り当てられている音源が意図しているものかどうかを確かめてください
それでも改善されない場合、MIDIファイル側の問題も考えられます

というのはMIDIには現在大きく4規格「GM」「GM2」「GS」「XG」がありますが
それぞれ所有する音の種類や数が異なっています
通常の楽器(打楽器以外)だとGMは128音色持っているのですが
例えばGSのヒット音源ハチプロ(俗称)の場合だと1117音色鳴らすことができます
それはピアノ一つとっても
ピアノ、ヨーロピアンピアノなど様々あり、そのヨーロピアンピアノの音を
GMで再生しようとしても再生してくれないことがあります
そこで、これが原因かを調べる方法として、GMフォーマットされたMIDIファイルをDLしていただいてそれを再生してもらう必要があります
GMフォーマットのMIDIは探してもらえれば星の数ほどありますので
「GM+MIDIファイル」で探してみてください

音源が正しく設定されていて、GMファイルでも音が出ないとなると
ソフトウェアが正常に動作していない可能性が出てきます
(文面よりYAMAHAのソフト音源を使用していると判断させてもらいました)
その場合は音源をいったん入れなおしてもらう必要があると思います
一度試してみて、改善されないようであればまた、このスレッドで返信してください
補足コメント
punyu

お礼率 85% (24/28)

早速のご回答ありがとうございます。
説明が悪かったようです、ごめんなさい。今はMedia Player6.4を再インストールしてあります。Yamahaにしたら・・音色が違っていてあまり好きじゃなかったのと・・体験版だったので、今は入れていません。できればメディアプレーヤーをもう一度使いたいのですが。。
マルチメディアのプロパティでは、MIDIタブの単一機器のところには
ESFM Synthesis(9080)
ESS MPU-401(9400)というのがあります。
どちらに設定していいのかわかりません。
で・・つい・・2-3日前までは音が流れていたので・・ファイルの関係とも思われないのですが。。
投稿日時 - 2001-12-12 20:32:04
お礼コメント
punyu

お礼率 85% (24/28)

ありがとうございました。音がでるようになりました。また何かありましたらよろしくお願いします。
投稿日時 - 2001-12-14 22:02:24


このQ&Aで解決しましたか?
関連するQ&A
-PR-
-PR-
このQ&Aにこう思った!同じようなことあった!感想や体験を書こう
このQ&Aにはまだコメントがありません。
あなたの思ったこと、知っていることをここにコメントしてみましょう。

その他の関連するQ&A、テーマをキーワードで探す

キーワードでQ&A、テーマを検索する
-PR-
-PR-
-PR-

特集


いま みんなが気になるQ&A

関連するQ&A

-PR-

ピックアップ

-PR-
ページ先頭へ