OKWAVEのAI「あい」が美容・健康の悩みに最適な回答をご提案!
-PR-
解決
済み

ハブを通してネットをする方法-2

  • すぐに回答を!
  • 質問No.164382
  • 閲覧数150
  • ありがとう数17
  • 気になる数0
  • 回答数11
  • コメント数0

お礼率 95% (139/146)

先日同じ質問をしたのですが、やはりハブを通してインターネットを見ることができず、もう一度同じ質問をさせて頂きます。
前回答えていただいた内容を実行した結果も含め質問します。

1台目のPCは前からケーブルでインターネットができていて、
新しく購入した2台目のPCもハブで繋いで同じような環境にしようと思っています。
IPアドレスは先日取得しまして、2台目のPCに設定も済みました。
ケーブル会社にIPアドレスが取得できている事も確認しました。

1台目のPCは今までどおりケーブルモデムから直接LANで繋ぐとインターネットが見れるのですが、ハブを通すと見ることができません。
2台目は、遠いためケーブルモデムから直接繋いで試すことができません。
ハブを通すと両方ともネットを見ることができません。

ハブはuplink付で、
ケーブルはストレートケーブルです。

最初にプロキシの設定を探す(?)みたいなメッセージがでます。
エクスプローラーのプロパティでLANの設定を見てみたのですが、
特に接続できてる時との変化はありませんでした。
ハブには5つポートがあるのですが、全て試してみましたが出来ませんでした。
ハブの切り替えスイッチも両方とも試しましたが、うまくいきませんでした。

何か解決法はあるでしょうか?教えて下さい。
通報する
  • 回答数11
  • 気になる
    質問をブックマークします。
    マイページでまとめて確認できます。

質問者が選んだベストアンサー

  • 回答No.11
レベル12

ベストアンサー率 45% (210/459)

こんにちは。itohhといいます。

HUBにPCを2台だけ接続するとランプは正常なのですね?
そうなると、PCの設定と、HUBは正常なようですねぇ。

また、試して欲しいのですが。

あとは、疑える箇所はHUBとモデム間しかないわけですが、
今、3本のLANケーブル(ストレート)が有るわけですよね、このLANケーブルを
交換して接続してみてください。

A.モデムとHUB間で使用していたLANケーブル
B.HUBと1台目PCで使用していたLANケーブル
C.HUBと2台目PCで使用していたLANケーブル

AとBのLANケーブルを交換してみてください。(1台目のPCはHUBに接続しない)
そして、2台目のPCからインターネットしてみてください。

どうでしょうか?これでもダメでしょうか!
これで、ダメというとなるとHUBを交換しかないような気がします。

補足をお待ちしています。
お礼コメント
whoops101

お礼率 95% (139/146)

ありがとうございます!!!!!!!!!!!!!!!

ケーブルを交換して接続し、電源落としたりつけたりしたら繋がりました!!
今までハブからPC(1)に繋がっていたのを、
モデムからハブ用にして、
モデムからハブ用のを
ハブからPC(1)に繋げたら繋がりました!

でも不安定で、ハブをちょっと動かしたら、
またコリジョン発生!となり繋がらなくなってしまいました。
なので、もう1回、電源を落としたりつけたり、
ケーブルを挿したり抜いたりしてたら、繋がるようになりました。

とにかく繋がったので、万歳で!
本当にいろいろ有難うございました。
投稿日時 - 2001-11-12 00:22:21
-PR-
-PR-

その他の回答 (全10件)

  • 回答No.4
レベル12

ベストアンサー率 45% (210/459)

こんにちは。itohhといいます。 接続方法は他の方が回答しているとおりだと思います。 その他で気になったところなんですが。 >私もLAN接続でIPアドレスは自動取得になっています。 固定のIPアドレスをケーブルTV会社から取得しているのですよね? その場合、自動取得ではなく、固定IPアドレスを設定しなくては行けないのではないでしょうか? どこのケーブルTVだかは、判らないのではっ ...続きを読む
こんにちは。itohhといいます。

接続方法は他の方が回答しているとおりだと思います。

その他で気になったところなんですが。
>私もLAN接続でIPアドレスは自動取得になっています。
固定のIPアドレスをケーブルTV会社から取得しているのですよね?
その場合、自動取得ではなく、固定IPアドレスを設定しなくては行けないのではないでしょうか?

どこのケーブルTVだかは、判らないのではっきりとは言えませんが契約しているケーブルTVのサイトに
設定方法は記載されていませんでしょうか?もう一度、確認してみては如何ですか?

あと、HUBの前面(側面かもしれませんが。)にポートの状態を表示するランプが点灯するように
なっていると思うのですか確認されましたか?
お礼コメント
whoops101

お礼率 95% (139/146)

回答ありがとうございます。私の契約しているケーブルテレビ会社はJ-COMです。実際にはIPアドレスを取得というより、コンピューター名を取得します。それをPCに設定するとIPアドレスも勝手についてくるみたいな・・・(もぅめちゃめちゃでスミマセン)。
J-COMでは細かい設定の方法が説明されていなく(またサポートも行われていません)、ネットで説明されていることはその通りやったのですが・・・(*_*;)
ポートは差し込んである所は全てハブの説明書通り点灯していて、"col"という所がオレンジ色に点滅して一見アクセスしているように見えます。(実際はなにも見えません)
いや~うまく説明できなくてすみません。
投稿日時 - 2001-11-08 03:13:15

  • 回答No.3
レベル8

ベストアンサー率 33% (18/53)

>ケーブル会社にIPアドレスが取得 ということはFLETS等ではなく、固定IP-Addressで常時接続の形態ということですね。 であれば、皆さん書いてあるように。  モデム === Hubのuplink へストレートケーブル  Hub === PC ストレートケーブル で、いいはずですが。  確認ですが、uplinkポートはスイッチ切替式ならuplink側に切り替えて置いてください。 ...続きを読む
>ケーブル会社にIPアドレスが取得
ということはFLETS等ではなく、固定IP-Addressで常時接続の形態ということですね。
であれば、皆さん書いてあるように。
 モデム === Hubのuplink へストレートケーブル
 Hub === PC ストレートケーブル
で、いいはずですが。
 確認ですが、uplinkポートはスイッチ切替式ならuplink側に切り替えて置いてください。
 
PC等のHUBへの接続が終わったら、1台目のPCから2台目のPCへpingを行って接続の確認をして下さい。
 次に、ケーブル会社側のDNSサーバ・POP3サーバなどのIP-Addressが解っている出来るだけ近い外のPCに対して、IP-Addressを使ってpingを行い接続の確認を行って下さい。
 ここまででまずはどうでしょうか。 
お礼コメント
whoops101

お礼率 95% (139/146)

回答どうも有り難うございます。uplinkポートの切り替えスイッチは切り替えてあります。そのあとのpingというのがスミマセン、わからないのですが、1台目のPCと2台目のPCが繋がっているか確認すればいいのですね。今の所、1台目のPCと2台目のPCはネットワークは繋がっていません。で、その後のpingというのがまったくわからないのですが、よく調べて試してみます。色々と有難うございました。
投稿日時 - 2001-11-07 22:48:58
  • 回答No.2
レベル13

ベストアンサー率 28% (156/546)

全てストレートケーブルならば、ケーブルモデムとの接続をUplinkポートに、 PCはその他のポートに接続すれば通信できるはずだと思います。 HubのLink LEDは点灯しているでしょうか? ...続きを読む
全てストレートケーブルならば、ケーブルモデムとの接続をUplinkポートに、
PCはその他のポートに接続すれば通信できるはずだと思います。

HubのLink LEDは点灯しているでしょうか?
お礼コメント
whoops101

お礼率 95% (139/146)

ありがとうございます。ハブのLinkLEDは繋いだポートの所は全て点灯しています。"col"というところもオレンジ色に点灯してアクセスしてるかのように見えます。が、なぜか見れません(T-T)
投稿日時 - 2001-11-07 22:36:00
  • 回答No.1
レベル11

ベストアンサー率 17% (57/319)

ケーブルについては知らないんですが ISDNで接続の場合なので 違っていたら御免なさい 私の場合はルーターを使っているのですがプロバイダーから貰ったIPアドレスは ルーターの所で設定します PCのではLANを使って接続するにしています PCのIPアドレスは自動取得になっています ...続きを読む
ケーブルについては知らないんですが
ISDNで接続の場合なので
違っていたら御免なさい
私の場合はルーターを使っているのですがプロバイダーから貰ったIPアドレスは
ルーターの所で設定します
PCのではLANを使って接続するにしています
PCのIPアドレスは自動取得になっています
お礼コメント
whoops101

お礼率 95% (139/146)

早速のお返事ありがとうございます。私もLAN接続でIPアドレスは自動取得になっています。で、ド素人なので(^.^;ちょっとルーターの所での設定というのがわからないのですが、それがハブのようなものであるのでしたら、私の使用しているハブにそのような設定できるようなものがあるかどうか調べてみます。というか、あるのでしょうか?(?_?;)? 深夜に有難うございました。
投稿日時 - 2001-11-07 03:14:18
  • 回答No.5
レベル12

ベストアンサー率 45% (210/459)

こんにちは。itohhといいます。 J-COMのサイトを見てきました、DHCPで動的にIPアドレスを取得することになっているんですね。 PCのネットワークの設定はDHCPで動的に設定するようにしていると思っていいのでしょうか? >"col"という所がオレンジ色に点滅して一見アクセスしている >ように見えます。(実際はなにも見えません) 頻繁に点滅するのでしょうか?そ ...続きを読む
こんにちは。itohhといいます。

J-COMのサイトを見てきました、DHCPで動的にIPアドレスを取得することになっているんですね。
PCのネットワークの設定はDHCPで動的に設定するようにしていると思っていいのでしょうか?

>"col"という所がオレンジ色に点滅して一見アクセスしている
>ように見えます。(実際はなにも見えません)
頻繁に点滅するのでしょうか?そうだとしたら、コリジョンが起きていると言うことですよね。
一般的にcolは、点灯してはいけないような...
3本のLANケーブルをHUBに接続しているのでしたら、3カ所のlinkランプは点灯していないの
でしょうか?
linkランプが点灯していないところがLANケーブルを認識していない場所です。

参考までにランプの意味を説明しているページを載せておきます。
(HUBの名前がわからないので。)
NetGear EN2005/2008 Ethernet Hubs
http://www.netgearinc.co.jp/support/files/en2005_8_trouble.html
お礼コメント
whoops101

お礼率 95% (139/146)

たびたびありがとうございます。
ハブはアイ・オーデータのET-HB5です。

点灯の仕方は教えて頂いたURLを参考にしますと、
私の状態は"黄の COL LEDが頻繁に、または長い間点滅する。"です。
ってことは、何かがいけないってことですね。
で、説明サイトでは私の状況の解決策としては
「接続している機器が半二重モードで動作しているか確認してください。ハブは、全二重モードで動作する機器とは互換性がありません」
とあるのですが、この意味がいまいちわかりません。
私のハブは、すべてストレートケーブルで接続されていているので
半二重モード・・??、
だけど、1つuplinkだからそこのポートだけストレートケーブルでも全二重モード???
だから、uplinkでない所にクロスケーブルをさしてケーブルモデムと繋げばいいのですか?????え・・・????
言葉の意味、違えてますか??
もう自分でもなにがなんだか全然わからなくて・・!

で、他に試したことなんですが、ハブを通すと1台ずつでもインターネットは見れず(colがずっと点滅して、プロキシの設定を検出し始めます)、
ケーブルモデムから直接ケーブルを差し込む方法だと2台とも別々ですがインターネットを見ることができます。なのでPCは生きてます。

く~~っ、コリジョン状態を抜け出すにはどうすれば?!
単語単語を調べながらやってるので、もうヘロヘロで(笑。
言葉が乱れていたらすみません。
投稿日時 - 2001-11-08 23:53:33
  • 回答No.6
レベル13

ベストアンサー率 28% (156/546)

再びお邪魔します。 LinkのLEDが点灯しているということは、ほぼ間違いなく通信モードの食い違いが原因かと思います。 通信モードとは、ケーブルには関係なく、お互いの半二重/全二重(Half/Full Duplex)、10Mbps/100Mbps のことで、通信機器同士の相性とでもいいましょうか。 推測するに、ケーブルモデムとPCは相性がいいのですが、Hubとの相性がよくないようです。 ...続きを読む
再びお邪魔します。

LinkのLEDが点灯しているということは、ほぼ間違いなく通信モードの食い違いが原因かと思います。

通信モードとは、ケーブルには関係なく、お互いの半二重/全二重(Half/Full Duplex)、10Mbps/100Mbps
のことで、通信機器同士の相性とでもいいましょうか。

推測するに、ケーブルモデムとPCは相性がいいのですが、Hubとの相性がよくないようです。

Hubの説明に、
>「接続している機器が半二重モードで動作しているか確認してください。ハブは、全二重モードで動作
>する機器とは互換性がありません」
とあるわけですから、PCが半二重でなければ相性が悪く通信できない可能性があります。
「Auto Negotiation」と言うお互いに相性を確認する方法もありますが・・・

まずは、whoops101さんのPCの通信モードを確認できないでしょうか?
確認方法は、「コントロールパネル」の「ネットワーク」でご使用のアダプタの「プロパティ」を見れば
多分確認できるはずです。
お礼コメント
whoops101

お礼率 95% (139/146)

たびたび本当に有難うございますっ。

通信モードのわかりやすい説明も有難うございます。
相性は相当悪いようです(笑。
1台目のPCの通信モードは、HalfDuplexだったので、
上のitohhさんの指示に従いFullDuplexに変えて再起動してみました。
が、colの点滅はおさまらず、IEを起動するとプロキシの設定を検出・・
になってしまいます。
2台目の通信モードは、igmpさんの言われる「Auto Negotiation」というものでした。
一応10~Full~(~はスイマセン憶えていません)に変更してみましたが、
1台目の状況とかわりませんでした。

確認する点は、このことでよかったでしょうか?
他にも確認する点があったら教えて下さい。<(_ _)>
投稿日時 - 2001-11-09 03:13:35
  • 回答No.9
レベル12

ベストアンサー率 45% (210/459)

こんにちは。itohhといいます。 そうですか、まだダメですか(^_^; ちょっと、試してみてくれますか? HUBにモデムからのLANケーブルを外してPC2台のLANケーブルだけにしてみてください。 このときの状態はどうでしょうか? これで正常になるようでしたらモデムとHUBを接続していたLANケーブルがおかしいのかもしれませんね。 ...続きを読む
こんにちは。itohhといいます。

そうですか、まだダメですか(^_^;

ちょっと、試してみてくれますか?
HUBにモデムからのLANケーブルを外してPC2台のLANケーブルだけにしてみてください。
このときの状態はどうでしょうか?

これで正常になるようでしたらモデムとHUBを接続していたLANケーブルがおかしいのかもしれませんね。
お礼コメント
whoops101

お礼率 95% (139/146)

何度も本当にどうも有り難うございます。

ケーブルモデムからのケーブルを抜いて2台のPCのケーブルだけが
ハブに繋がってる状態にしてみました。
LEDは、正常です。
1つフォルダを共有にして片方のPCから覗こうとしましたが、
まったく見えませんでした。
投稿日時 - 2001-11-11 01:59:51
  • 回答No.8
レベル8

ベストアンサー率 33% (18/53)

うむむむ・・・。ふたたびurkです。 今までのお話から見ると、後残るは2つ、 1.モデムとHUBの相性がわるい。  結構あります。HUBをカスケードで接続したときなどたまにあります。メーカーに問い合わせると、接続先の部品が他社の場合、よく相性のせいにされます。そんなときも10Mに落とすと問題ないのですが。 2.HUBが故障?  HUBのuplink ポートが壊れているとか。  どこかで余っ ...続きを読む
うむむむ・・・。ふたたびurkです。
今までのお話から見ると、後残るは2つ、
1.モデムとHUBの相性がわるい。
 結構あります。HUBをカスケードで接続したときなどたまにあります。メーカーに問い合わせると、接続先の部品が他社の場合、よく相性のせいにされます。そんなときも10Mに落とすと問題ないのですが。
2.HUBが故障?
 HUBのuplink ポートが壊れているとか。

 どこかで余っているHUB(会社でシステム担当者に頼むと大概何台かあります)を借りてやってみるとかは、いかがですか。
お礼コメント
whoops101

お礼率 95% (139/146)

本当に何度も有難うございます。
ハブを貸してもらえる所があれば、
一刻も早く(笑)他のハブを試してみようと思います。
投稿日時 - 2001-11-11 01:00:32
  • 回答No.7
レベル12

ベストアンサー率 45% (210/459)

こんにちは。itohhといいます。 半二重/全二重とは、 > 1つの通信チャネルを使用して、送信と受信を切り替えながら通信を行なう通信方式。 >同時に送受信を行なえる全二重通信とは異なり、半二重通信では、ある瞬間には送信ま >たは受信のいずれかのみを行なうことができる。 (アスキーデジタル用語辞典より) igmpさんと回答がかぶってしまうところがあるのですが。 >ハブはアイ・オーデー ...続きを読む
こんにちは。itohhといいます。

半二重/全二重とは、
> 1つの通信チャネルを使用して、送信と受信を切り替えながら通信を行なう通信方式。
>同時に送受信を行なえる全二重通信とは異なり、半二重通信では、ある瞬間には送信ま
>たは受信のいずれかのみを行なうことができる。
(アスキーデジタル用語辞典より)

igmpさんと回答がかぶってしまうところがあるのですが。
>ハブはアイ・オーデータのET-HB5です。
サイトで確認したのですが、このHUBは、10BASE-TのHUBですね。

お使いのPCのLANカードはたぶん10BASE-T/100BASE-TX自動判定機能が付いていると
勝手に解釈して説明します。

たぶん、自動判定機能が正しく認識してくれていないのだと思います。
igmpさんが回答されているとおり、LANカードのプロパティを確認してください。
そして、「Auto Detect」を「10BASE-T Full Duplex」にしてください。
いったん、PCを再起動して見てください。
HUBのランプを確認すると正常になっていませんでしょうか?
お礼コメント
whoops101

お礼率 95% (139/146)

本当に何度も有難うございます。
半二重/全二重の説明も有難うございます。

>サイトで確認したのですが、このHUBは、10BASE-TのHUBですね。
はい、そうです。

>お使いのPCのLANカードはたぶん10BASE-T/100BASE-TX自動判定機能が付いてい>ると 勝手に解釈して説明します。
はい、そうです。

1台目のPCの通信モードは、HalfDuplexだったので、
FullDuplexに変えて再起動しましたが、colの点滅は一向におさまらず、
やはりIEを起動するとプロキシの設定を検出・・になって見れません。
2台目の通信モードは、「Auto Detect」というものでしたので、
10BASE-T Full Duplexに変更してみましたが、1台目の状況とかわりませんでした。
何度やってもやはり、点滅状態です。
うむむむ・・・。
投稿日時 - 2001-11-09 03:25:53
  • 回答No.10
レベル13

ベストアンサー率 28% (156/546)

う~ん。 hooさん、urkさん、itohhさん、おまけの私のアドバイスをもってもダメですか・・・ ちょっとここまでの経緯を整理させて下さい。 (話を簡単にするため、2台目のPCはないものとして考えます) 0.TPケーブルは全てストレートケーブル 1.ケーブルモデムとPCを直接LANで繋ぐと問題なし 2.ケーブルモデムとPCの間にHubを介すると通信不可となる 3.但し、この場合にL ...続きを読む
う~ん。
hooさん、urkさん、itohhさん、おまけの私のアドバイスをもってもダメですか・・・

ちょっとここまでの経緯を整理させて下さい。
(話を簡単にするため、2台目のPCはないものとして考えます)

0.TPケーブルは全てストレートケーブル
1.ケーブルモデムとPCを直接LANで繋ぐと問題なし
2.ケーブルモデムとPCの間にHubを介すると通信不可となる
3.但し、この場合にLink LEDは正常であるが、Col LEDがオレンジ色で点灯(点滅ではない?)
4.Hubは10MBps半二重モード(Half Duplex)で動作する(#5のお礼の言葉より)
5.当初1台目のPCの設定はHalf Duplexであった(#6のお礼の言葉より)

以上が私の理解ですが、間違いありませんでしょうか?

で、上記が全て正しいとしたら、PCの通信モードをHalfからFullに設定してはいけないと思います(HubがFullですから)。
また、Hubは10Mらしいのですが、PC側の設定が100M固定ということはないでしょうか?

その他、HubのManualで確認して頂きたいのですが、Col LEDが点灯の場合は、「パーティション」
状態である、と書かれていないでしょうか?
お礼コメント
whoops101

お礼率 95% (139/146)

ありがとうございます。
なんか今までの経緯をまとめて頂いてどうもすみません。
その通りです。

説明書では、colLEDのパターンは2つで、
消灯の場合:コリジョンは発生していません
黄色の場合:コリジョンが発生しています
我が家は黄色です。

PC側の設定が100M固定・・というのは、どこでどのように調べれば良いのでしょうか?
また設定を変更できる方法がありましたら、教えて下さい。
投稿日時 - 2001-11-11 01:19:23
このQ&Aで解決しましたか?
関連するQ&A
-PR-
-PR-
このQ&Aにこう思った!同じようなことあった!感想や体験を書こう
このQ&Aにはまだコメントがありません。
あなたの思ったこと、知っていることをここにコメントしてみましょう。

その他の関連するQ&A、テーマをキーワードで探す

キーワードでQ&A、テーマを検索する
-PR-
-PR-
-PR-

特集


いま みんなが気になるQ&A

関連するQ&A

-PR-

ピックアップ

-PR-
ページ先頭へ