OKWAVEのAI「あい」が美容・健康の悩みに最適な回答をご提案!
-PR-
解決
済み

Xemacsに関する質問

  • 困ってます
  • 質問No.156782
  • 閲覧数23
  • ありがとう数1
  • 気になる数0
  • 回答数1
  • コメント数0

お礼率 84% (106/126)

 今日は、質問です。よろしくお願いします。今Vine Linux2.1を使っています。それでインストールのときXemacsをインストールしなかったので、いまからインストールしようとしているのですが、うまくインストールできません。用意したXemacsはLinux徹底活用ガイドという雑誌(ムックと言うかもしれませんがよくわからないので雑誌と言うことで書いときます。)に付録として付いてきたものです。インストールの方法ですが、tarコマンドで解凍し、./configureをしてmakeを実行しました。これであとは、make installすれば(雑誌に書いてある方法では)インストールが完了となるはずだったのですが、この最後のmake install1が実行してみても「更新されています」と出てよくわかりません。ここで行き詰まって困っています。早くXemacsを使いたいのですが。どなたか解決法をご存知の方、アドバイスお願いします。えっとパソコンの種類はValueStar NXを使っています。Xemacsのバージョンは21.1.14です。よろしくお願いします。
通報する
  • 回答数1
  • 気になる
    質問をブックマークします。
    マイページでまとめて確認できます。

質問者が選んだベストアンサー

  • 回答No.1
レベル9

ベストアンサー率 54% (39/72)

VineだったらVine用のバイナリ(rpmパッケージ)をインストールするか、Vine用のsrpmからビルドするのが簡単だと思うのですが。

元ソースからビルドしたいようなので、

まず、環境変数LANGやLC_ALLなどをCに設定して実行するとどうなりますか?
日本語だとエラーがわかりにくいので。

多分、up to dateとか言われると思うのでそれはインストール先のディレクトリの指定をconfigureしたときにミスしたと思います。

バイナリのインストール先が今コンパイルしているディレクトリになってたりしませんか?

もう一度READMEとか読んでみたら対策が打てるかもしれません。

また、現在のコンパイルしたものが動くかどうか確かめるだけならば、./xemacsとかやったら動くかどうか確かめるのも有意義だと思います。
お礼コメント
kennkenn

お礼率 84% (106/126)

 ご親切なレスありがとうございました。あまりにlinuxの知識に乏しすぎるのでsrpmとか環境変数とかは良くわかりませんでした。環境変数はどっかで読んだのですが、忘れてしまっていました(勉強不足)。そうして、アドバイスの中で自分が出来ることはREADMEを読むことだけだったのですが、あいにく英語版だったので、ほとんど読めませんでした。もうあきらめようと思っていたのですが、ちょっとインターネットでxemacsのことを調べたら、make installするときは、スーパーユーザーになっていなければならない事がわかり、早速実行してみたら、インストールできました(本には解説がついていませんでした。今ごろ言ってもどうしようもないですが。)。と言うことで偶然インストールできたのは、いろいろなご指導のおかげと思います。ありがとうございました。次回はもう少しlinuxの知識を準備しておこうと思っています。
投稿日時 - 2001-10-25 21:08:13
-PR-
-PR-
このQ&Aのテーマ
このQ&Aで解決しましたか?
関連するQ&A
-PR-
-PR-
このQ&Aにこう思った!同じようなことあった!感想や体験を書こう
このQ&Aにはまだコメントがありません。
あなたの思ったこと、知っていることをここにコメントしてみましょう。

その他の関連するQ&A、テーマをキーワードで探す

キーワードでQ&A、テーマを検索する
-PR-
-PR-
-PR-

特集


いま みんなが気になるQ&A

関連するQ&A

-PR-

ピックアップ

-PR-
ページ先頭へ