OKWAVEのAI「あい」が美容・健康の悩みに最適な回答をご提案!
-PR-
解決
済み

RPM版PostgreSQLのアンインストールについて

  • すぐに回答を!
  • 質問No.156284
  • 閲覧数430
  • ありがとう数0
  • 気になる数0
  • 回答数1
  • コメント数0

お礼率 36% (33/90)

みなさん、こんばんは。
さっそくですが、質問があります。

現在サーバーを構築しているのですが、その中にpostgreSQLを入れて動かしたいのです。

使用OSはRedhat Linux 7.1JのFTP版で、始めからインストールされているpostgreSQLのRPM版をアンインストールして、最新版をインストールし直したいと
思っています。
(最新版はRPMのではなく、postgresql-7.1.3.tar.gzをインストールするつもりです。)

そこで、rpm -eコマンドでpostgreSQLをアンインストールしたいのですが、
postgresql-7.0.3-8とpostgresql-devel-7.0.3-8を削除しようとしても下記の様なエラーが出て、アンインストールできません。

rpm -e postgresql-devel-7.0.3-8 とすると・・・・

 エラー:これらのパッケージを削除すると依存性を破壊します。
 postgresql-devel >= 7.0は perl-DBD-Pg-0.95-1に必要とされています。

rpm -e postgresql-7.0.3-8 とすると・・・

 エラー:これらのパッケージを削除すると依存性を破壊します。
 postgresql = 7.0.3はpostgresql-devel-7.0.3-8に必要とされています。
 postgresqlはphp-pgsql-4.0.4pl1-9に必要とされています。
 libpq.so はperl-DBD-Pg-0.95-1に必要とされています。
 libpq.so はphp-pgsql-4.0.4pl1-9に必要とされています。


いったいどうやったら、削除できるのでしょうか?
どなたか教えてください。
通報する
  • 回答数1
  • 気になる
    質問をブックマークします。
    マイページでまとめて確認できます。

質問者が選んだベストアンサー

  • 回答No.1
レベル9

ベストアンサー率 41% (23/55)

初めまして、tefuronさん。

”改訂第3版”PCUNIXユーザーのための
PostgeSQL完全攻略ガイド
技術評論社

上記の本19頁にRPMの削除順序が載っています。
もしよかったら参考にしてください。
-PR-
-PR-
このQ&Aで解決しましたか?
関連するQ&A
-PR-
-PR-
このQ&Aにこう思った!同じようなことあった!感想や体験を書こう
このQ&Aにはまだコメントがありません。
あなたの思ったこと、知っていることをここにコメントしてみましょう。

その他の関連するQ&A、テーマをキーワードで探す

キーワードでQ&A、テーマを検索する
-PR-
-PR-
-PR-

特集


いま みんなが気になるQ&A

関連するQ&A

-PR-

ピックアップ

-PR-
ページ先頭へ