OKWAVEのAI「あい」が美容・健康の悩みに最適な回答をご提案!
-PR-
解決
済み

インターネットエクスプローラとネットスケープナビゲーターのどちらがよいのでしょうか…?

  • すぐに回答を!
  • 質問No.152625
  • 閲覧数156
  • ありがとう数5
  • 気になる数0
  • 回答数4
  • コメント数0

お礼率 83% (5/6)

教えてください!
皆さんにお聞きしたいのですが、私はjava関係の開発をする会社に入社したので、パソコンで勉強しようと思うのですが、アプレットが表示されません。きっと、Virtual Machineがないのだろうと思い、パソコンに以前から入っていた、IE5.5のコンポーネントを追加しようと思いコントロールパネルを立ち上げてみたのですが、項目の中にIEの項目がなく、以前質問したときに、DLを使ってVirtualMachineをインストールする方法というのがあるということで、試してみようとしたのですが、方法がよくわからず、今度はアップデートをして見たのですが、VMが追加されたのかどうかわからず、いくらやっても、IEプラウザでアプレットを表示することが出来ませんでした。そして、悩んだ末、ネットスケープナビゲータ6をインストールし、設定も自動的に行われ、●●.htmlと言うファイルのアイコンはネットスケープに変わっていました。しかし、会社に行くと、「ネットスケープはマイクロソフトに接続しないよ」という言葉を与えられ、動揺しています。ネットスケープをインストールしたら、すぐにアプレットを見ることが出来ました。でも、ネットスケープを使用する人はIEよりも多いと聞いていたのですが、もしかして間違いなのでしょうか・・・。ホームページを作成したり、いろいろと勉強をしていきたいのですが、IEを使用しなくなったことについて何か、問題や違いはありますか?
通報する
  • 回答数4
  • 気になる
    質問をブックマークします。
    マイページでまとめて確認できます。

質問者が選んだベストアンサー

  • 回答No.2
レベル11

ベストアンサー率 53% (199/370)

趣旨がいまいち理解できず申し訳ないのですが、

・まともにリリースするページならば、マイナーなブラウザならば切り捨ててよい、ということにはならないので、ある程度メジャーなブラウザすべてに対応する必要がある。さらに、現実問題としてInternetExplorerのシェアが圧倒的(8割強と思ってください)なので、デファクトスタンダードはNetscapeではなくInternetExplorerである

・Netscape4.xはJVMの問題でブラウザ起動後初めてアプレットなどを起動するときにJVMの起動に数分かかるため、Netscape使いからはアプレットは嫌われがち。

>しかし、会社に行くと、「ネットスケープはマイクロソフトに接続しないよ」という
Netscapeを使用したままhttp://www.msn.ne.jp/に接続してみてください。

>でも、ネットスケープを使用する人はIEよりも多いと聞いていたのですが
何年前のことでしょうか?
確かに、ブラウザのバージョンが2.0とかの時代はIEの利用者などまだまだ少数派だったのは事実ですが、状況は常に変わっていますので。
現在は、WindowsのみならずMacでもかなりそのシェアを延ばしているはずです。
UNIX系OSのみをターゲットにするのならば話は別かもしれませんが、家庭用のPCからのアクセスを考えた場合、むしろ少数派はNetscape利用者です。
現在ならばInternetExplorer5.02、5.5、NetscapeNavigater4.xあたりに対応できるページを作るのが最低条件じゃないでしょうか?
今からの開発となるとさらにIE6.0、NN6.xへの対応も必須でしょうね。

そんな感じで、基本的にInternetExplorerを切り捨てて開発を行うのはどう考えてもむちゃくちゃだと思いますが。
補足コメント
shinco

お礼率 83% (5/6)

ありがとうございます。でもどうしよう・・・。デフォルトに設定してしまいました。ネットスケープを。
投稿日時 - 2001-10-17 12:17:08
-PR-
-PR-

その他の回答 (全3件)

  • 回答No.1
レベル12

ベストアンサー率 25% (243/949)

NetscapeブラウザとIEは基本的には同じです。 しかしJavaScriptで一部互換性がなく、IEで作動しても Netscapeで作動しないものがあるようです。 その他、タグの細かい解釈でも微妙に食い違っています。 用途によってNetscapeとIEを使い分ければ済む話でしょう。 >「ネットスケープはマイクロソフトに接続しないよ」 そんなわけないでしょ。 WindowsU ...続きを読む
NetscapeブラウザとIEは基本的には同じです。
しかしJavaScriptで一部互換性がなく、IEで作動しても
Netscapeで作動しないものがあるようです。
その他、タグの細かい解釈でも微妙に食い違っています。
用途によってNetscapeとIEを使い分ければ済む話でしょう。

>「ネットスケープはマイクロソフトに接続しないよ」

そんなわけないでしょ。
WindowsUpdateは接続できないですがね。

>ネットスケープを使用する人はIEよりも多いと聞いていた

現在では間違いです
元々、Netscapeが広く使われていたのですが、
ところがちょうどインターネットが爆発的に普及しだした頃、
IE3が出現し、無料&プリインストールの手軽さから
初心者を中心に一気にシェアが拡大してきました。
その後、Netscapeも無料化に踏み切り、シェア縮小を食い止めようと
しましたが、OSに最初から組みこまれているIEとは勝負にならず
ブラウザ戦争に敗れたNetscapeがAOLに買収され、
ブラウザの開発が止まってしまったことで一気にIEの独壇場になりました。
Netscape6が出ましたが、やたら使いにくく、現在でもNetscape4を
使用している人が多いと思います。

わたしは現在IE6を使用していますが、基本的にはNetscape派です。
お礼コメント
shinco

お礼率 83% (5/6)

ありがとうございます。皆様から頂いた意見を参考にしたとこら、Naodon1020さんが言われたように使い分ける方法で行きたいと思います!!ありがとうございました!!
投稿日時 - 2001-10-17 13:19:15

  • 回答No.3
レベル11

ベストアンサー率 53% (199/370)

>>「ネットスケープはマイクロソフトに接続しないよ」 No.1様>そんなわけないでしょ。 No.1様>WindowsUpdateは接続できないですがね。 microsoftのホームページの閲覧は可能ですが、Microsoftのインターネット情報サイトであるMSNは、今月頭のリニューアル以降、InternetExplorer4.0以上のブラウザでなくては入室できなくな ...続きを読む
>>「ネットスケープはマイクロソフトに接続しないよ」
No.1様>そんなわけないでしょ。
No.1様>WindowsUpdateは接続できないですがね。

microsoftのホームページの閲覧は可能ですが、Microsoftのインターネット情報サイトであるMSNは、今月頭のリニューアル以降、InternetExplorer4.0以上のブラウザでなくては入室できなくなっています。
http://www.msn.ne.jp/
に接続しようとしたブラウザがこの条件を満たしておらず、かつMSNExplorerでも、WindowsCEからのアクセスでもない場合はInternetExplorerかMSNExplorerをダウンロード、インストールするように促すページにとばされます。
お礼コメント
shinco

お礼率 83% (5/6)

すばやい解答ありがとうございます。なにか大きく間違えていたようです。でも。また、IEを入れなおすことをしなければなりませんね。アプレットが見れて喜んでいるだけでは駄目ですね・・・。
開発の時はネットスケープ。普通の時がIEという風に2つ使用することが出来たら、いいのに・・・。
投稿日時 - 2001-10-17 12:16:33
  • 回答No.4
レベル14

ベストアンサー率 24% (612/2465)

各ブラウザで、対応するVMのバージョンが異なります。 少し前に調べた情報ですが参考にしてください。 IE6はまだ調べていません。 Netscape 4.75Java VM Netscape Communications Corporation 1.1.5 Netscape 6.1Java VM Sun Microsystems Inc. 1.3.0_0 InternetExplorer5.01S ...続きを読む
各ブラウザで、対応するVMのバージョンが異なります。
少し前に調べた情報ですが参考にしてください。
IE6はまだ調べていません。
Netscape 4.75Java VM Netscape Communications Corporation 1.1.5
Netscape 6.1Java VM Sun Microsystems Inc. 1.3.0_0
InternetExplorer5.01SP2Java VM Microsoft Corp. 1.1.4121212121
InternetExplorer5.5Java VM Microsoft Corp. 1.1.4

このことからも解るように、NN6.1向けに開発すると他のブラウザでは参照できません。
VM1.1.4程度で動作するものを開発するのが望ましいでしょう。
しかし、先をにらんで1.2以前は切り捨てるという考えもあるかもしれません。

今後を考えると、IEよりはNetscape向けがよいのではないでしょうか。XP以降MicrosoftはJAVAを切り捨てますから。

VisualCafe等のJAVA開発ソフトに入っているサンプルは、IE、NN、NCのバージョンにより同等のVMであっても動作するものと、しないものがあります。
お礼コメント
shinco

お礼率 83% (5/6)

ありがとうございます!どうも、IEの仕様を理解できません。ネットスケープが速度がのろいとか、どういうことがないのなら、ネットスケープを使用していこうかと思ってます。ありがとうございました(^-^)/
投稿日時 - 2001-10-17 13:12:22
このQ&Aで解決しましたか?
関連するQ&A
-PR-
-PR-
このやり方知ってる!同じこと困ったことある。経験を教えて!
このQ&Aにはまだコメントがありません。
あなたの思ったこと、知っていることをここにコメントしてみましょう。

その他の関連するQ&A、テーマをキーワードで探す

キーワードでQ&A、テーマを検索する
-PR-
-PR-
-PR-

特集


いま みんなが気になるQ&A

関連するQ&A

-PR-

ピックアップ

-PR-
ページ先頭へ