OKWAVEのAI「あい」が美容・健康の悩みに最適な回答をご提案!
-PR-
解決
済み

APACHEとTOMCAT連携が上手く行きません。(mod_jserv.so)

  • 困ってます
  • 質問No.112495
  • 閲覧数114
  • ありがとう数1
  • 気になる数0
  • 回答数2
  • コメント数0

お礼率 57% (27/47)

Redhat7.1でapache(1.3.12)とtomcat(3.2.3)の連携を行っていますが、ファイルクラッシュ?エラーメッセージが出てしまいます。
モジュールはjakartaサイトからダウンロードしてきました。
詳細は---
/etc/rc.d/init.d/httpd start
Starting httpd: [日付] [warn]Loaded DSO libexec/mod_jserv.so uses plain Apache 1.3 API,
this module might crash under EAPI!
(please recompile it with -DEAPI)
    [OK]
------
と表示されます。
”再度DEAPIと一緒にコンパイルしろ”と云う事なのでしょうが、ディレクトリ内を幾ら探してもそれらしいファイルは見つかりません。
[OK]が出ていると云う事は、上記以外は通っている事なのでしょうか?[FAILED]なら解りますが・・・。
どの様に復旧させれば良いのか、皆目見当が付きません。
ご存知の方、是非ご指導の程宜しくお願い申し上げます。
因みに、TOMCAT単体では稼動します。
通報する
  • 回答数2
  • 気になる
    質問をブックマークします。
    マイページでまとめて確認できます。

質問者が選んだベストアンサー

  • 回答No.1
レベル12

ベストアンサー率 43% (280/638)

いつも、お節介で、回答を書いていますが、回答したあとで、とんちんかんなアドバイスではなかった、間違ったことを言ってしまったのではいか、後悔しています。世間には、「何を言っているの?馬鹿な、いいかげんなことを言って」と、冷ややかな見方をされる方もおいでですが、困っているときはお互いさまです。

お答えする前には、少なからずそれなりの実機でのテストで、ある程度の確認をしてお答えしていますが、最近のApacheの経験がないので、アドバイスにあまり期待しないでください。
コンパイル済みのApacheが、使用しているLinuxでは、ダウンロードどした状態では使用できないようです。

エラーメッセージの内容は、DSO(Dynamic Shared Object) libexec/mod_jseerv.so(ソース・オブジェクト)が、plain(通常の)Apache1.3 APIを使用しているので、EAPI(Extended Applicaction Interface)のところで、クラシュしていることを表示しています。そのために、DEAPI-多分EPAIをDisableして、再度コンパイルすることを指示しています。多分、makeする際の、Makefileの定義のところだとは思いますが、どこかは、特定できません。
もし、場所がわかりましたら、再度、アップしましょう。

Apacheが起動したら、php言語ですね!

それでは、ご健闘を祈ります。

hogehoge ojin
-PR-
-PR-

その他の回答 (全1件)

  • 回答No.2
レベル12

ベストアンサー率 43% (280/638)

まとめてみると、 1.TOMCATは動作している。 2.Apache 1.3.12 DSOサポートバージョン   DSOサポートバージョンを使用しないとTOMCATとの連携はうまく行かない。 3.JServerを有効にする。   mod_jserv.soが存在することは、JServerを有効にしたとは思いますが。 4.ApacheとJServerを利用する。 次のURLを、是非参照し ...続きを読む
まとめてみると、

1.TOMCATは動作している。
2.Apache 1.3.12 DSOサポートバージョン
  DSOサポートバージョンを使用しないとTOMCATとの連携はうまく行かない。
3.JServerを有効にする。
  mod_jserv.soが存在することは、JServerを有効にしたとは思いますが。
4.ApacheとJServerを利用する。

次のURLを、是非参照してください、必ず成功すると思います。
じつは、ojinも初めての経験でした。

URL:http://home7.highway.ne.jp/dayan/tips/unix/tomcat.html
極めて親切に記載されています。

では、ご健闘をいのります。

hogehoge ojin
お礼コメント
trinityr

お礼率 57% (27/47)

ojinさん何時も恐縮です。(実はご回答戴けるのを期待しています・・・。)
投稿してから、自分でもイロイロNet上を探し回り試してみました。(OS入れなおし3回・fmt1回)
矢張りコンパイルエラーだったみたいです。後、何度か上書きしている内に見えない部分でぶつかっていたみたいです。(シロウト判断ですが。)
結局、FMTした後に”これだ!”と思う組み合わせで設定したら、何とか連携できた次第です。(今朝繋がったばかりです。トホホ・・・)
今後とも、宜しくお願い申し上げます。
因みに、組み合わせが関係あるのか解りませんが、以下の環境で稼動しました。
----------------
OS:RedHat7.1
JDK:jdk-1.3.1
TOMCAT:jakarta-3.1.1
APACHE:Ver1.3.19(デフォルト)
POSTGRESQL:pgsql-7.1.1
----------------
有難うございました。
投稿日時 - 2001-08-03 17:35:33


このQ&Aで解決しましたか?
-PR-
-PR-
このQ&Aにこう思った!同じようなことあった!感想や体験を書こう
このQ&Aにはまだコメントがありません。
あなたの思ったこと、知っていることをここにコメントしてみましょう。

その他の関連するQ&A、テーマをキーワードで探す

キーワードでQ&A、テーマを検索する
-PR-
-PR-
-PR-

特集


いま みんなが気になるQ&A

-PR-

ピックアップ

-PR-
ページ先頭へ